Pacote de Compatibilidade

Visão geral

A comunicação interativa é a abordagem padrão e recomendada para criar comunicações com clientes no AEM Forms 6.5. Para continuar usando cartas no AEM Forms 6.5, é necessário instalar o pacote de compatibilidade do AEMFD mais recente.

O pacote de compatibilidade do AEMFD também permite usar os seguintes ativos do AEM Forms 6.4, 6.3 e 6.2 no AEM Forms 6.5:

  • Fragmentos de documento
  • Cartas
  • Dicionários de dados
  • Modelos e páginas obsoletas de formulários adaptáveis

Para obter mais informações, consulte Ativos compatíveis com o AEM Forms 6.5 instalando o pacote de Compatibilidade.

Adicionar suporte para os ativos AEM Forms 6.4, 6.3 e 6.2 no AEM Forms 6.5

Depois de executar uma atualização, faça o seguinte para instalar o pacote de compatibilidade do AEMFD e tornar seus ativos compatíveis com o 6.5:

Certifique-se de ter AEM pacote de compatibilidade pré-instalado.

  1. Instale o pacote de compatibilidade mais recente 6.5 e .

    Para obter mais informações sobre como fazer upload e instalar o pacote, consulte Como trabalhar com pacotes.

  2. Depois que os logs forem estabilizados, reinicie o servidor.

  3. Use o utilitário de migração para tornar seus ativos compatíveis com a 6.5.

    Para obter mais informações, consulte utilitário de migração.

Ativos compatíveis com o AEM Forms 6.5 ao instalar o pacote Compatibilidade

Ao instalar o pacote de Compatibilidade, você pode tornar os seguintes ativos e modelos compatíveis com o AEM Forms 6.5:

  • Ativos de gerenciamento de correspondência da AEM 6.4 e anteriores:

  • Modelos de formulário adaptável obsoleto:

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrollmentTemplate
    • /libs/fd/af/templates/simpleEnrollmentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrollmentTemplate
    • /libs/fd/af/templates/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate2
  • Páginas obsoletas para formulários adaptáveis:

    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment

Nesta página