AEM Forms 앱 문제 해결

이 문서에서는 AEM Forms 앱을 빌드하는 동안 표시될 수 있는 오류 메시지와 이를 해결하는 단계를 설명합니다.

이 문서의 섹션에는 다음이 포함됩니다.

iOS 사용자에 대한 첨부 파일 손실

OSGi에서 AEM Forms과 동기화하도록 구성된 iOS용 AEM Forms 앱은 필드 수준 첨부 파일만 지원합니다. 모든 첨부 파일의 이름은 고유해야 합니다. 여러 첨부 파일의 이름이 동일한 경우 하나의 첨부 파일만 유지되며 동일한 이름의 다른 첨부 파일은 모두 손실됩니다. iOS 장치의 사용자에게 데이터 손실이 발생하지 않도록 하려면 다음 단계를 수행하십시오.

  1. 연결된 서버에서 Adobe Experience Manager > 도구 > 작업 > 웹 콘솔​로 이동합니다.

  2. 적응형 양식 및 대화형 통신 웹 채널 구성​을 찾아 클릭합니다.

  3. 적응형 양식 및 대화형 통신 웹 채널 구성 대화 상자에서 파일 이름을 고유한 이름으로 만들기​를 활성화합니다.

    파일 이름을 고유하게 만들기 설정이 비활성화되면 사용자가 여러 첨부 파일이 있는 적응형 양식을 제출하려고 하면 데이터가 손실됩니다.

  4. 저장​을 클릭합니다.

작업 공간 사용자가 제출한 HTML5 양식 초안이 포털에 표시되지 않습니다

초안으로 저장 HTML 렌더링 프로필과 함께 AEM Forms 앱에서 활성화된 HTML5 양식의 경우 저장된 초안이 작업 공간 사용자에게 표시되지 않습니다. 포털에서 작업 공간 사용자가 제출한 HTML5 양식의 저장된 초안을 보려면 다음 단계를 수행하십시오.

  1. CRXDE를 열고 관리자 자격 증명으로 로그인합니다.

    URL: https://<server>:<port>/lc/crx/de/index.jsp

  2. CRXDE의 루트 경로에서 액세스 제어 아래의 액세스 제어 목록에서 + 를 클릭합니다.

  3. 새 항목 추가 대화 상자에서 주도자 필드에 있는 그룹 검색 단추를 클릭합니다.

  4. 주도자 선택 대화 상자의 이름 필드에 PERM_WORKSPACE_USER을 입력하고 검색​을 클릭합니다.

  5. 주도자 선택 대화 상자에서 PERM_WORKSPACE_USER 그룹을 선택하고 확인​을 클릭합니다.

  6. 새 항목 추가 대화 상자의 주도자 필드에서 PERM_WORKSPACE_USER 그룹이 선택됩니다.

    사용자 그룹에 대해 jcr:read 권한을 활성화합니다.

  7. 확인​을 클릭합니다.

HTML5 양식(캐시되지 않음)을 AEM Forms 앱에서 로드하지 못했습니다

AEM Forms 앱이 이전 버전의 AEM Forms 서버에 연결되어 있으면 캐싱되지 않은 HTML5 양식을 AEM Forms 앱에서 로드할 수 없습니다.

문제를 해결하려면 다음 단계를 수행하십시오.

  1. 작성자 인스턴스에서 Adobe Experience Manager > 도구 > Workspace 앱 오프라인 서비스 구성 > 지금 구성​으로 이동합니다.

  2. 작업 공간 앱 오프라인 서비스 페이지에서 수동 리소스 캐시​를 클릭합니다.

    URL:https://<server>:<port>/libs/fd/workspace-offline/content/config.html

  3. 수동 리소스 캐시 탭에서 + 단추를 클릭하여 CRX 경로를 추가합니다.

  4. 새 리소스 추가 필드에 다음을 입력합니다./etc.clientlibs/fd/xfaforms/I18N/en_US.js 을 클릭하고 추가​를 클릭합니다.

  5. 저장​을 클릭합니다.

AEM Forms이 Windows에서 동기화되지 않음

Windows의 AEM Forms 앱에서 양식 또는 해당 리소스의 경로가 256자보다 크거나 같은 경우 양식이 연결된 서버와 동기화되지 않습니다.

양식 및 해당 리소스의 경로를 수정하여 문자 수를 256자 미만으로 줄입니다.

지원되지 않는 버전의 Gradle

오류 메시지: 프로젝트에서 지원되지 않는 버전의 Gradle을 사용하고 있습니다.

Android Studio에서 AEM Forms 앱을 빌드하면 오류 메시지가 표시됩니다. 시스템에서 지원되는 Gradle 버전이 지원되지 않아 문제가 발생합니다.

해결 방법: Fix Gradle 래퍼 를 클릭하고 프로젝트 를 다시 가져와 문제를 해결하십시오.

gradle_unsupported_version

Gradle 및 Android Gradle 플러그인 호환성 문제

오류 메시지: Android Gradle 플러그인 및 Gradle 버전은 호환되지 않습니다.

Android Studio 사용자 인터페이스의 빌드 메뉴에서 빌드 APK 옵션을 선택하면 오류 메시지가 표시됩니다.

gradle_plugin_compatibility

해결 방법: Gradle Scripts > gradle-wrapper. properties 파일을 열고 ​distributionUrlproperty를 편집합니다.

예를 들어 Android Studio 콘솔에서는 Gradle 버전을 3.5로 다운그레이드하는 것이 좋습니다. distributionUrl of gradle-wrapper.properties 파일에서 버전을 편집합니다.

빌드 > 빌드 APK​를 다시 선택하여 오류를 해결하고 .apk 파일을 생성합니다.

gradle_wrapper_properties

이 페이지에서는