Requisiti tecnici

Adobe supporta Adobe Experience Manager (AEM) sulle piattaforme come descritto nelle seguenti informazioni in questo documento.

Per eventuali problemi relativi alla piattaforma, contattate il fornitore della piattaforma.

Nota

A seconda della piattaforma su cui installate AEM, potrebbero essere presenti diversi set di requisiti per la gestione degli utenti.

Prerequisiti

Requisiti minimi per l’installazione di Adobe Experience Manager:

  • Piattaforma Java installata, JDK Standard Edition o altre macchine virtuali Java supportate
  • file Quickstart Experience Manager (JAR indipendente o WAR per la distribuzione di applicazioni Web)

Requisiti minimi di dimensionamento

Requisiti minimi per l’esecuzione di Adobe Experience Manager:

  • 5 GB di spazio libero su disco nella directory di installazione
  • 2 GB di memoria
Nota

Per ulteriori informazioni, consultate le linee guida sul ridimensionamento dell'hardware.

Livelli di supporto

In questo documento sono elencate le piattaforme client e server supportate per Adobe Experience Manager. Adobe offre diversi livelli di supporto, sia per le configurazioni consigliate che per altre configurazioni.

Configurazioni supportate

Adobe consiglia queste configurazioni e fornisce supporto completo nell'ambito del contratto standard di manutenzione del software.

Livello di supporto Descrizione
A: Supportato Adobe fornisce supporto e manutenzione completi per questa configurazione. Questa configurazione è coperta processo garanzia della qualità.
R: Supporto limitato Per garantire il successo del progetto dei nostri clienti, Adobe fornisce supporto completo nell'ambito di un programma di supporto limitato, che richiede il rispetto di condizioni specifiche. Il supporto a livello R richiede una richiesta formale del cliente e una conferma da parte Adobe. Per ulteriori informazioni, contatta Assistenza clienti di Adobe.

Configurazioni non supportate

Livello di supporto Descrizione
Z: Non supportato La configurazione non è supportata. Adobe non fornisce alcuna istruzione sul funzionamento della configurazione e non la supporta.

Piattaforme supportate

Java Virtual Machines

L'applicazione richiede l'esecuzione di una macchina virtuale Java, fornita dalla distribuzione Java Development Kit (JDK).

Adobe Experience Manager funziona con le seguenti versioni di Java Virtual Machines:

ATTENZIONE

Si consiglia di tenere traccia dei bollettini sulla sicurezza dal fornitore Java per garantire la sicurezza degli ambienti di produzione e installare gli aggiornamenti Java più recenti.

Platform Livello di supporto
Oracle Java SE 12 JDK [1] Z: Non supportato
Oracle Java SE 11 JDK - 64 bit A: Supportato
Oracle Java SE 10 JDK [1] Z: Non supportato
Oracle Java SE 9 JDK [1] Z: Non supportato
Oracle Java SE 8 JDK - 64 bit A: Supportato [3]
VM IBM J9 - build 2.9, JRE 1.8.0 [2] A: Supportato
VM IBM J9 - build 2.8, JRE 1.8.0 [2] A: Supportato
  1. Oracle è passato al modello “Long Term Support” (LTS) per i prodotti Oracle Java SE. Java 9, Java 10, and Java 12 are non-LTS releases by Oracle (see Oracle Java SE support roadmap). Per distribuire AEM in ambiente di produzione, Adobe fornisce supporto solo per le release LTS di Java.

  2. IBM JRE è supportato solo insieme a WebSphere Application Server.

  3. Il supporto e la distribuzione di Oracle Java SE JDK, compresi tutti gli aggiornamenti di manutenzione delle release LTS oltre la fine degli aggiornamenti pubblici, saranno supportati da Adobe direttamente per tutti AEM clienti che utilizzano la tecnologia Oracle Java SE. Per ulteriori informazioni, vedere il supporto Oracle Java per le domande e risposte di Adobe Experience Manager.

Storage e persistenza

Esistono diverse opzioni per distribuire l'archivio di Adobe Experience Manager. Vedere l'elenco seguente per le tecnologie supportate e le opzioni di storage.

Platform Descrizione Livello di supporto
File system con file TAR [1] Archivio A: Supportato
File system with Datastore [1] Binari A: Supportato
Archiviare i file binari nei file TAR sul file system [1] Binari Z: Non supportato per la produzione
Amazon S3 Binari A: Supportato
Archiviazione BLOB di Microsoft Azure Binari A: Supportato
MongoDB Enterprise 4.0 Archivio A: Supportato [2, 3]
MongoDB Enterprise 3.6 Archivio Z: Non supportato
MongoDB Enterprise 3.4 Archivio Z: Non supportato
IBM DB2 10.5 Repository e database Forms R: Supporto limitato [4]
Oracle Database 12c (12.1.x) Repository e database Forms R: Supporto limitato
Microsoft SQL Server 2016 Database Forms A: Supportato
Apache Lucene (Introduzione rapida) Servizio di ricerca A: Supportato
Apache Solr Servizio di ricerca A: Supportato
  1. Il file system include l'archiviazione a blocchi conforme con POSIX. Ciò include la tecnologia di storage in rete. Tenere presente che le prestazioni del file system potrebbero variare e influenzare le prestazioni complessive. Si consiglia di caricare AEM di prova in combinazione con il file system di rete/remoto.
  2. Lo Shopping MongoDB non è supportato in AEM.
  3. MongoDB Storage Engine WiredTiger è supportato solo.
  4. Supportato per clienti AEM Forms. Non supportato per le nuove installazioni.
Nota

Consultate Distribuzione di community per ulteriori informazioni sulla funzionalità di AEM Communities .

Nota

MongoDB è un software di terze parti e non è incluso nel pacchetto di licenze AEM. Per ulteriori informazioni, vedere la pagina relativa ai criteri di licenza MongoDB.

Per ottenere il massimo dalla distribuzione AEM con MongoDB, Adobe consiglia di concedere in licenza la versione Enterprise di MongoDB per beneficiare del supporto professionale. Per ulteriori informazioni, consultate Implementazioni consigliate.

La licenza include un set di repliche standard, composto da una delle istanze primarie e due secondarie che possono essere utilizzate per l'autore o per le distribuzioni di pubblicazione.

Se si desidera eseguire sia l'autore che la pubblicazione su MongoDB, è necessario acquistare due licenze separate.

Assistenza clienti di Adobe assisterà i problemi di qualificazione relativi all'utilizzo di MongoDB con AEM.

Per ulteriori informazioni, vedere la pagina MongoDB per Adobe Experience Manager.

Nota

I database relazionali supportati elencati sopra sono software di terze parti e non sono inclusi nel pacchetto di licenze AEM.

Per eseguire AEM 6.5 con un database relazionale supportato, è necessario un contratto di assistenza separato con un fornitore di database. Assistenza clienti di Adobe assisterà i problemi di qualificazione relativi all'utilizzo di database relazionali con AEM 6.5.

La maggior parte dei database relazionali sono attualmente supportati all'interno del livello R sul AEM 6.5, che include criteri di supporto e un programma di supporto come indicato nella descrizione di livello R precedente.

Motori Servlet / Server applicazioni

Adobe Experience Manager può essere eseguito come server autonomo (il file JAR di avvio rapido) o come applicazione Web all'interno di un server applicazione di terze parti (il file WAR).

Versione minima dell'API Servlet richiesta è Servlet 3.1

Platform Livello di supporto
Motore Servlet integrato Quickstart (Jetty 9.4) A: Supportato
Oracle WebLogic Server 12.2 (12cR2) Z: Non supportato
IBM WebSphere Application Server Continuous Delivery (LibertyProfile) con profilo Web 7.0 e IBM JRE 1.8 R: Sostegno limitato per i nuovi contratti [2]
IBM WebSphere Application Server 9.0 e IBM JRE 1.8 R: Sostegno limitato per i nuovi contratti [1] [2]
Apache Tomcat 8.5.x R: Sostegno limitato per i nuovi contratti [2]
JBoss EAP 7.2.x con Application Server JBoss Z: Non supportato
JBoss EAP 7.1.4 con Application Server JBoss R: Sostegno limitato per i nuovi contratti [1] [2]
JBoss EAP 7.0.x con Application Server JBoss Z: Non supportato
  1. Consigliato per le distribuzioni con AEM Forms.
  2. L'avvio AEM distribuzioni 6.5 sui server applicazioni consente di passare al supporto limitato. I clienti esistenti possono effettuare l'aggiornamento a AEM 6.5 e continuare a utilizzare i server delle applicazioni. Per i nuovi clienti è dotato di criteri di supporto e di un programma di supporto come indicato nella descrizione di livello R precedente.

Sistemi operativi server

Adobe Experience Manager funziona con le seguenti piattaforme server per gli ambienti di produzione:

Platform Livello di supporto
Linux, basato sulla distribuzione Red Hat A: Supportato [1] [3]
Linux, basato sulla distribuzione Debian incl. Ubuntu A: Supportato [2]
Linux, basato sulla distribuzione SUSE A: Supportato
Microsoft Windows Server 2019 [4] R: Sostegno limitato per i nuovi contratti
Microsoft Windows Server 2016 [4] R: Sostegno limitato per i nuovi contratti [5]
Microsoft Windows Server 2012 R2 Z: Non supportato
Oracle Solaris 11 Z: Non supportato
IBM AIX 7.2 Z: Non supportato
  1. Linux Kernel 2.6, 3.x e 4.x include derivati dalla distribuzione Red Hat, tra cui Red Hat Enterprise Linux, CentOS, Oracle Linux e Amazon Linux. funzioni aggiuntive di AEM Forms sono supportate solo su CentOS 7 e Red Hat Enterprise Linux 7.
  2. AEM Forms è supportato solo su Ubuntu 16.04 LTS
  3. Distribuzione Linux supportata da Adobe Managed Services
  4. Le distribuzioni di produzione di Microsoft Windows sono supportate per i clienti che effettuano l'aggiornamento alla versione 6.5 e per l'utilizzo in modalità non di produzione. Le nuove distribuzioni sono su richiesta per AEM Sites e Assets.
  5. AEM Forms è supportato su Microsoft Windows Server senza le restrizioni del livello di supporto R

Ambienti di elaborazione virtuali e cloud

Adobe Experience Manager è supportato in esecuzione in una macchina virtuale in ambienti cloud computing, come Microsoft Azure e Amazon Web Services (AWS), in conformità ai requisiti tecnici elencati in questa pagina e in base termini di supporto standard del Adobe.

Adobe consiglia di utilizzare Adobe Managed Services per distribuire AEM in Azure o AWS. Adobe Managed Services offre agli esperti esperienza e competenze per la distribuzione e il AEM operativo in questi ambienti cloud computing. Consulta la documentazione aggiuntiva sui servizigestiti Adobe.

In tutti gli altri casi di implementazione di AEM in Azure o AWS, o in qualsiasi altro ambiente cloud computing, il supporto da Adobe sarà contenuto nell'ambiente di elaborazione virtuale in conformità alle specifiche tecniche elencate in questa pagina. Eventuali problemi segnalati relativi alle AEM in esecuzione in uno di questi ambienti cloud dovranno essere riproducibili indipendentemente da qualsiasi servizio cloud specifico per l'ambiente cloud computing, a meno che il servizio cloud non sia specificamente supportato come parte dei requisiti tecnici elencati in questa pagina, ad esempio archiviazione Azure Blob o AWS S3.

Per raccomandazioni su come distribuire AEM su Azure o AWS, al di fuori dei servizi gestiti di Adobe, Adobe consiglia vivamente di lavorare direttamente con il provider cloud o partner di Adobe che supportano la distribuzione di AEM nell'ambiente cloud di vostra scelta. Il fornitore o il partner cloud selezionato sarà responsabile delle specifiche di dimensionamento, della progettazione e dell'implementazione dell'architettura., per soddisfare i requisiti specifici di prestazioni, carico, scalabilità e sicurezza.

Piattaforme Dispatcher (server Web)

Il Dispatcher è il componente per il caching e il bilanciamento del carico. Scarica la versionepiù recente del dispatcher. Experience Manager 6.5 richiede il dispatcher versione 4.3.2 o successiva.

I seguenti server Web sono supportati per l’utilizzo con Dispatcher versione 4.3.2:

Platform Livello di supporto
Apache httpd 2.4.x [1,2] A: Supportato
Microsoft IIS 10 (Internet Information Server) A: Supportato
Microsoft IIS 8.5 (Internet Information Server) Z: Non supportato
  1. I server Web basati sul codice sorgente httpd Apache avranno lo stesso livello di supporto della versione di httpd su cui si basa. In caso di dubbi, chiedere Adobe la conferma del livello di supporto relativo al rispettivo prodotto server. Seguenti casi:

    1. Il server HTTP è stato creato utilizzando solo le distribuzioni di origine Apache ufficiali, oppure
    2. Il server HTTP è stato distribuito come parte del sistema operativo su cui è in esecuzione. Esempi: IBM HTTP Server, Oracle HTTP Server
  2. Dispatcher non disponibile per Apache 2.4.x per i sistemi operativi Windows.

Piattaforme client supportate

Browser supportati per l’authoring dell’interfaccia utente

L'interfaccia utente di Adobe Experience Manager funziona con le seguenti piattaforme client. Tutti i browser vengono testati con il set predefinito di plug-in e componenti aggiuntivi.

L'interfaccia utente AEM è ottimizzata per schermi più grandi (in genere notebook e computer desktop) e per fattori di forma per tablet (come Apple iPad o Microsoft Surface). Il fattore forma telefono non è supportato.

Nota

Supporto per browser con cicli di rilascio rapidi:

Mozilla Firefox, Google Chrome e Microsoft Edge rilasciano aggiornamenti ogni pochi mesi. Adobe si impegna a fornire aggiornamenti per Adobe Experience Manager per mantenere il livello di supporto come indicato di seguito con le prossime versioni di questi browser.

Browser Supporto per l'interfaccia utente
Supporto per l’interfaccia classica
Google Chrome (Evergreen) A: Supportato A: Supportato
Microsoft Edge (Evergreen) A: Supportato A: Supportato
Microsoft Internet Explorer 11 Z: Non supportato Z: Non supportato
Mozilla Firefox (Evergreen) A: Supportato A: Supportato
Mozilla Firefox ultimo ESR [1] A: Supportato A: Supportato
Apple Safari su macOS (Evergreen) A: Supportato A: Supportato
Apple Safari 11.x su macOS Z: Non supportato Z: Non supportato
Apple Safari su iOS 12.x A: Supportato [2] Z: Non supportato
Apple Safari su iOS 11.x Z: Non supportato Z: Non supportato
  1. Versione estesa di supporto Firefox Ulteriori informazioni su mozilla.org
  2. supporto per Apple iPad

Browser supportati per i siti Web

In genere, il supporto dei browser per i siti Web sottoposti a rendering da AEM Sites dipende dall'implementazione AEM modelli di pagina, dalla progettazione e dall'output di componenti ed è pertanto a controllo dell'implementazione di tali parti.

Client WebDAV

Microsoft Windows 7+

Per connettersi con Microsoft Windows 7+ a un'istanza AEM non protetta con SSL, in Windows deve essere abilitata l'autenticazione di base sulla rete non protetta. Ciò richiede una modifica nel Registro di sistema di Windows del WebClient:

  1. Individuate la sottochiave del Registro di sistema:

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
  2. Aggiungete la voce del Registro di sistema BasicAuthLevel a questa sottochiave con un valore pari o superiore a 2.

Per migliorare la reattività del client WebDav in Windows - vedere Supporto Microsoft KB 2445570

Note aggiuntive sulla piattaforma

Questa sezione contiene note speciali e informazioni più dettagliate sull’esecuzione di Adobe Experience Manager e dei relativi componenti aggiuntivi.

IPv4 e IPv6

Tutti gli elementi di Adobe Experience Manager (Instance, Dispatcher) possono essere installati nelle reti IPv4 e IPv6.

L'operazione è perfetta, in quanto non è necessaria alcuna configurazione speciale. Potete semplicemente specificare un indirizzo IP utilizzando il formato appropriato per il tipo di rete, se necessario.

Ciò significa che, quando è necessario specificare un indirizzo IP, è possibile selezionare (come richiesto) da:

  • un indirizzo IPv6, ad esempio https://[ab12::34c5:6d7:8e90:1234]:4502

  • un indirizzo IPv4, ad esempio https://123.1.1.4:4502

  • un nome server, ad esempio, https://www.yourserver.com:4502

  • il caso predefinito di localhost verrà interpretato per le installazioni di rete IPv4 e IPv6, ad esempio, https://localhost:4502

Requisiti per AEM Dynamic Media Add-on

AEM Contenuti multimediali dinamici è disabilitato per impostazione predefinita. Per abilitare gli elementi multimedialidinamici, consulta la sezione.

Con l’opzione Contenuti multimediali dinamici attivata, sono applicabili i seguenti requisiti tecnici aggiuntivi.

Nota

Questi requisiti di sistema si applicano solo se si utilizza la modalità Dynamic Media - Hybrid; Elemento multimediale dinamico - La modalità ibrida dispone di un server di immagini incorporato, certificato solo in alcuni sistemi operativi.

Per i clienti di Dynamic Media che eseguono Dynamic Media - Modalità Scene7 ( ​cioè, modalità runmode), non sono previsti requisiti di sistema aggiuntivi; solo gli stessi requisiti di sistema AEM. File multimediali dinamici - L’architettura in modalità Scene7 utilizza il servizio basato su cloud e non il servizio incorporato in AEM.

Hardware

I seguenti requisiti hardware sono applicabili sia per Linux che per Windows:

  • CPU Intel Xeon o AMD Opteron con almeno 4 core
  • Almeno 16 GB di RAM

Linux

Se utilizzate Dynamic Media su Linux, è necessario soddisfare i seguenti prerequisiti:

  • RedHat Enterprise 7 o CentOS 7 e versioni successive con patch di correzione più recenti
  • Sistema operativo a 64 bit
  • Scambio disattivato (consigliato)
  • SELinux disabilitato (vedere la nota seguente)
Nota

Se le impostazioni internazionali sono impostate in modo tale che LC_CTYPE non sia uguale a en_US.UTF-8, impedisce il funzionamento di Dynamic Media. Per visualizzare il valore corrispondente al tipo "locale" al prompt dei comandi. Se non è impostato su tale valore, impostare la variabile di ambiente LC_CTYPE sulla stringa vuota digitando "export LC_CTYPE=" prima di eseguire AEM.

Nota

Disattivazione di SELLinux: Image Server non funziona con SELLinux attivato. Questa opzione è attivata per impostazione predefinita. Per risolvere questo problema, modificate il file /etc/selLinux/config e modificate il valore SELLinux da:

SELINUX=enforcing a SELINUX=disabled

Nota

Architettura NUMA: I sistemi con processori con AMD64 e Intel EM64T sono generalmente configurati come piattaforme NUMA (non uniformi Memory Architecture), il che significa che il kernel costruisce più nodi di memoria in fase di avvio anziché costruire un singolo nodo di memoria.

Il costrutto a più nodi può determinare l'esaurimento della memoria su uno o più nodi prima che gli altri si esauriscano. Quando si verifica l’esaurimento della memoria, il kernel può decidere di interrompere i processi (ad esempio, Image Server o Platform Server) anche se è disponibile memoria.

Pertanto, Adobe consiglia che, se si esegue un sistema di questo tipo, si spenga NUMA utilizzando l'opzione numa=off boot per evitare che il kernel uccida questi processi.

Nota

Il nome host del server deve risolvere: Verificate che il nome host del server sia risolvibile in un indirizzo IP. Se ciò non è possibile, aggiungete il nome host completo e l'indirizzo IP agli /etc/hosts:

<ip address> <fully qualified hostname>

Windows

  • Microsoft Windows Server 2016
  • Spazio di scambio pari ad almeno il doppio della quantità di memoria fisica (RAM)

Per utilizzare i contenuti multimediali dinamici in Windows, installare i redistribuibili di Microsoft Visual Studio 2010, 2013 e 2015 per x64 e x86.

Per Windows x64:

Per Windows x86:

MacOS

  • 10.9.x e versioni successive
  • Supportato solo a scopo di prova e demo

Requisiti per AEM Forms PDF Generator

Prodotto

Formati supportati per la conversione in PDF

Acrobat 2017 classic track ultima versione XPS, formati immagine (BMP, GIF, JPEG, JPG, TIF, TIFF, PNG, JPF, JPX, JP2, J2K, J2C, JPC), HTML, HTM, DWG, DXF e DWF
Microsoft® Office 2016 DOC, DOCX, XLS, XLSX, PPT, PPTX, RTF e TXT
WordPerfect X7 WP, WPD
Microsoft® Office Visio 2016
VSD, VSDX
Microsoft® Publisher 2016
PUB
Microsoft® Project 2016
MPP
OpenOffice 4.1.2 ODT, ODP, ODS, ODG, ODF, SXW, SXI, SXC, SXD, XLS, XLSX, DOC, DOCX, PPT, PPTX, formati immagine (BMP, GIF, JPEG, JPG, TIF, TIFF, PNG, JPF, JPX, JP2, J2K, J2C, JPC), HTML, HTM RTF e TXT
Nota

PDF Generator supporta solo versioni in inglese, francese, tedesco e giapponese dei sistemi operativi e delle applicazioni supportati.

Inoltre:

  • PDF Generator richiede la versione a 32 bit di Acrobat 2017 Classic track versione 17.011.30078 o successiva per eseguire la conversione.

  • PDF Generator supporta solo la versione a 32 bit per la vendita al dettaglio di Microsoft Office Professional Plus e di altri software richiesti per la conversione.

  • PDF Generator non supporta Microsoft Office 365.

  • Le conversioni di PDF Generator per OpenOffice sono supportate solo in Windows e Linux.

  • Le funzioni PDF, Optimize PDF e Export PDF OCR sono supportate solo in Windows.

  • Una versione di Acrobat viene fornita con AEM Forms per abilitare la funzionalità PDF Generator. È consigliabile accedere alla versione bundle solo a livello di programmazione con AEM Forms, per tutta la durata della licenza AEM Forms , da utilizzare con AEM Forms PDF Generator. Per ulteriori informazioni, consultate descrizione del prodotto AEM Forms come da distribuzione (locale o Managed Services)"

  • Il servizio PDF Generator non supporta Microsoft Windows 10.

Requisiti per riscrittura dei metadati XMP AEM Assets

XMP riscrittura è supportata e abilitata per le piattaforme e i formati file seguenti:

  • Sistemi operativi:

  • Formati file: JPEG, PNG, TIFF, PDF, INDD, AI ed EPS.

Requisiti per AEM Assets per l'elaborazione di risorse con metadati pesanti su Linux

Il processo XMPFilesProcessor richiede il funzionamento della libreria GLIBC_2.14. Utilizzate un kernel Linux che contiene GLIBC_2.14, ad esempio il kernel Linux versione 3.1.x. Migliora le prestazioni per l’elaborazione di risorse contenenti una grande quantità di metadati, come i file PSD. L'utilizzo di una versione precedente di GLIBC genera un errore nei registri a partire da com.day.cq.dam.core.impl.handler.xmp.NCommXMPHandler Failed to read XMP.

In questa pagina