Utilisation de Maven pour les communautés

Présentation

Cette section de la documentation AEM Communities s'ajoute aux éléments suivants :

Il existe désormais deux artefacts "uber" qui remplacent des artefacts individuels :

Artefact JAR de l'API Communautés

Voici un exemple de GAV pour le fichier JAR de l’API AEM Communities :

<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>

Assurez-vous que la version spécifiée correspond à la version du package Communities installée pour AEM Communities. Pour vérifier le numéro de version installé :

  1. Connectez-vous avec des privilèges d’administration.

  2. Accédez à Package Manager. For example, http://localhost:4502/crx/packmgr/

  3. Recherchez le package : cq-socialcommunities-pkg-1.x.xxx

  4. Extrayez la version du nom du package :

    • La première version de AEM 6.3 est la version 1.11.170.
    • Les packs de fonctionnalités seront des versions 1.12.xxx.
Remarque

Il est recommandé de rester à jour avec la dernière version des communautés.

Consultez la section Dernières versions pour identifier la version la plus récente.

Exemple de dépendance Maven

Le jar de l'API Communautés doit être spécifié avant le jar de l'API Uber.

<dependency>
    <groupId>com.adobe.cq.social</groupId>
    <artifactId>cq-socialcommunities-api</artifactId>
    <version>1.11.170</version>
    <scope>provided</scope>
</dependency>
<dependency>
    <groupId>com.adobe.aem</groupId>
    <artifactId>uber-jar</artifactId>
    <version>6.3.0</version>
    <scope>provided</scope>
    <classifier>apis</classifier>
</dependency>

Sur cette page