Aggiornamento a AEM 6.4 Forms su OSGi

Utilizza uno dei seguenti percorsi di aggiornamento, in base alle esigenze del tuo ambiente.

AEM 6.2 Forms o AEM 6.3 Forms > AEM 6.4 Forms

Puoi eseguire un aggiornamento diretto da AEM 6.2 Forms o AEM 6.3 Forms a AEM 6.4 Forms. Effettua le seguenti operazioni:

  1. Aggiorna l'istanza AEM esistente a AEM 6.4. I passaggi sono elencati di seguito:

    1. Installa il service pack e le patch più recenti per Forms 6.2 o AEM 6.3 Forms. Per ulteriori informazioni, consulta:

    2. Prepara l'istanza sorgente per l'aggiornamento. Per passaggi dettagliati, consulta Aggiornamento a AEM 6.4.

    3. Scarica la AEM 6.4 QuickStart.

    4. (Solo installazioni basate su Unix/Linux) Se utilizzi UNIX o Linux come sistema operativo sottostante, apri la finestra del terminale, accedi alla cartella contenente crx-quickstart ed esegui il seguente comando:

      chmod -R 755 ../crx-quickstart

    5. Aggiorna l'istanza AEM a AEM 6.3. Per istruzioni dettagliate, consulta Aggiornamento a AEM 6.4.

      Prima di continuare con i passaggi successivi, attendi che i messaggi ServiceEvent REGISTERED e ServiceEvent UNREGISTERED smettano di essere visualizzati nel file <crx-repository>/error.log .

      NOTA

      Quando il server è in esecuzione, alcuni bundle AEM Forms rimangono nello stato di installazione. Il numero di bundle può variare per ogni installazione. Puoi tranquillamente ignorare lo stato di questi bundle. I bundle sono elencati in https://[server]:[port]/system/console/.

  2. Installa il pacchetto aggiuntivo di AEM Forms. I passaggi sono elencati di seguito:

    1. Apri Software Distribution. Per accedere a Software Distribution è necessario disporre di un Adobe ID.

    2. Tocca Adobe Experience Manager che si trova nel menu di intestazione.

    3. Nella sezione Filtri :

      1. Seleziona Forms dall'elenco a discesa Soluzione.
      2. Seleziona la versione e digita il pacchetto. Puoi anche utilizzare l'opzione Download di ricerca per filtrare i risultati.
    4. Tocca il nome del pacchetto applicabile al tuo sistema operativo, seleziona Accetta termini EULA e tocca Scarica.

    5. Apri Gestione pacchetti e fai clic su Carica pacchetto per caricarlo.

    6. Seleziona il pacchetto e fai clic su Installa.

      Puoi anche scaricare il pacchetto utilizzando il collegamento diretto elencato nell'articolo Versioni di AEM Forms .

      NOTA

      Una volta installato il pacchetto, viene richiesto di riavviare l'istanza AEM. Non arrestare immediatamente il server. Prima di arrestare il server AEM Forms, attendere che i messaggi ServiceEvent REGISTERED e ServiceEvent UNREGISTERED smettano di apparire nel file <crx-repository>/error.log e il registro sia stabile. Inoltre, alcuni pacchetti possono rimanere nello stato di installazione. Puoi ignorare lo stato di questi pacchetti in tutta sicurezza.

    7. Arresta l’istanza AEM ed elimina i file seguenti:

      • [AEM_Installation_Directory]\[crx-quickstart]\launchpad\ext\bcmail-jdk15-1.35
      • [AEM_Installation_Directory]\[crx-quickstart]\launchpad\ext\bcprov-jdk15-1.35
    8. Avvia l'istanza AEM.

  3. Eseguire attività post-installazione.

    • Esegui utility di migrazione

      L’utility di migrazione rende compatibili con i moduli adattivi e le risorse di gestione della corrispondenza delle versioni precedenti AEM 6.4 forms. È possibile scaricare l'utility da Distribuzione software AEM. Per informazioni dettagliate su come configurare e utilizzare l'utility di migrazione, consulta utility di migrazione.

      Se utilizzi Esempio per integrare il componente per bozze e invii con il database e per l'aggiornamento da una versione precedente, esegui le seguenti query SQL dopo l'esecuzione dell'aggiornamento:

      UPDATE metadata m, additionalmetadatatable am
      SET m.dataType = am.value
      WHERE m.id = am.id
      AND am.key = 'dataType'
      
      DELETE from additionalmetadatatable
      WHERE `key` = 'dataType'
      
    • (Solo per l’aggiornamento da AEM 6.2 Forms o versioni precedenti) Riconfigura Adobe Sign

      Se Adobe Sign era stato configurato nella versione precedente di AEM Forms, riconfigura Adobe Sign dai servizi AEM Cloud. Per ulteriori dettagli, consulta Integrare Adobe Sign con AEM Forms.

    • (Solo per l’aggiornamento da Forms 6.2 o versioni precedenti) Riconfigura analisi e rapporti

      In Forms 6.4 AEM, la variabile di traffico per la sorgente e l’evento di successo per l’impression non sono disponibili. Pertanto, quando esegui l’aggiornamento da AEM 6.2 Forms o versioni precedenti, AEM Forms smette di inviare dati al server Adobe Analytics e i rapporti di analisi per i moduli adattivi non sono disponibili. Inoltre, AEM 6.4 Forms introduce una variabile di traffico per la versione di analisi dei moduli e un evento di successo per la quantità di tempo trascorso su un campo. Quindi, riconfigura analisi e rapporti per il tuo ambiente AEM Forms. Per passaggi dettagliati, consulta Configurazione di analisi e rapporti.

  4. Verificare che il server sia stato aggiornato correttamente, che anche tutti i dati siano migrati correttamente e che possa funzionare normalmente.

    • Verifica lo stato dei bundle: Assicurati che tutti i bundle siano in stato attivo.

    • Verificare la replica e la replica inversa: pubblicare, compilare e inviare alcuni moduli migrati. Verifica anche i dati inviati.

    • Verifica l'accesso alle interfacce utente amministratore e sviluppatore: accedi a AEM'istanza da un account amministratore e verifica di avere accesso ai seguenti URL:

      • https://[server]:[port]/crx/packmgr
      • https://[server]:[port]/crx/de
      • https://[server]:[port]/aem/forms.html/content/dam/formsanddocuments
    NOTA

    In Forms 6.4 AEM, la struttura di crx-repository è cambiata. Dopo aver effettuato l’aggiornamento a AEM moduli 6.4, utilizza i percorsi modificati per la personalizzazione che hai creato nuovamente. Per l’elenco completo dei percorsi modificati, consulta Ristrutturazione dell’archivio Forms in AEM 6.4.

AEM 6.0 Forms e AEM 6.1 Forms > AEM 6.4 Forms

Il percorso di aggiornamento diretto da AEM 6.0 Forms e AEM 6.1 Forms a AEM 6.4 Forms non è disponibile. Esegui un aggiornamento intermedio a AEM 6.2 Forms o aggiornamento a AEM 6.3 Forms e quindi esegui l'aggiornamento da AEM 6.2 Forms o AEM 6.3 Forms a AEM 6.4 Forms.

In questa pagina