安装兼容性包

在AEM Forms6.4上安装兼容性软件包可让您使用AEM Forms6.3中的通信管理资源以及已弃用的自适应表单模板和页面

概述

交互通信是在AEM Forms6.4中创建客户通信的默认和推荐方法。要继续使用AEM 6.3Forms和AEM 6.2Forms的字母,您需要安装 AEMFD兼容性包

AEMFD兼容性软件包允许您在AEM Forms6.3和AEM Forms6.4上使用以下来自AEMFD 6.3和6.2的资源:

  • 在AEM Forms6.3和6.2中创建的文档片段
  • 书信
  • 数据字典
  • 自适应表单已弃用的模板和页面

有关详细信息,请 参阅通过安装兼容性包使资产与AEM Forms6.4兼容

在AEM Forms6.4中增加对AEM Forms6.3和6.2资产的支持

执行升级后,请执行以下操作以安装AEMFD兼容性包并使您的资源与6.4兼容:

确保已预 装AEM Compatibility包。

  1. 安装兼 容性包

    有关上传和安装包的详细信息,请参 阅如何使用包

  2. 日志稳定后,重新启动服务器。

  3. 使用迁移实用程序使您的资源与6.4兼容。

    有关详细信息,请参阅 迁移实用程序

通过安装兼容性包使资源与AEM Forms6.4兼容

通过安装兼容性包,您可以使以下资源和模板与AEM Forms6.4兼容:

  • AEM 6.3及更早版本的通信管理资产

  • 自适应表单已弃用模板

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrommentTemplate
    • /libs/fd/af/templates/simpleEngrommentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrommentTemplate
    • /libs/fd/af/templates/tabbedEnmortmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrommentTemplate
    • /libs/fd/afaddon/templates/advancedEnmortmentTemplate2
  • 自适应表单已弃用的页面:

    • /libs/fd/af/components/page/调查
    • /libs/fd/af/components/page/tabbedrent
    • /libs/fd/afaddon/components/page/advancedenrollment

在此页面上