Installer le package de compatibilité

Dernière mise à jour : 2023-05-04
  • Créé pour :
  • Admin
ATTENTION

AEM 6.4 a atteint la fin de la prise en charge étendue et cette documentation n’est plus mise à jour. Pour plus d’informations, voir notre période de support technique. Rechercher les versions prises en charge here.

L’installation du package de compatibilité sur AEM Forms 6.4 vous permet d’utiliser les actifs Correspondence Management d’AEM Forms 6.3 et les modèles et pages de formulaires adaptatifs obsolètes.

Présentation

La communication interactive est l’approche par défaut et recommandée pour créer des communications client dans AEM Forms 6.4. Pour continuer à utiliser les lettres d’AEM 6.3 Forms et d’AEM 6.2 Forms, vous devez installer le Package de compatibilité AEMFD.

Le package de compatibilité AEMFD vous permet d’utiliser les ressources suivantes d’AEM Forms 6.3 et 6.2 sur AEM Forms 6.4 :

  • Fragments de document créés dans AEM Forms 6.3 et 6.2
  • Lettres
  • Dictionnaires de données
  • Modèles et pages obsolètes de formulaires adaptatifs

Pour plus d’informations, consultez la section Ressources devenues compatibles avec AEM Forms 6.4 après l’installation du package de compatibilité.

Ajout de la prise en charge des ressources AEM Forms 6.3 et 6.2 dans AEM Forms 6.4

Après avoir effectué une mise à niveau, exécutez les opérations suivantes pour installer le package de compatibilité AEMFD et rendre vos actifs compatibles avec la version 6.4 :

Assurez-vous que le package de compatibilité AEM est préinstallé.

  1. Installez le Package de compatibilité.

    Pour plus d’informations sur le téléchargement et l’installation du package, voir Utilisation des packages.

  2. Une fois les journaux stabilisés, redémarrez le serveur.

  3. Utilisez l’utilitaire de migration pour rendre vos actifs compatibles avec la version 6.4.

    Pour plus d’informations, consultez la section Utilitaire de migration.

Actifs devenus compatibles avec AEM Forms 6.4 après l’installation du package de compatibilité

En installant le package de compatibilité, vous pouvez rendre les ressources et les modèles suivants compatibles avec AEM Forms 6.4 :

  • Actifs de Correspondence Management d’AEM 6.3 et versions antérieures

  • Modèles de formulaire adaptatif obsolètes

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrollmentTemplate
    • /libs/fd/af/templates/simpleEnrollmentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrollmentTemplate
    • /libs/fd/af/templates/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate2
  • Pages obsolètes de formulaires adaptatifs :

    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment

Sur cette page