Kompatibilitätspaket installieren

Letzte Aktualisierung: 2023-05-04
  • Erstellt für:
  • Admin
VORSICHT

AEM 6.4 hat das Ende der erweiterten Unterstützung erreicht und diese Dokumentation wird nicht mehr aktualisiert. Weitere Informationen finden Sie in unserer technische Unterstützung. Unterstützte Versionen suchen here.

Durch die Installation des Kompatibilitätspakets auf AEM Forms 6.4 können Sie die Correspondence Management-Assets aus AEM Forms 6.3 und veraltete Vorlagen und Seiten für adaptive Formulare verwenden

Übersicht

Interaktive Kommunikation ist der standardmäßige und empfohlene Ansatz zur Erstellung von Kundenkommunikation in AEM Forms 6.4. Um die Briefe aus AEM 6.3 Forms und AEM 6.2 Forms weiterhin verwenden zu können, müssen Sie die AEMFD-Kompatibilitätspaket.

Mit dem AEMFD-Kompatibilitätspaket können Sie die folgenden Assets aus AEM Forms 6.3 und 6.2 in AEM Forms 6.4 verwenden:

  • Dokumentfragmente, die in AEM Forms 6.3 und 6.2 erstellt wurden
  • Briefe
  • Datenwörterbücher
  • Veraltete Vorlagen und Seiten für adaptive Formulare

Weitere Informationen finden Sie unter Durch Installation des Kompatibilitätspakets mit AEM Forms 6.4 kompatible Assets.

Unterstützung für AEM Forms 6.3- und 6.2-Assets in AEM Forms 6.4 hinzugefügt

Gehen Sie nach der Aktualisierung wie folgt vor, um das AEM-Kompatibilitätspaket zu installieren und Ihre Assets mit Version 6.4 kompatibel zu machen:

Stellen Sie sicher, dass das AEM-Kompatibilitätspaket vorinstalliert ist.

  1. Installieren Sie die Kompatibilitätspaket.

    Weitere Informationen zum Hochladen und Installieren des Pakets finden Sie unter Arbeiten mit Paketen.

  2. Nachdem die Protokolle stabilisiert wurden, starten Sie den Server neu.

  3. Verwenden Sie das Migrationsdienstprogramm, um Ihre Assets mit Version 6.4 kompatibel zu machen.

    Weitere Informationen finden Sie unter Migrationsdienstprogramm.

Durch Installation des Kompatibilitätspakets mit AEM Forms 6.4 kompatible Assets

Durch Installation des Kompatibilitätspakets können Sie die folgenden Assets und Vorlagen mit AEM Forms 6.4 kompatibel machen:

  • Correspondence Management-Assets aus AEM 6.3 und früher

  • Veraltete Vorlagen für adaptive Formulare

    • /libs/fd/af/templates/blankTemplate2
    • /libs/fd/af/templates/simpleEnrollmentTemplate
    • /libs/fd/af/templates/simpleEnrollmentTemplate2
    • /libs/fd/af/templates/surveyTemplate
    • /libs/fd/af/templates/surveyTemplate2
    • /libs/fd/af/templates/tabbedEnrollmentTemplate
    • /libs/fd/af/templates/tabbedEnrollmentTemplate2
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate
    • /libs/fd/afaddon/templates/advancedEnrollmentTemplate2
  • Veraltete Seiten für adaptive Formulare:

    • /libs/fd/af/components/page/survey
    • /libs/fd/af/components/page/tabbedenrollment
    • /libs/fd/afaddon/components/page/advancedenrollment

Auf dieser Seite