JEE上的AEM Forms支持的平台

支持的平台

支持级别

AEM Forms在JEE服务器上的设置可以使用支持的操作系统、应用程序服务器、数据库、数据库驱动程序、JDK、LDAP服务器和电子邮件服务器的任意组合。

此文档列表JEE上AEM Forms支持的客户端和服务器平台。 Adobe为我们的推荐配置和其他配置提供多种支持级别。 文档还会列表其他受支持的软件及其版本、异常、修补程序定义和第三方软件修补程序支持策略。

注意
  • 有关受支持服务器平台的例外的完整列表,请参见受支持服务器平台的例外
  • AEM Forms在JEE上仅支持受支持操作系统和应用程序的英语、法语、德语和日语版本。

建议的配置

Adobe建议这些配置,并作为标准软件维护协议的一部分提供完全或受限的支持:

支持级别 描述
答:支持
Adobe为此配置提供全面支持和维护。 此配置由Adobe的质量保证流程涵盖。
R:受限支持 Adobe在满足特定先决条件后提供对此配置的完全支持。 与Adobe企业支持部门联系,了解先决条件并提出支持请求。
L:有限支持 Adobe在满足特定先决条件后为此配置提供全面支持和维护。 并非所有功能在配置中都可用。 与Adobe企业支持部门联系,了解先决条件并请求支持。

不支持的配置

支持级别 描述
E:预期可用 该配置预计会正常工作,而且没有相反的报告。
Z:不支持 不支持此配置。 Adobe不对配置是否工作做出任何声明,也不支持配置。

Java虚拟机(JVM)

Adobe Experience Manager Forms需要运行Java虚拟机,该虚拟机由Java开发工具包(JDK)分发提供。 Adobe Experience Manager使用以下版本的Java虚拟机:

平台

支持级别

支持的修补程序定义

OracleJava™ SE 8(64位)

答:支持

次要版本和更新

IBM® J9 Virtual Machine(内部版本2.8,JRE 1.8.0) 答:支持 次要版本和更新
注意
  • AEM Forms在JEE上仅支持生产环境上的64位JVM。
  • 建议跟踪Java供应商的安全公告,以确保生产环境的安全和安全,并安装最新的Java更新。

数据库和CRX持久性

AEM持久性支持

平台

描述

支持级别

文件系统

存储库微内核(TAR MK文件)

支持

MongoDB Enterprise 3.4

存储库微内核

支持

IBM DB2 11.1 存储库微内核 支持

Oracle数据库12c版本1

存储库微内核

支持

Microsoft SQL Server 2016

存储库微内核

支持

  • MongoDB是第三方软件,不包含在AEM授权包中。 有关详细信息,请参阅MongoDB授权策略页。

  • 为了充分利用AEM部署,Adobe建议授权许可MongoDB企业版,以从专业支持中受益。

  • Adobe客户关怀将帮助确定与将MongoDB与AEM一起使用相关的问题。 有关详细信息,请参阅MongoDB forAdobe Experience Manager页面

  • “文件系统”包括符合POSIX的块存储。 这包括网络存储技术。 请注意,文件系统性能可能会有所不同,并影响总体性能。 建议将AEM与网络/远程文件系统一起加载测试。

  • 仅支持MongoDB存储引擎WiredTiger。

  • AEM不支持MongoDB共享。

  • AEM Forms在JEE上不支持MySQL的RDBMK持久性。

  • 文档安全模块不使用内容存储库。 这意味着,如果您仅使用文档安全,并且不计划使用HTML Workspace、HTML5表单或自适应表单,则请勿安装内容存储库。

  • AEM FormsJEE支持Oracle多租户架构。

数据库支持

平台

描述

支持级别AEM 6.4

支持级别AEM Forms6.4(JEE)

IBM DB2 11.1 存储库微内核 支持 支持

Oracle数据库12c版本1

存储库微内核

支持

支持

MySQL 5.7.19

存储库微内核

预期可用

支持

Microsoft SQL Server 2016

存储库微内核

预期可用

支持

数据库驱动程序

数据库

平台

支持的修补程序定义

MySQL

MySQL Connector/J 5.7

mysql-connector-java-5.1.30-bin.jar(5.1.30版)

随AEM Forms提供JEE安装

Microsoft SQL Server

Microsoft® SQL Server JDBC驱动程序6.2.1.0

sqljdbc6.jar

随AEM Forms一起安装JEE。

Oracle

Oracle数据库12.1.0.2.0 JDBC驱动程序

ojdbc7.jar(版本12.1.0.2.0)

随AEM Forms一起安装JEE。

IBM DB2

IBM® DB2 Universal JDBC驱动程序4.16.53(db2jcc4.jar)

IBM Website下载驱动程序

应用程序服务器

平台

支持级别

支持的修补程序定义

OracleWebLogic Server 12.2.1(12c R2)[1] [2] [4] [8]

答:支持

服务包和关键更新

IBM® WebSphere® Application Server 9.0 [2] [6]
答:支持 服务包和关键更新

JBoss®企业应用程序平台(EAP)7.0.6 [1] [4] [5] [7] [8][11]

答:支持

支持的EAP版本
的修补程序和累积修补程序

注意

IBM® WebSphere®群集仅在网络部署版本中受支持。

服务器操作系统

生产环境

平台

支持级别

支持的修补程序定义

Microsoft Windows Server 2016 答:支持 服务包和关键更新

Microsoft Windows Server 2012 R2 V6.3

答:支持

服务包和关键更新

OracleSolaris™ 11 - V5.11 [3] [10]

L:有限

更新和修补程序

Red Hat Enterprise Linux 7(Kernel 3.x)
注: Red Hat Enterprise Linux 6在2020年11月30日进入维护阶段并过渡到扩展生命周期支持阶段。 Adobe建议使用Red Hat Enterprise Linux 7进行升级和新安装。 现有安装可以在延长生命周期支持阶段使用Red Hat Enterprise Linux 6。

答:支持

次要版本、累积更新和关键更新

SUSE® Linux® Enterprise Server 12

答:支持

服务包、累积修补程序和关键安全更新

OracleLinux® 7更新3 答:支持 服务包、累积修补程序和关键安全更新
CentOS 7 [9] 答:支持 服务包、累积修补程序和关键安全更新
IBM AIX 7.2 [10] 答:有限支持 服务包、累积修补程序和关键安全更新
注意

AEM FormsJEE仅支持64位操作系统。

虚拟化环境

您可以在物理机或虚拟环境上在JEE上运行AEM Forms。 但是,如果您在虚拟环境上与AEM Forms发生任何问题,请尝试在物理机上复制该问题。 如果物理机上仍存在问题,请与Adobe支持联系以获得解决。 对于不在物理机上复制的问题,请与虚拟环境供应商联系。

开发环境

平台(基本版本)

支持级别

支持的修补程序定义

Microsoft® Windows® 10

E:预期可用

服务包和关键更新

注意
  • AEM FormsJEE仅支持64位操作系统。
  • Windows 10不支持PDF Generator服务。

支持的服务器平台的例外

在选择平台以在JEE服务器上设置您的AEM Forms时,请考虑以下例外情况。

  1. AEM Forms在JEE上不支持Oracle在IBM® AIX®上的WebLogic和JBoss®。
  2. AEM FormsJEE不支持OracleWebLogic和IBM® WebSphere®与MySQL。
  3. AEM FormsJEE不支持采用英特尔®架构的OracleSolaris™(仅支持SPARC®)。
  4. AEM Forms在JEE上不支持OracleWebLogic和SUSE Linux Enterprise Server 12上的JBoss。 SUSE Linux Enterprise Server 12仅支持IBM WebSphere。
  5. AEM Forms在JEE上不支持除OracleJava™ SE外的任何JDK。
  6. AEM Forms在JEE上不支持除IBM® JDK外的IBM® WebSphere®的任何JDK。
  7. AEM FormsJEE不支持IBM® DB2和JBoss®。
  8. CRX-repository支持TarMK、MongoDB和关系数据库(RDBMK)类型的持久性。 应用程序服务器和CRX-repository之间不能有两个不同的数据库系统。 但是,在JEE环境的AEM Forms上,可以将MongoMK与CRX-repository结合使用,将受支持的关系数据库与应用程序服务器结合使用。
  9. AEM Forms在JEE上不支持CentOS上的WebSphere应用程序服务器。
  10. AIX和Solaris操作系统只适用于升级客户。
  11. AEM FormsJEE不支持基于JBoss角色的访问控制(RBAC)。

此外,在为AEM FormsAdobeJEE部署时选择软件时,请考虑以下几点:

  • AEM FormsJEE版支持受支持软件的指定主要版本和次要版本的更新、修补程序和修复包。 但是,除非指定,否则不支持更新到下一个主版本或次版本。
  • 基于群集的安装不支持TarMK持久性。 有关支持的持久性的信息,请参见为AEM Forms安装选择持久性类型
  • AEM FormsJEE根据我们的第三方软件支持政策支持各种第三方软件。
  • AEM FormsJEE平台支持第三方供应商提供的平台。 某些组合可能不允许由第三方供应商进行。 例如,许多供应商尚未通过IBM® DB2认证其应用程序服务器。 因此,JEE的AEM Forms也不支持这些组合。 要确保选择支持的软件版本,请查看第三方供应商的支持列表。
  • AEM FormsJEE不支持TarMK Cold Standby。
  • AEM Forms的JEE不支持垂直聚类。
  • AEM Forms在JEE上不支持群集环境上的MySQL数据库。
  • 在Weblogic上配置包JDBC模块时,RDBMK不能用于DB2、MYSQL、MS SQL和Oracle数据库。

LDAP服务器(可选)

产品(基本版本)

支持的修补程序定义

Oracle统一目录(OUD)11g版本2 服务包
Microsoft Active Directory 2016 维护版本和修复包

Microsoft® Active Directory 2012

随操作系统提供的更新

Microsoft Active Directory轻量目录服务2012

随操作系统提供的更新

IBM® Tivoli Directory Server 6.4

功能包和临时修复

IBM Lotus Domino 8.5.0 维护版本和修复包
Novell eDirectory 8.8.7 产品更新

电子邮件服务器(可选)

  • IBM Lotus Domino 9.0
  • Microsoft Exchange 2013
  • Microsoft Office 365

内容管理器和相应的连接器

产品
版本
IBM Content Manager Server 8.5修复包2
IBM Content Manager Client

支持版本8.5

EMC Documentum 7.0和7.3
IBM Filenet 5.2
Microsoft Sharepoint 2013年和2016年

支持Cordova

AEM Forms应用程序现在支持Apache Cordova。 以下是支持的特定于平台的Cordova版本:

  • Apache Cordova 6.4.0
  • Cordova iOS 4.3.0
  • Cordova Android 6.0.0
  • Cordova Windows 4.4.3

对PDF Generator的软件支持

产品

支持的转换为PDF的格式

Acrobat2017年经典赛 XPS,图像格式(BMP、GIF、JPEG、JPG、TIF、TIFF、PNG、JPF、JPX、JP2、J2K、J2C、JPC)、HTML、HTM、DWG、DXF和DWF
Microsoft® Office 2016 DOC、DOCX、XLS、XLSX、PPT、PPTX、RTF和TXT
Microsoft® Office 2013 DOC、DOCX、XLS、XLSX、PPT、PPTX、RTF和TXT
WordPerfect X7 WP, WPD
Microsoft® Office Visio 2013 VSD、VSDX
Microsoft® Office Visio 2016 VSD、VSDX
Microsoft® Publisher 2013 PUB
Microsoft® Publisher 2016 PUB
Microsoft® Project 2013 MPP
Microsoft® Project 2016 MPP
OpenOffice 4.1.2 ODT、ODP、ODS、ODG、ODF、SXW、SXI、SXC、SXD、XLS、XLSX、DOC、DOCX、PPT、PPTX、图像格式(BMP、GIF、JPEG、TIF、 PNG、JPF、JPX、JP2、J2K、J2C、JPC)、HTML、HTM、RTF和TXT
OpenOffice 3.4 ODT、ODP、ODS、ODG、ODF、SXW、SXI、SXC、SXD、XLS、XLSX、DOC、DOCX、PPT、PPTX、图像格式(BMP、GIF、JPEG、TIF、 PNG、JPF、JPX、JP2、J2K、J2C、JPC)、HTML、HTM、RTF和TXT
注意

PDF Generator仅支持支持的操作系统和应用程序的英语、法语、德语和日语版本。

此外:

  • PDF Generator需要32位版本的Acrobat2017经典音轨版本17.011.30078或更高版本才能执行转换。
  • PDF Generator仅支持Microsoft Office Professional Plus的32位零售版以及转换所需的其他软件。
  • PDF Generator不支持Microsoft Office 365。
  • 仅在Windows、Linux和Solaris上支持OpenOffice的PDF Generator转换。
  • AIX上已弃用HTML2PDF服务。
  • OCR PDF、Optimize PDF和Export PDF功能仅在Windows上受支持。
  • Acrobat的某个版本与AEM Forms捆绑在一起,以实现PDF Generator功能。 捆绑版本仅应在AEM Forms许可期限内通过AEM Forms以编程方式访问,以便与AEM FormsPDF生成器一起使用。 有关详细信息,请参阅按部署说明的AEM Forms产品说明(内部部署Managed Services)"

辅助功能支持的例外

AEM Forms的以下子系统不符合508:

  • 自适应Forms创作UI
  • Forms经理创作UI
  • 通信管理创作UI
  • 管理员UI(管理控制台UI)

AEM FormsJEE的系统要求

最低硬件要求

平台 最低硬件要求
Microsoft Windows Server Intel® Xeon® E5-2680、2.4 GHz处理器或等效的
VMWare ESX 5.1或更高版本
RAM:6 GB(64位操作系统,带64位JVM)
可用磁盘空间:15GB临时空间外加22GB
(适用于JEE上的AEM Forms)
Sun Solaris UltraSPARC® IIIi, 1.5 GHz处理器
Solaris容器(Zones)分区
RAM:6 GB(64位操作系统,带64位JVM)
可用磁盘空间:6 GB临时空间外加22 GB
(针对JEE上的AEM Forms)
IBM AIX P6 pSeries 520(型号52A)9131-52A,1.8 GHz处理器
LPAR分区
RAM:6 GB(64位操作系统,带64位JVM)
可用磁盘空间:6 GB临时空间外加22 GB
(针对JEE上的AEM Forms)
SUSE Linux Enterprise Server Intel Xeon E5-2670v2,1个vCPU,2.5 GHz处理器
AWS m3.medium(3 ECU)
RAM:6 GB(64位操作系统,带64位JVM)
可用磁盘空间:6 GB临时空间外加22 GB
(针对JEE上的AEM Forms)
Red Hat Enterprise Linux Intel Xeon E5-2670v2,1个vCPU,2.5 GHz处理器
AWS m3.medium(3 ECU)
RAM:6 GB(64位操作系统,带64位JVM)
可用磁盘空间:6 GB临时空间加上JEE上的AEM Forms22 GB

小型生产环境的硬件要求
  • 以英特尔为后盾的环境:英特尔®至强® E5-2680,2.4 GHz或更高。使用双核处理器将进一步提高性能
  • 以Sun SPARC为后盾的环境: UltraSPARC V或更高版本
  • 以IBM AIX为后盾的环境: Power6或更高版本
  • 内存: 4 GB

有关其他要求,请参阅:

JEE上的AEM Forms支持的客户端

Workbench

注意

支持32位和64位操作系统。

平台

支持的修补程序定义

Microsoft® Windows® 10

(企业、专业、基本)

服务包和关键更新
Microsoft® Windows® 2012 Server R2 服务包和关键更新
Microsoft® Windows® 2016 Server 服务包和关键更新
  • 安装的磁盘空间:1.7 GB(仅限Workbench),2.7 GB(在单个驱动器上),可完全安装Workbench、Designer和示例程序集400 MB(临时安装目录)- 200 MB(在用户临时目录), 200 MB(在Windows临时目录中)
注意

如果所有这些位置都驻留在单个驱动器上,则安装过程中必须有1.5 GB可用空间。 安装完成后,将删除复制到临时目录的文件。

  • 运行Workbench的内存:2 GB内存
  • 硬件要求:Intel® Pentium® 4或AMD等效处理器,1 GHz处理器
  • 最低1024 X 768像素或更高的显示器分辨率,16位颜色或更高
  • TCP/IPv4或TCP/IPv6网络连接到JEE服务器上的AEM Forms
注意

您必须具有“管理”权限才能在Windows上安装Workbench。 如果您使用非管理员帐户进行安装,安装程序将提示您输入相应帐户的凭据。

设计器

注意:要 在Windows上安装Designer,请以管理权限运行安装程序。

  • Microsoft® Windows® 2012 Server R2、Microsoft® Windows® 2016 Server、Microsoft Windows 10

    • 支持PAE、NX和SSE2的1 GHz或更快的处理器。
    • 32位需要1GB内存,64位操作系统需要2GB内存
    • 32位为16 GB磁盘空间,64位操作系统为20 GB磁盘空间
  • 图形内存- 128 MB GPU(建议使用256 MB)

  • 2.35 GB可用硬盘空间

  • DVD-ROM驱动器

  • Internet Explorer 10或11;Firefox 45.x

  • 1024 X 768像素或更高的显示器分辨率

  • 视频硬件加速(可选)

  • Acrobat Pro DC、Acrobat Standard DC或Adobe Acrobat Reader DC。

Adobe Acrobat和Adobe Reader

Acrobat和Adobe Reader(基地)

支持的修补程序定义

Acrobat2017(经典曲目) 版本17.011.30078或更高版本
注意

AcrobatDC产品系列为Acrobat和Reader引入了两种途径,这两种途径本质上是不同的产品:“经典”和“连续”。 有关这两个音轨的详细信息和比较,请参阅https://www.adobe.com/go/acrobatdctracks。

浏览器

台式机

浏览器(基础)

支持级别

支持的修补程序定义

Microsoft Edge

答:支持

服务包和更新

Mozilla Firefox 45.x

答:支持

所有更新

Google Chrome 46+

答:支持

所有更新

Apple Safari 11.x 答:支持 所有更新

MAC OS X上的Google Chrome和Firefox

答:支持

所有更新

注意

桌面的某些与浏览器相关的例外情况如下:

  • 大多数新式浏览器不再支持基于NPAPI的插件。 有关它对AEM Forms应用程序和工作流的影响的信息,请参见停止NPAPI浏览器插件及其影响
  • 仅Macintosh OS X支持Safari。

移动客户端

浏览器(基础)

支持的修补程序定义

Android™ 4.1.2及更高版本上的Chrome

所有更新

iOS 11.0及更高版本上的Safari 所有更新
Windows 10上的Internet Explorer 所有更新
Microsoft Edge
所有更新
Android™ 4.4及更高版本上的本机Android浏览器 所有更新
注意
  • Forms门户仅在iPad上的Safari上受支持。

AEM Forms应用程序

移动设备支持

AEM Forms应用程序可用于以下平台:

平台 支持的设备
Apple iOS 运行iOS 11及更高版本的Apple iPhone、iPad、iPad Air和iPad mini。
Google Android Android 4.4(Android Kit Kat)及以上​[API级别19及以上]。 AEM Forms应用在7英寸和10英寸的三星Galaxy平板电脑、7英寸的Google Nexus平板电脑和流行智能手机上获得认证。
Microsoft Windows 运行Microsoft Windows 10操作系统的Microsoft Surface设备、平板电脑、笔记本电脑和台式机。

AdobeFlash Player

Flash Player(基本)

支持的修补程序定义

Flash Player最新版本

次要版本和更新

注意

Adobe文档Security Extension for Microsoft Office

单击此处查看Adobe文档安全扩展Microsoft® Office的系统要求。

客户端支持的异常

除Reader和Acrobat外,并非所有指定的客户端软件都支持Microsoft® Windows® 2012。

此外,JEE上的AEM Forms支持受支持软件的指定主要版本和次要版本的更新、修补程序和修复包。 但是,除非指定,否则不支持更新到下一个主版本或次版本。

第三方修补程序支持策略

针对JEE的AEM Forms的第三方软件要求在其各自产品文档的“系统要求”部分中进行了说明。 所有文档均可从https://adobe.com/go/learn_aemforms_documentation_64访问。

AEM Forms在JEE的第三方参考平台上声明了在JEE上开发和发布AEM Forms时当前的第三方基础架构的特定修补程序级别,以及该版本的JEE上AEM Forms所支持的基础架构的最低修补程序/服务包级别。

Adobe支持第三方供应商在发布时发布的紧急或推荐的修补程序,前提是第三方供应商保证与AEM FormsJEE支持的版本向后兼容。 Adobe将仅支持在AEM FormsJEE文档中规定的最低修补程序级别之后发布的修补程序。

在某些情况下,Adobe不支持更改主要功能的第三方更新,因此不支持完全向后兼容性。 有关支持的更新的详细信息,请参阅针对特定供应商产品和Adobe支持的修补程序类型的支持的修补程序定义

在Adobe无法控制的情况下,声称向后兼容的第三方修补程序可能会对Adobe产品或客户环境产生负面影响。 在这种情况下,Adobe建议客户先评估来自第三方的任何紧急补丁程序的影响,然后再将其应用到关键系统。 Adobe将与第三方合作,通过正常的Adobe支持项目或第三方在他们的地区纠正该问题,通过合理的业务努力解决此类问题。 这不保证将受Adobe支持的新发布的第三方修补程序能够按照供应商或AEM Forms在JEE上的说明运行。

Adobe保留在任何给定时刻更改由AEM Forms在JEE版本上支持的第三方参考平台及其支持的修补程序定义的权利。

通过搜索Adobe企业支持站点以找到与您的产品相关的知识库文章,还可以找到有关第三方修补程序的其他信息。

联系支持

在此页面上