Solucionar problemas do aplicativo AEM Forms

Este artigo descreve as mensagens de erro que podem ser exibidas durante a criação do aplicativo AEM Forms e as etapas para resolvê-las.

As seções neste artigo incluem:

Perda de anexo para usuários do iOS

O aplicativo AEM Forms para iOS configurado para sincronizar com AEM Forms no OSGi é compatível somente com anexos em nível de campo. Todos os anexos devem ter nomes exclusivos. Se vários anexos tiverem um nome idêntico, apenas um anexo será mantido e todos os outros com um nome idêntico serão perdidos. Execute as seguintes etapas para impedir que os usuários de dispositivos iOS sofram perda de dados:

  1. No servidor conectado, navegue até Adobe Experience Manager > Ferramentas > Operações > Console da Web.

  2. Localize e clique em Adaptive Form e Interative Communication Web Channel Configuration.

  3. Na caixa de diálogo Adaptive Form and Interative Communication Web Channel Configuration, habilite Tornar nomes de arquivos exclusivos.

    Se a configuração Tornar nomes de arquivo únicos estiver desativada, os usuários sofrerão perda de dados se tentarem enviar formulários adaptáveis com vários anexos.

  4. Clique em Salvar.

Os rascunhos de formulário HTML5 enviados por usuários do espaço de trabalho não estão visíveis no portal

Para formulários HTML5 ativados no aplicativo AEM Forms com Salvar como rascunho Perfil de renderização HTML, os rascunhos salvos não ficam visíveis para os usuários do espaço de trabalho. Para exibir rascunhos salvos de formulários HTML5 enviados por usuários do espaço de trabalho no portal, execute as seguintes etapas:

  1. Abra o CRXDE e faça logon com credenciais de administrador.

    URL: https://<server>:<port>/lc/crx/de/index.jsp

  2. No caminho raiz do CRXDE, na Lista de Controle de Acesso em Controle de Acesso, clique em +.

  3. Na caixa de diálogo Adicionar nova entrada, clique no botão de pesquisa do grupo no campo Principal.

  4. No campo Nome da caixa de diálogo Selecionar Principal, digite PERM_WORKSPACE_USER e clique em Pesquisar.

  5. Selecione o grupo PERM_WORKSPACE_USER na caixa de diálogo Selecionar Principal e clique em OK.

  6. Na caixa de diálogo Adicionar nova entrada, o grupo PERM_WORKSPACE_USER é selecionado no campo Principal.

    Ative os privilégios jcr:read para o grupo de usuários.

  7. Clique em OK.

Os formulários HTML5 (não armazenados em cache) não são carregados no aplicativo AEM Forms

Quando o aplicativo AEM Forms é conectado a uma versão mais antiga do servidor AEM Forms, os formulários HTML5 não armazenados em cache não são carregados no aplicativo AEM Forms.

Execute as seguintes etapas para resolver o problema:

  1. Na instância do autor, navegue até Adobe Experience Manager > Ferramentas > Configurar o serviço offline do aplicativo do Workspace > Configurar agora.

  2. Na página Serviço Offline de Aplicativo do Workspace, clique em Cache de Recurso Manual.

    URL: https://<server>:<port>/libs/fd/workspace-offline/content/config.html

  3. Na guia Manual Resource Cache, clique no botão + para adicionar um caminho CRX.

  4. No campo Adicionar um Novo Recurso, digite: /etc.clientlibs/fd/xfaforms/I18N/en_US.js e clique em Adicionar.

  5. Clique em Salvar.

Os AEM Forms não são sincronizados no Windows

No aplicativo AEM Forms no Windows, um formulário não é sincronizado com o servidor conectado se o caminho do formulário ou de seus recursos contiver mais de ou igual a 256 caracteres.

Modifique o caminho do formulário e seus recursos para reduzir o número de caracteres para menos de 256 caracteres.

Versão não suportada do Gradle

Mensagem de erro: o projeto está usando uma versão não suportada do Gradle.

A mensagem de erro é exibida ao criar o aplicativo AEM Forms no Android Studio. O problema ocorre devido à versão não suportada do Gradle suportada no sistema.

Solução: clique em Corrigir invólucro de Gradle e reimporte o projeto para resolver o problema.

gradle_unsupported_version

Problemas de compatibilidade do plug-in Gradle e Android Gradle

Mensagem de erro: as versões do plug-in e Gradle do Android Gradle não são compatíveis.

A mensagem de erro é exibida ao selecionar a opção Criar APK no menu Criar na interface do usuário do Android Studio.

gradle_plugin_compatibility

Solução: Abra Scripts de Gradle > gradle-wrapper. properties e edite a propriedade ​distributionUrlproperty.

Por exemplo, o console do Android Studio recomenda o downgrade da versão Gradle para 3.5. Edite a versão no arquivo distributionUrl of gradle-wrapper.properties.

Selecione Build > Build APK novamente para resolver o erro e gerar o arquivo .apk.

gradle_wrapper_properties

Nesta página

Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now