Risoluzione dei problemi app AEM Forms

Questo articolo descrive i messaggi di errore che potrebbero essere visualizzati durante la creazione 'app AEM Forms e i passaggi per risolverli.

Le sezioni di questo articolo includono:

Perdita di allegati per gli utenti iOS

app AEM Forms per iOS configurata per la sincronizzazione con AEM Forms su OSGi supporta solo allegati a livello di campo. Tutti gli allegati devono avere nomi univoci. Se più allegati hanno lo stesso nome, viene mantenuto un solo allegato e tutti gli altri con lo stesso nome vanno persi. Effettuate le seguenti operazioni per evitare che gli utenti dei dispositivi iOS si trovino in una situazione di perdita di dati:

  1. Nel server connesso, andate a Adobe Experience Manager > Strumenti > Operazioni > Console Web.

  2. Trovare e fare clic su Servizio configurazione modulo adattivo.

  3. Nella finestra di dialogo Servizio configurazione modulo adattivo, abilitare Rendi univoci i nomi dei file.

    Se l'impostazione Rendi univoci i nomi dei file è disabilitata, gli utenti potrebbero perdere i dati se tentano di inviare moduli adattivi con più allegati.

  4. Fai clic su Salva.

Le bozze dei moduli HTML5 inviate dagli utenti dell'area di lavoro non sono visibili sul portale

Per i moduli HTML5 abilitati nell'app AEM Forms con il profilo di rendering HTML Salva come bozza, le bozze salvate non sono visibili agli utenti dell'area di lavoro. Per visualizzare le bozze salvate dei moduli HTML5 inviate dagli utenti dell'area di lavoro sul portale, effettuare le seguenti operazioni:

  1. Aprite CRXDE e accedete con le credenziali di amministratore.

    URL: https://<server>:<port>/lc/crx/de/index.jsp

  2. Nel percorso principale del CRXDE, nell'elenco Controllo accesso in Controllo accesso fare clic su +.

  3. Nella finestra di dialogo Aggiungi nuova voce, fare clic sul pulsante di ricerca del gruppo nel campo Principal.

  4. Nel campo Nome della finestra di dialogo Seleziona entità digitare PERM_WORKSPACE_USER e fare clic su Cerca.

  5. Selezionare il gruppo PERM_WORKSPACE_USER nella finestra di dialogo Seleziona entità e fare clic su OK.

  6. Nella finestra di dialogo Aggiungi nuova voce, il gruppo PERM_WORKSPACE_USER è selezionato nel campo Principal.

    Abilitate i privilegi jcr:read per il gruppo di utenti.

  7. Fai clic su OK.

Impossibile caricare i moduli HTML5 (non memorizzati nella cache) 'app AEM Forms

Quando 'app AEM Forms è connessa a una versione precedente del server AEM Forms, i moduli HTML5 non memorizzati nella cache non vengono caricati 'app AEM Forms.

Per risolvere il problema, effettuate le seguenti operazioni:

  1. Nell'istanza di authoring, passare a Adobe Experience Manager > Strumenti > Configura servizio offline app Workspace > Configura ora.

  2. Nella pagina Servizio offline app Workspace fare clic su Cache risorse manuale.

    URL: https://<server>:<porta>/libs/fd/workspace-offline/content/config.html

  3. Nella scheda Cache delle risorse manuali, fare clic sul pulsante + per aggiungere un percorso CRX.

  4. Nel campo Aggiungi una nuova risorsa digitare: /etc.clientlibs/fd/xfaforms/I18N/en_US.js e fare clic su Aggiungi.

  5. Fai clic su Salva.

AEM Forms non sincronizza in Windows

Nell'app AEM Forms su Windows, un modulo non si sincronizza con il server connesso se il percorso del modulo o una delle relative risorse contiene più o meno 256 caratteri.

Modificare il percorso del modulo e le relative risorse per ridurre il numero di caratteri a meno di 256 caratteri.

Versione non supportata di Gradle

Messaggio di errore: il progetto utilizza una versione non supportata di Gradle.

Il messaggio di errore viene visualizzato quando create app AEM Forms in Android Studio. Il problema si verifica a causa di una versione non supportata di Gradle supportata nel sistema.

Risoluzione: fate clic su Correggi wrapper sfumatura e reimportate il progetto per risolvere il problema.

gradle_unsupported_version

Problemi di compatibilità dei plug-in Gradle e Gradle

Messaggio di errore: Le versioni del plug-in Gradle Android e Gradle non sono compatibili.

Il messaggio di errore viene visualizzato quando si seleziona l'opzione Crea APK dal menu Genera nell'interfaccia utente di Android Studio.

gradle_plugin_compatible

Risoluzione: Open Gradle Scripts > gradle-wrapper. properties file e modificare la ​distributionUrlproperty.

Ad esempio, la console di Android Studio consiglia di ridurre la versione Gradle a 3.5. Modificate la versione in distributionUrl di gradle-wrapper.properties file.

Selezionare di nuovo Build > Crea APK per risolvere l'errore e generare il file .apk.

gradle_wrapper_properties

In questa pagina