Fehlerbehebung der AEM Forms-App

In diesem Artikel werden die Fehlermeldungen, die beim Erstellen von AEM Forms App möglicherweise angezeigt werden und die Schritte zur Problembehebung.

Die Abschnitte in diesem Artikel behandeln Folgendes:

Verlust von Anhängen für iOS-Benutzer

AEM Forms-App für iOS, die zur Synchronisierung mit AEM Forms unter OSGi konfiguriert ist, unterstützt nur Anlagen auf Feldebene. Alle Anlagen müssen eindeutige Namen haben. Wenn mehrere Anlagen denselben Namen haben, wird nur eine Anlage beibehalten und alle anderen mit identischem Namen gehen verloren. Führen Sie die folgenden Schritte aus, um Benutzer auf iOS-Geräten vor Datenverlust zu bewahren:

  1. Navigieren Sie auf dem verbundenen Server zu Adobe Experience Manager > Tools > Vorgänge > Web-Konsole.

  2. Suchen und Klicken Webkanalkonfiguration für adaptive Formulare und interaktive Kommunikation.

  3. Im Webkanalkonfiguration für adaptive Formulare und interaktive Kommunikation dialog, aktivieren Dateinamen individualisieren.

    Wenn Dateinamen individualisieren -Einstellung deaktiviert ist, kann es bei Benutzern zu Datenverlusten kommen, wenn sie versuchen, adaptive Formulare mit mehreren Anhängen zu senden.

  4. Klicken Sie auf Speichern.

Entwürfe von HTML5 -Formularen, die von Workspace-Benutzern eingesendet wurden, werden nicht auf dem Portal angezeigt

Für HTML5 Formulare, die in der AEM Forms-App mit Als Entwurf speichern HTML Render Profile, die gespeicherten Entwürfe sind für Workspace-Benutzer nicht sichtbar. So zeigen Sie gespeicherte Entwürfe von HTML5-Formularen an, die von Workspace-Benutzern im Portal übermittelt wurden:

  1. Öffnen Sie CRXDE und melden Sie sich als Administrator an.

    URL: https://<server>:<port>/lc/crx/de/index.jsp

  2. Im Stammpfad von CRXDE, in der Zugriffssteuerungsliste unter Zugriffssteuerung klicken Sie auf +.

  3. Klicken Sie im Dialogfeld Neuen Eintrag hinzufügen auf die Gruppensuche-Schaltfläche im Feld „Prinzipal“.

  4. Geben Sie im Feld "Name"des Dialogfelds "Prinzipal auswählen"Folgendes ein: PERM_WORKSPACE_USER und klicken Sie auf Suche.

  5. Auswählen PERM_WORKSPACE_USER Gruppe im Dialogfeld "Prinzipal auswählen"und klicken Sie auf OK.

  6. Im Dialogfeld „Neuen Eintrag hinzufügen“ wird PERM_WORKSPACE_USER-Gruppe im Feld „Prinzipal“ ausgewählt.

    Aktivieren jcr:read Berechtigungen für die Benutzergruppe.

  7. Klicken Sie auf OK.

HTML5-Formulare (nicht zwischengespeichert) werden in AEM Forms App nicht geladen

Wenn AEM Forms App mit einer älteren Version von AEM Forms-Server verbunden ist, können nicht zwischengespeicherte HTML5-Formulare nicht in AEM Forms App hochgeladen werden.

Führen Sie zur Behebung dieses Problems folgende Schritte durch:

  1. Navigieren Sie in der Autoreninstanz zu Adobe Experience Manager > Tools > Workspace-App-Offline-Dienst konfigurieren > Jetzt konfigurieren.

  2. Auf der Seite Workspace-App Offline-Service klicken Sie auf Manueller Ressourcen-Cache.

    URL: https://<server>:<port>/libs/fd/workspace-offline/content/config.html

  3. Im manuellen Ressourcen-Cache klicken Sie auf die Schaltfläche +, um einen CRX-Pfad hinzuzufügen.

  4. Im Neue Ressource hinzufügen -Feld, Typ: /etc.clientlibs/fd/xfaforms/I18N/en_US.js und klicken Sie auf Hinzufügen.

  5. Klicken Sie auf Speichern.

AEM Forms werden unter Windows nicht synchronisiert

Ein Formular wird unter Windows nicht in der AEM Forms-App mit dem verbundenen Server synchronisiert, wenn der Pfad des Formulars oder seine Ressourcen länger als 256 Zeichen lang sind.

Modifizieren Sie den Pfad des Formulars und seine Ressourcen, um die Anzahl der Zeichen im Pfad auf 256 zu reduzieren.

Nicht unterstützte Version von Gradle

Fehlermeldung: Das Projekt verwendet eine nicht unterstützte Version von Gradle.

Die Fehlermeldung wird angezeigt, wenn Sie die AEM Forms-App in Android Studio erstellen. Das Problem tritt aufgrund einer nicht unterstützten Version von Gradle auf, die vom System unterstützt wird.

Auflösung: Klicken Gradle Wrapper- und Neu-Import-Projekt reparieren um das Problem zu beheben.

gradle_unsupported_version

Kompatibilitätsprobleme mit Gradle und Android Gradle Plug-In

Fehlermeldung: Die Versionen des Android Gradle-Plug-ins und Gradle sind nicht kompatibel.

Die Fehlermeldung wird angezeigt, wenn Sie Build-APK -Option Build auf der Benutzeroberfläche von Android Studio.

gradle_plugin_compatibility

Auflösung: Öffnen Gradle Scripts > gradle-wrapper.properties und bearbeiten Sie die distributionUrl -Eigenschaft.

Beispielsweise empfiehlt die Android Studio-Konsole, die Gradle-Version auf 3.5 herabzustufen. Bearbeiten Sie die Version in distributionUrl von gradle-wrapper.properties -Datei.

Auswählen Build > Build-APK erneut, um den Fehler zu beheben und die .apk-Datei zu generieren.

gradle_wrapper_properties

Auf dieser Seite