Erstellen von Workflow-Modellen

VORSICHT

Informationen zur Verwendung der klassischen Benutzeroberfläche finden Sie in der Dokumentation zu AEM 6.3.

Sie erstellen ein Workflow-Modell, um die Schritte zu definieren, die ausgeführt werden, wenn ein Benutzer den Workflow startet. Sie können auch Modelleigenschaften definieren, um beispielsweise festzulegen, ob es sich um einen Übergangs-Workflow handelt oder der Workflow mehrere Ressourcen verwendet.

Wenn ein Benutzer einen Workflow startet, wird eine Instanz gestartet. Dabei handelt es sich um das entsprechende Laufzeitmodell, das erstellt wird, wenn Sie Ihre Änderungen durch Klicken auf Sync synchronisieren.

Erstellen neuer Workflows

Wenn Sie zum ersten Mal ein neues Workflow-Modell erstellen, umfasst es Folgendes:

  • Die Schritte Fluss Start und Flussende.

    Diese stellen den Anfang und das Ende des Workflows dar. Diese Schritte sind obligatorisch und können nicht bearbeitet oder entfernt werden.

  • Beispiel für einen Schritt Teilnehmer mit dem Namen Schritt 1.

    Dieser Schritt ist so konfiguriert, dass er dem Workflow-Initiator ein Arbeitselement zuordnet. Sie können diesen Schritt nach Bedarf bearbeiten oder löschen und Schritte hinzufügen.

Gehen Sie folgendermaßen vor, um einen neuen Workflow mit dem Editor zu erstellen:

  1. Öffnen Sie die Konsole Workflow-Modelle . über Tools, Workflow, Modelle oder beispielsweise:

    http://localhost:4502/aem/workflow

  2. Wählen Sie dann Erstellen und dann Modell erstellen aus.

  3. Das Dialogfeld Workflow-Modell hinzufügen wird angezeigt. Geben Sie den Titel und den Namen (optional) ein. Wählen Sie anschließend Fertig aus.

  4. Das neue Modell wird in der Konsole Workflow-Modelle aufgeführt.

  5. Wählen Sie Ihren neuen Workflow aus und öffnen Sie ihn dann, indem Sie auf Bearbeiten​klicken, um ihn zu konfigurieren:

    wf-01

HINWEIS

Wenn Sie Modelle programmgesteuert (mithilfe eines CRX-Pakets) erstellen, können Sie auch einen Unterordner erstellen:

/var/workflow/models

Beispiel: /var/workflow/models/prototypes

Dieser Ordner kann anschließend zum Verwalten des Zugriffs auf die Modelle in diesem Ordner verwendet werden.

Bearbeiten von Workflows

Sie können jedes vorhandene Workflow-Modell zu folgenden Zwecken bearbeiten:

Beim Bearbeiten eines Standard- oder Legacy-Workflows (vorkonfiguriert) wird ein zusätzlicher Schritt durchgeführt, um sicherzustellen, dass eine sichere Kopie durchgeführt wird, bevor Sie Ihre Änderungen vornehmen.

Wenn Sie mit den Änderungen an Ihrem Workflow fertig sind, müssen Sie zum Generieren eines Laufzeitmodells auf Sync klicken. Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Synchronisieren von Workflows – Generieren von Laufzeitmodellen

Wenn Sie rechts in der Editor-Symbolleiste auf Sync klicken, wird ein Laufzeitmodell generiert. Das Laufzeitmodell ist das Modell, das tatsächlich verwendet wird, wenn ein Benutzer einen Workflow startet. Wenn Sie Ihre Änderungen nicht durch Klicken auf Sync synchronisieren, stehen diese nicht zur Laufzeit zur Verfügung.

Wenn Sie (oder andere Benutzer) Änderungen am Workflow vornehmen, müssen Sie auf Sync klicken, um ein Laufzeitmodell zu erstellen, auch wenn einzelne Dialogfelder (z. B. für Schritte) eigene Optionen zum Speichern aufweisen.

Nachdem die Änderungen mit dem (gespeicherten) Laufzeitmodell synchronisiert wurden, wird stattdessen Synchronisiert angezeigt.

Bei einigen Schritten gibt es Pflichtfelder und/oder eine integrierte Validierung. Wenn die entsprechenden Bedingungen nicht erfüllt sind, wird eine Fehlermeldung angezeigt, falls Sie versuchen, das Modell mithilfe der Option Sync zu synchronisieren. Etwa wenn für einen Teilnehmer-Schritt kein Teilnehmer definiert wurde:

wf-21

Erstmaliges Bearbeiten von Standard- oder Legacy-Workflows

Wenn Sie ein Standard- bzw. Legacy-Modell zur Bearbeitung öffnen, finden Sie die folgenden Bedingungen vor:

  • Der Browser Steps ist nicht verfügbar (linke Seite).

  • Die Symbolleiste weist eine Option zum Bearbeiten auf (auf der rechten Seite).

  • Zunächst werden das Modell und seine Eigenschaften im schreibgeschützten Modus wie folgt dargestellt:

    • Standard-Workflows befinden sich unter /libs
    • Alte Workflows befinden sich unter /etc

Durch Auswahl von Bearbeiten geschieht Folgendes:

  • eine Kopie des Workflows in /conf
  • Stellen Sie den Browser Steps zur Verfügung.
  • Sie erhalten die Möglichkeit, Änderungen vorzunehmen.
HINWEIS

Unter Speicherorte von Workflow-Modellen finden Sie weitere Informationen.

wf-22

Hinzufügen von Schritten zu Modellen

Sie müssen zu Ihrem Modell Schritte hinzufügen, um die auszuführende Aktivität darzustellen. Mit jedem Schritt wird eine bestimmte Aktivität ausgeführt. In einer Standard-AEM-Instanz stehen unterschiedliche Schrittkomponenten zur Auswahl.

Wenn Sie ein Modell bearbeiten, werden die verfügbaren Schritte in den verschiedenen Gruppen des Browsers Steps angezeigt. Beispiel:

wf-10

HINWEIS

Weitere Informationen zu den primären Schrittkomponenten, die mit AEM installiert werden, finden Sie in der Referenz für Workflow-Schritte.

So fügen Sie einem Modell einen Schritt hinzu:

  1. Öffnen Sie ein vorhandenes Workflow-Modell zur Bearbeitung. Wählen Sie in der Workflow-Modelle-Konsole das gewünschte Modell aus und klicken Sie anschließend auf Bearbeiten.

  2. Öffnen Sie den Browser Steps . Verwenden Sie Seitliches Bedienfeld ein/aus, ganz links in der oberen Symbolleiste. Folgende Informationen/Optionen sind verfügbar:

    • Die Option Filter zum Filtern nach bestimmten Schritten.
    • Verwenden Sie das Dropdown-Menü, um die Auswahl auf eine bestimmte Gruppe von Schritten zu begrenzen.
    • Wählen Sie das Symbol Beschreibung anzeigen wf-stepinfo-icon aus, um weitere Details zum entsprechenden Schritt anzuzeigen.

    wf-02

  3. Ziehen Sie die entsprechenden Schritte an die gewünschte Stelle im Modell,

    beispielsweise einen Teilnehmer-Schritt.

    Nachdem es zum Fluss hinzugefügt wurde, können Sie den Schritt konfigurieren.

    wf-03

  4. Fügen Sie nach Bedarf Schritte hinzu oder nehmen Sie andere Änderungen vor.

    Zur Laufzeit werden die Schritte in der Reihenfolge ausgeführt, in der sie im Modell erscheinen. Nachdem Sie Schrittkomponenten hinzugefügt haben, können Sie diese an eine andere Stelle im Modell ziehen.

    Sie können vorhandene Schritte wie beim Seiten-Editor darüber hinaus kopieren, ausschneiden, einfügen, gruppieren oder löschen.

    Aufspaltungsschritte können auch mithilfe der Symbolleistenoption reduziert/erweitert werden: wf-collapse-expand-toolbar-icon

  5. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Konfigurieren von Workflow-Schritten

Sie können Konfigurieren und das Verhalten eines Workflow-Schritts mithilfe der Dialogfelder Schritteigenschaften anpassen.

  1. So öffnen Sie das Dialogfeld Schritt-Eigenschaften für einen Schritt:

    • Tippen Sie auf den Schritt im Workflow-Modell und wählen Sie Konfigurieren in der Komponenten-Symbolleiste aus.
    • Doppelklicken Sie auf den Schritt.
    HINWEIS

    Weitere Informationen zu den primären Schrittkomponenten, die mit AEM installiert werden, finden Sie in der Referenz für Workflow-Schritte.

  2. Konfigurieren Sie die Schritt-Eigenschaften nach Bedarf. Die jeweils verfügbaren Eigenschaften hängen vom Schritttyp ab, ggf. stehen auch mehrere Registerkarten zur Verfügung. Beispiel: Der standardmäßige Teilnehmer-Schritt, der in einem neuen Workflow als Step 1 vorhanden ist:

    wf-11

  3. Bestätigen Sie Ihre Änderungen durch Klicken auf das Häkchen-Symbol.

  4. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Erstellen von Übergangs-Workflows

Sie können ein Übergangs-Workflow-Modell erstellen, wenn Sie ein neues Modell erstellen oder ein vorhandenes Modell bearbeiten:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus.

  3. Aktivieren Sie im Dialogfeld Übergangs-Workflow (oder deaktivieren Sie bei Bedarf):

    wf-07

  4. Bestätigen Sie die Änderung mit Speichern und schließen und klicken Sie anschließend in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

HINWEIS

Beim Ausführen eines Workflows im Übergangsmodus speichert AEM keinen Workflow-Verlauf. Aus diesem Grund werden in der Timeline keine Informationen zu diesem Workflow angezeigt. 🔗

Workflow-Modelle in der Touch-Benutzeroberfläche verfügbar machen

Wenn ein Workflow-Modell in der klassischen Benutzeroberfläche vorhanden ist, aber im Popupmenü für die Auswahl in der Leiste Timeline der Touch-Benutzeroberfläche fehlt, folgen Sie der Konfiguration, um es verfügbar zu machen. Die folgenden Schritte zeigen die Verwendung des Workflow-Modells Aktivierungsanfrage.

  1. Vergewissern Sie sich, dass das Modell nicht in der Touch-Benutzeroberfläche verfügbar ist. Greifen Sie über den Pfad /assets.html/content/dam auf ein Asset zu. Auswählen eines Assets. Öffnen Sie Timeline in der linken Leiste. Klicken Sie auf Workflow starten und bestätigen Sie, dass das Modell Aktivierungsanfrage nicht in der Popup-Liste vorhanden ist.

  2. Navigieren Sie durch Tools > Allgemein > Tagging. Wählen Sie Workflow.

  3. Wählen Sie Erstellen > Tag erstellen. Legen Sie Title auf DAM und Name auf dam fest. Klicken Sie auf Übermitteln.
    Tag im Workflow-Modell erstellen

  4. Navigieren Sie zu Tools > Workflow > Modelle. Wählen Sie Aktivierungsanfrage und dann Bearbeiten.

  5. Wählen Sie Bearbeiten und öffnen Sie dann Workflow-Modelleigenschaften. Gehen Sie zur Registerkarte Einfach .

  6. Fügen Sie Workflow : DAM zum Feld Tags hinzu. Bestätigen Sie die Auswahl mit dem Häkchen.

  7. Bestätigen Sie das Hinzufügen des Tags mit Speichern und schließen.
    Seiteneigenschaften des Modells bearbeiten

  8. Schließen Sie den Prozess mit Sync ab. Der Workflow ist jetzt in der Touch-optimierten Benutzeroberfläche verfügbar.

Konfigurieren von Workflows für die Unterstützung für mehrere Ressourcen

Sie konfigurieren ein Workflow-Modell für die Unterstützung für mehrere Ressourcen, wenn Sie ein neues Modell erstellen oder ein vorhandenes Modell bearbeiten:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus.

  3. Aktivieren Sie im Dialogfeld Multi Resource Support (oder deaktivieren Sie bei Bedarf):

    wf-08

  4. Bestätigen Sie die Änderung mit Speichern und schließen und klicken Sie anschließend in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Konfigurieren von Workflow-Phasen (die den Workflow-Fortschritt anzeigen)

Die Workflow-Phasen helfen Ihnen bei der Visualisierung des Fortschritts bei der Verarbeitung von Aufgaben.

VORSICHT

Wenn Workflow-Phasen in Seiteneigenschaften definiert sind, aber für keinen der Workflow-Schritte verwendet werden, zeigt der Fortschrittsbalken keinen Fortschritt an (unabhängig vom aktuellen Workflow-Schritt).

Die jeweils verfügbaren Phasen werden in den Workflow-Modellen definiert. Die vorhandenen Workflow-Modelle können aktualisiert werden, um die Phasendefinitionen einzubinden. Sie können eine beliebige Anzahl von Phasen für das Workflow-Modell definieren.

Gehen Sie folgendermaßen vor, um Phasen zu definieren:

  1. Öffnen Sie das Workflow-Modell zur Bearbeitung.

  2. Wählen Sie in der Symbolleiste die Option Eigenschaften für Workflow-Modell aus. Wechseln Sie dann zur Registerkarte Phasen.

  3. Fügen Sie Ihre gewünschten Phasen hinzu (und positionieren Sie sie). Sie können eine beliebige Anzahl von Phasen für das Workflow-Modell definieren.

    Beispiel:

    wf-08-1

  4. Klicken Sie zum Speichern der Eigenschaften auf Speichern und schließen.

  5. Ordnen Sie jedem der Schritte im Workflow-Modell eine Phase zu. Beispiel:

    wf-09

    Eine Phase kann mehreren Schritten zugeordnet werden. Beispiel:

    Schritt Staging
    Schritt 1 Erstellen
    Schritt 2 Erstellen
    Schritt 3 Überprüfung
    Schritt 4 Genehmigen
    Schritt 5 Genehmigen
    Schritt 6 Fertig stellen
  6. Bestätigen Sie Ihre Änderungen, indem Sie in der Editor-Symbolleiste auf Sync klicken, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Exportieren von Workflow-Modellen in Pakete

  1. Erstellen Sie mit Package Manager ein neues Paket:

    1. Navigieren Sie über Tools, Bereitstellung, Pakete zum Package Manager.
    2. Klicken Sie auf Paket erstellen.
    3. Geben Sie den Paketnamen sowie alle weiteren erforderlichen Informationen an.
    4. Klicken Sie auf OK.
  2. Klicken Sie in der Symbolleiste Ihres neuen Pakets auf Bearbeiten.

  3. Öffnen Sie die Registerkarte Filter.

  4. Wählen Sie Filter hinzufügen und geben Sie den Pfad zum Design Ihres Workflow-Modells ein:

    /conf/global/settings/workflow/models/<*your-model-name*>

    Klicken Sie auf Fertig.

  5. Wählen Sie Filter hinzufügen und geben Sie den Pfad zu Ihrem Laufzeit-Workflow-Modell ein:

    /var/workflow/models/<*your-model-name*>

    Klicken Sie auf Fertig.

  6. Fügen Sie weitere Filter für alle benutzerdefinierten Skripte hinzu, die von Ihrem Modell verwendet werden.

  7. Klicken Sie auf Speichern, um Ihre Filterdefinitionen zu bestätigen.

  8. Wählen Sie in der Symbolleiste Ihrer Paketdefinition die Option Build aus.

  9. Wählen Sie in der Symbolleiste Ihres Pakets die Option Herunterladen aus.

Verwenden von Workflows zum Verarbeiten von Formularübermittlungen

Sie können ein Formular so konfigurieren, dass es durch den ausgewählten Workflow verarbeitet wird. Wenn Benutzer das Formular übermitteln, wird eine neue Workflow-Instanz mit den Daten der Formularübermittlung als Nutzlast erstellt.

Gehen Sie folgendermaßen vor, um den Workflow zur Verwendung mit Ihrem Formular zu konfigurieren:

  1. Erstellen Sie eine neue Seite und öffnen Sie sie zur Bearbeitung.

  2. Fügen Sie der Seite die Komponente Formular hinzu.

  3. Konfigurieren Sie die Komponente Formular-Start, die auf der Seite angezeigt wird.

  4. Verwenden Sie Workflow starten , um den gewünschten Workflow aus den verfügbaren auszuwählen:

    wf-12

  5. Bestätigen Sie die neue Formularkonfiguration durch Klicken auf das Häkchen-Symbol.

Testen von Workflows

Beim Testen eines Workflows ist es sinnvoll, verschiedene Nutzlasttypen zu verwenden, auch solche, die sich von denen unterscheiden, für die der Workflow entwickelt wurde. Wenn Sie beispielsweise möchten, dass Ihr Workflow für die Verwendung mit Assets ausgelegt ist, testen Sie ihn, indem Sie eine Seite als Nutzlast festlegen und sicherstellen, dass keine Fehler auftreten.

Testen Sie Ihren neuen Workflow beispielsweise wie folgt:

  1. Starten Sie Ihr Workflow- Modell über die Konsole.

  2. Definieren Sie die Nutzlast und bestätigen Ihre Eingaben.

  3. Ergreifen Sie die erforderlichen Maßnahmen, damit der Workflow fortgesetzt wird.

  4. Überwachen Sie während der Ausführung des Workflows die Protokolldateien.

Sie können AEM auch so konfigurieren, dass die DEBUG-Meldungen in den Protokolldateien angezeigt werden. Weitere Informationen finden Sie unter Protokollierung . Wenn die Entwicklung abgeschlossen ist, setzen Sie Protokollebene zurück auf Info.

Beispiele

Beispiel: Erstellen eines (einfachen) Workflows zum Annehmen oder Ablehnen einer Anfrage zur Veröffentlichung

Um einige der Möglichkeiten zur Erstellung eines Workflows zu veranschaulichen, wird im folgenden Beispiel eine Variante des Workflows Publish Example erstellt.

  1. Erstellen Sie ein neues Workflow-Modell.

    Der neue Workflow umfasst Folgendes:

    • Prozessstart
    • Step 1
    • Prozessende
  2. Löschen Sie Step 1 (da dies der falsche Schritttyp für dieses Beispiel ist):

    • Klicken Sie auf den Schritt und wählen Sie Löschen aus der Komponenten-Symbolleiste aus. Bestätigen Sie die Aktion.
  3. Ziehen Sie aus der Auswahl Workflow des Schrittbrowsers einen Teilnehmer-Schritt auf den Workflow und positionieren Sie ihn zwischen Flow Start und Flow End.

  4. So öffnen Sie das Dialogfeld "Eigenschaften":

    • Klicken Sie auf den Teilnehmer-Schritt und wählen Sie Konfigurieren in der Komponenten-Symbolleiste aus.
    • Doppelklicken Sie auf den Teilnehmer-Schritt.
  5. Geben Sie auf der Registerkarte Common Validate Content sowohl für Title als auch für Description ein.

  6. Öffnen Sie die Registerkarte Benutzer/Gruppe:

    • Aktivieren Sie das Kontrollkästchen Benachrichtigen Sie den Benutzer per E-Mail.
    • Wählen Sie Administrator ( admin) für das Feld Benutzer/Gruppe aus.
    HINWEIS

    Damit E-Mails versendet werden können, müssen der E-Mail-Dienst und die Benutzerkontoinformationen konfiguriert werden.

  7. Bestätigen Sie Ihre Änderungen durch Klicken auf das Häkchen-Symbol.

    Sie werden zur Übersicht des Workflow-Modells zurückgeleitet. Hier wurde der Teilnehmer-Schritt in Validate Content umbenannt.

  8. Ziehen Sie eine oder Aufspaltung in den Workflow und positionieren Sie sie zwischen Validate Content und Flussende.

  9. Öffnen Sie die ODER-Teilung zur Konfiguration.

  10. Konfigurieren:

    • Häufig: Wählen Sie 2 Verzweigungen aus.
    • Zweig 1: Wählen Sie Standardroute aus.
    • Zweig 2: Stellen Sie sicher, dass Standardroute nicht ausgewählt ist.
  11. Bestätigen Sie Ihre Änderungen an der ODER-Teilung.

  12. Ziehen Sie einen Teilnehmer-Schritt auf den linken Zweig, öffnen Sie die Eigenschaften, geben Sie die folgenden Werte an und bestätigen Sie die Änderungen:

    • Titel: Reject Publish Request
    • Benutzer/Gruppe: z. B. projects-administrators
    • Benutzer per E-Mail benachrichtigen: Aktivieren Sie diese Option, damit der Benutzer per E-Mail benachrichtigt wird.
  13. Ziehen Sie einen Prozessschritt auf den rechten Zweig, öffnen Sie die Eigenschaften, geben Sie die folgenden Werte an und bestätigen Sie die Änderungen:

    • Titel: Publish Page as Requested
    • Prozess: auswählen Activate Page. Mit diesem Prozess wird die ausgewählte Seite in den Publisher-Instanzen veröffentlicht.
  14. Klicken Sie in der Editor-Symbolleiste auf Sync, um das Laufzeitmodell zu generieren.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

    Ihr neues Workflow-Modell sieht dann wie folgt aus:

    wf-13

  15. Wenden Sie diesen Workflow auf Ihre Seite an, sodass Benutzer, die zur Phase Fertig stellen übergehen, den Schritt Inhalt überprüfen auswählen können, egal ob sie die Seite wie angefordert veröffentlichen oder die Anfrage zur Veröffentlichung ablehnen möchten.

    chlimage_1-182

Beispiel: Definieren einer Regel für eine ODER-Teilung

ODER-Teilung-Schritte ermöglichen es Ihnen, bedingte Verarbeitungspfade in Ihren Workflow einzubinden.

So definieren Sie eine ODER-Regel:

  1. Erstellen Sie zwei Skripte und speichern Sie diese im Repository, beispielsweise unter:

    /apps/myapp/workflow/scripts

    HINWEIS

    Die Skripte müssen über eine Funktion check() verfügen, die einen booleschen Wert zurückgibt.

  2. Bearbeiten Sie den Workflow und fügen Sie die ODER-Teilung zum Modell hinzu.

  3. Bearbeiten Sie die Eigenschaften von Zweig 1 der ODER-Teilung:

    • Definieren Sie dies als Standardroute, indem Sie den Wert auf true setzen.

    • Legen Sie als Regel den Pfad zum Skript fest. Beispiel:

      /apps/myapp/workflow/scripts/myscript1.ecma

    HINWEIS

    Sie können die Reihenfolge der Verzweigungen bei Bedarf ändern.

  4. Bearbeiten Sie die Eigenschaften von Zweig 2 der ODER-Teilung:

    • Legen Sie als Regel den Pfad zum anderen Skript fest. Beispiel:

      /apps/myapp/workflow/scripts/myscript2.ecma

  5. Legen Sie die Eigenschaften der einzelnen Schritte in jedem Zweig fest. Stellen Sie sicher, dass Benutzer/Gruppe festgelegt ist.

  6. Klicken Sie in der Editor-Symbolleiste auf Sync, um Ihre Änderungen am Laufzeitmodell beizubehalten.

    Weitere Informationen finden Sie unter Synchronisieren von Workflows.

Funktion Check()

HINWEIS

Weitere Informationen finden Sie unter Verwenden von ECMAScript.

Das folgende Beispielskript gibt true zurück, wenn der Knoten ein JCR_PATH ist, der sich unter /content/we-retail/us/en befindet:

function check() {
    if (workflowData.getPayloadType() == "JCR_PATH") {
      var path = workflowData.getPayload().toString();
      var node = jcrSession.getItem(path);

      if (node.getPath().indexOf("/content/we-retail/us/en") >= 0) {
       return true;
      } else {
       return false;
      } 
     } else {
      return false;
     }
}

Beispiel: Benutzerdefinierte Aktivierungsanfrage

Sie können jeden der vorkonfigurierten Workflows anpassen. Um das Verhalten anzupassen, überlagern Sie Details des entsprechenden Workflows.

Beispielsweise der Workflow Aktivierungsanfrage. Dieser wird für die Veröffentlichung von Seiten innerhalb von Sites verwendet und automatisch ausgelöst, wenn ein Inhaltsautor nicht über die entsprechenden Replikationsrechte verfügt. Weitere Informationen finden Sie unter Anpassen der Seitenbearbeitung - Anpassen des Aktivierungsanfrage-Workflows .

Auf dieser Seite