メタデータプロファイル

メタデータプロファイルを使用すると、フォルダー内のアセットに初期設定のメタデータを適用できます。メタデータプロファイルを作成し、フォルダに適用します。その後フォルダにアップロードするアセットは、メタデータプロファイルで設定した初期設定のメタデータを継承します。

メタデータプロファイルの追加

  1. AEMロゴをタップまたはクリックし、ツール/アセット/メタデータプロファイル​に移動し、作成​をタップします。

  2. メタデータプロファイルのタイトル(「サンプルメタデータ」など)を入力し、「送信」をクリックします。メタデータプロファイルの​フォーム​を編集が表示されます。

    chlimage_1-480

  3. コンポーネントをクリックし、「設定」タブでプロパティを設定します。例えば、説明​コンポーネントをクリックして、そのプロパティを編集します。

    chlimage_1-481

    説明​コンポーネントについて、次のプロパティを編集します。

    • フィールドラベル:メタデータプロパティの表示名です。ユーザーの参照用のみで使用します。
    • プロパティにマップ:このプロパティの値は、リポジトリに保存されるアセットノードの相対パス/名前を提供します。この値は常にと開始する必要があります。これは、パスがアセットのノード下にあることを示している ./ からです。

    chlimage_1-482

    プロパティにマッピング」に指定した値は、アセットのメタデータノード下のプロパティとして保存されます。例えば、「プロパティにマッピング」の名前として /jcr:content/metadata/dc:desc を指定した場合、AEM Assets はアセットのメタデータノードに値 dc:desc を保存します。

    • デフォルト値:メタデータコンポーネントのデフォルト値を追加するには、このプロパティを使用します。例えば、「My description」と指定すると、この値がアセットのメタデータノードの dc:desc プロパティに割り当てられます。

    chlimage_1-483

    メモ

    新しいメタデータプロパティにデフォルト値を追加します(にまだ存在しない)。 /jcr:content/metadata ノード)は、デフォルトでは、アセットのプロパティページにプロパティとその値を表示しま ​せん。アセットのプロパティページで新しいプロパティを表示するには、対応するスキーマフォームを変更します。

  4. (オプション)「フォームを作成」タブから「フォームを編集」に追加追加のコンポーネントを追加し、「設定」タブでプロパティを設定します。次のプロパティは、「フォームを作成」タブから使用できます。

コンポーネント プロパティ
セクションヘッダー フィールドラベル、
説明
1 行のテキスト フィールドラベル,
プロパティにマップ,
デフォルト値
複数値テキスト フィールドラベル,
プロパティにマップ,
デフォルト値
数値 フィールドラベル,
プロパティにマップ,
デフォルト値
日付 フィールドラベル,
プロパティにマップ,
デフォルト値
標準タグ フィールドラベル,
プロパティにマップ,
既定値,
説明

chlimage_1-484

  1. 完了」をクリックします。メタデータプロファイルは、メタデータプロファイル​ページのプロファイルのリストに追加されます。

    chlimage_1-485

メタデータプロファイルのコピー

  1. メタデータプロファイル​ページから、プロファイルを選択してコピーします。

    chlimage_1-486

  2. ツールバーの​コピー​をクリックします。

  3. メタデータプロファイルをコピー」ダイアログで、プロファイルの新しいコピーのタイトルを入力します。

  4. コピー」をクリックします。プロファイルのコピーが、メタデータプロファイル​ページのプロファイルのリストに表示されます。

    chlimage_1-487

メタデータプロファイルの削除

  1. メタデータプロファイル​ページで、削除するプロファイルを選択します。

    chlimage_1-488

  2. ツールバーの​メタデータプロファイル​を削除をクリックします。

  3. ダイアログボックスで、「削除」をクリックして削除操作を確定します。 メタデータプロファイルがリストから削除されます。

フォルダーへのメタデータプロファイルの適用

フォルダーにメタデータプロファイルを割り当てると、サブフォルダーは自動的に親フォルダーのプロファイルを継承します。つまり、フォルダーに適用できるのは 1 つのメタデータプロファイルのみとなります。そのため、アセットをアップロード、保存、使用およびアーカイブする場所のフォルダー構造については入念に検討してください。

フォルダーに異なるメタデータプロファイルを割り当てた場合、新しいプロファイルが以前のプロファイルよりも優先されます。以前に存在していたフォルダーのアセットは変更されずに維持されます。新しいプロファイルは、その後にフォルダーに追加されるアセットに対して適用されます。

プロファイルが割り当てられているフォルダーは、ユーザーインターフェイスでカード名にプロファイルの名前が表示されます。

chlimage_1-489

特定のフォルダーまたはすべてのアセットにグローバルにメタデータプロファイルを適用できます。

特定のフォルダーへのメタデータプロファイルの適用

ツール​メニュー内から、またはフォルダー内にいる場合は「プロパティ」から、メタデータプロファイルをフォルダーに適用できます。この節では、メタデータプロファイルをフォルダーに適用する両方の方法について説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

プロファイルユーザーインターフェイスからのフォルダーへのメタデータプロファイルの適用

  1. AEM のロゴをタップし、ツール/アセット/メタデータプロファイル​に移動します。

  2. 1 つまたは複数のフォルダーに適用するメタデータプロファイルを選択します。

    chlimage_1-490

  3. メタデータプロファイルをフォルダーに適用」をタップし、新たにアップロードしたアセットを受け取る 1 つまたは複数のフォルダーを選択して、「完了」をタップします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

「プロパティ」からのフォルダーへのメタデータプロファイルの適用

  1. 左側のレールで、「アセット」をタップし、メタデータプロファイルを適用するフォルダーに移動します。

  2. チェックマークをタップして対象のフォルダーを選択し、「プロパティ」をタップします。

  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューからプロファイルを選択して、「保存」をクリックします。

    chlimage_1-491

    既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

メタデータプロファイルのグローバルな適用

特定のフォルダーにプロファイルを適用できるだけでなく、グローバルにプロファイルを適用することもできます。これにより、AEM Assets にアップロードされている、すべてのフォルダー内にあるすべてのコンテンツに、選択したプロファイルを適用できます。メタデータプロファイルをグローバルに適用するには、次の手順に従います。

  1. 次のいずれかの操作をおこないます。

    • https://[aem_server]:[port]/mnt/overlay/dam/gui/content/assets/foldersharewizard.html/content/damに移動し、適切なプロファイルを適用して、「保存」をタップまたはクリックします。

      chlimage_1-492

    • CRXDE Lite で、/content/dam/jcr:content ノードに移動します。プロパティ metadataProfile:/etc/dam/metadata/dynamicmedia/<name_of_metadata_profile> を追加し、「すべて保存」をタップします。

      chlimage_1-493

フォルダからのメタデータプロファイルの削除

フォルダーからメタデータプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

ツール​メニュー内で、またはフォルダー内にいる場合は「プロパティ」で、メタデータプロファイルをフォルダーから削除できます。この節では、メタデータプロファイルをフォルダーから削除する両方の方法について説明します。

プロファイルユーザーインターフェイスを使用して、フォルダーからメタデータプロファイルーを削除

プロファイルのユーザーインターフェイスを介して、フォルダからメタデータプロファイルを削除するには、次の手順に従います。

  1. AEM のロゴをタップし、ツール/アセット/メタデータプロファイル​に移動します。

  2. 1 つまたは複数のフォルダーから削除するメタデータプロファイルを選択します。

  3. フォルダーからメタデータプロファイルーを削除」をタップし、プロファイルーの削除に使用するフォルダーまたは複数のフォルダーを選択して、「完了」をタップします。

    名前がフォルダー名の下に表示されなくなっていることで、メタデータプロファイルがフォルダーに適用されていないことを確認できます。

プロパティを使用して、フォルダーからメタデータプロファイルを削除します

  1. AEM のロゴをタップして「アセット」に移動した後、メタデータプロファイルを削除するフォルダーに移動します。
  2. チェックマークをタップして対象のフォルダーを選択し、「プロパティ」をタップします。
  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューから「なし」を選択します。 「保存」をタップします。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

このページ

Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now