成像转码库

Adobe的图像转码库是专有的图像处理解决方案,可以执行核心图像处理功能,包括:

  • 编码
  • 转码(转换支持的格式)
  • 使用PS和英特尔IPP算法重新取样图像
  • 位深度和颜色用户档案保留
  • JPEG质量压缩
  • 调整图像大小

成像转码库提供CMYK支持和完全Alpha支持,CMYK -Alpha除外。

除了支持各种文件格式和用户档案之外,在性能、可伸缩性和质量方面,成像转码库还比其他第三方解决方案具有显着优势。 以下是使用图像转码库的一些主要优势:

  • 随文件大小或分辨率的增加进行缩放:扩展主要通过图像转码库的专利功能实现,在对文件进行解码时重新调整大小。此功能可确保运行时内存使用始终是最佳的,而不是增加文件大小或分辨率百万像素的二次型函数。 成像转码库可以处理更大、高分辨率(包含更高百万像素)的文件。 第三方工具(如ImageMagick)在处理此类文件时无法处理大文件并崩溃。
  • Photoshop品质压缩和调整大小算法:在缩减采样质量(平滑、锐利和自动双立方)和压缩质量方面与行业标准一致。成像转码库进一步评估输入图像的品质因子,并智能地使用输出图像的最佳表和品质设置。 此功能可生成最佳大小的文件,而不会影响视觉质量。
  • 高吞吐量: 响应时间较短,吞吐量始终高于ImageMagick。因此,图像转码库应减少用户的等待时间和托管成本。
  • 借助并发负载实现更好的扩展: 成像转码库在并发负载条件下表现最佳。它提供高吞吐量,同时具有最佳CPU性能、内存使用和低响应时间,有助于降低托管成本。

支持的平台

图像转码库仅适用于RHEL 7和CentOS 7分发。

注意

不支持Mac OS和其他*nix分发(例如,Debian和Ubuntu)。

使用

成像转码库的命令行参数可以包括:

 -destMime PNG/JPEG: Mime type of output rendition
 -BitDepth 8/16: Preserves Bit Depth. Bitdepth ‘4’ is automatically converted to ‘8’
 -preserveBitDepth: Downscales Bit Depth (No upscaling)
 -preserveCMYK: Preserves CMYK color space
 -jpegQuality: Provides jpeg quality parameter (0-12 , corresponding to Photoshop qualities)
 -ResamplingMethod BiCubic/Lanczos/PSBicubic: Provides resampling methods. PSBicubic is a Photoshop quality resampling method.
 -resize

可以为-resize参数配置以下选项:

  • X: Works similar to AEM. For example -resize 319.

  • WxH: Aspect Ratio will not be maintained, For example -resize 319X319.

  • Wx: Fixes the width and calculates the height maintaining the aspect ratio. For example -resize 319x.

  • xH: Fixes the height and calculates the width maintaining the aspect ratio. For example -resize x319.

 -AllowUpsampling (Resizes smaller images)
 -input <fileName>
 -output <fileName>

配置映像转码库

要配置ITL处理,请创建配置文件并更新工作流以执行它。

为提取的包创建配置文件

要配置库,请创建.conf文件,以通过以下步骤指示库。 您需要管理员或根权限。

  1. 从软件分发🔗下载映像转码库包,并使用包管理器安装它。 该包与AEM 6.5兼容。

  2. 要了解com.day.cq.dam.cq-dam-switchengine的捆绑id,请登录到Web控制台,然后点按​OSGi > Bundles。 或者,要打开捆绑包控制台,请访问https://[aem_server:[port]/system/console/bundles/ URL。 找到com.day.cq.dam.cq-dam-switchengine包及其ID。

  3. 通过使用命令ls -la /aem64/author/crx-quickstart/launchpad/felix/bundle<id>/data/binaries/检查文件夹,确保提取所有所需的库,其中文件夹名称是使用捆绑ID构建的。 例如,如果bundle id为588,则命令为ls -la /aem64/author/crx-quickstart/launchpad/felix/bundle588/data/binaries/

  4. 创建SWitchEngineLibs.conf文件以链接到库。

    cd `/etc/ld.so.conf.d`
    touch SWitchEngineLibs.conf
    vi SWitchEngineLibs.conf
    
  5. 使用cat SWitchEngineLibs.conf命令向conf文件添加/aem64/author/crx-quickstart/launchpad/felix/bundle<id>/data/binaries/路径。

  6. 执行ldconfig命令以创建必要的链接和缓存。

  7. 在用于开始AEM的帐户中,编辑.bash_profile文件。 通过添加以下内容添加LD_LIBRARY_PATH

    LD_LIBRARY_PATH=.
    export LD_LIBRARY_PATH
    
  8. 要确保路径的值设置为.,请使用echo $LD_LIBRARY_PATH命令。 输出应该只是.。 如果该值未设置为.,请重新启动会话。

配置DAM更新资产工作流

更新DAM更新资产工作流,以使用库处理图像。

  1. 点按/单击 AEM 徽标,然后转到​工具 > 工作流 > 模式

  2. 从​工作流模型​页面,在编辑模式下打开​DAM更新资产​工作流模型。

  3. 打开​处理缩略图​工作流处理步骤。 在​缩略图​选项卡中,添加要在​跳过MIME类型​列表中跳过默认缩略图生成过程的MIME类型。
    例如,如果要使用图像转码库创建TIFF图像的缩览图,请在​跳过MIME类型​字段中指定image/tiff

  4. 在​启用Web的图像​选项卡中,添加要在​跳过列表​中跳过默认Web再现生成过程的MIME类型。 例如,如果您在上述步骤中跳过了MIME类型image/tiff,请将image/tiff添加到跳过列表。

  5. 打开​EPS缩略图(由ImageMagick提供)​步骤,导航到​参数​选项卡。 在​Mime类型​列表中,添加您希望映像转码库处理的MIME类型。 例如,如果您跳过了上述步骤中的MIME类型image/tiff,请将image/jpeg添加到​Mime类型​列表。

  6. 如果存在默认命令,请删除该命令。

  7. 切换侧面板,从步骤列表添加​SWitchEngine处理程序

  8. 根据您的自定义要求向SwitchEngine处理程序添加命令。 调整您为满足您的要求而指定的命令参数。 例如,如果要保留JPEG图像的颜色用户档案,请向​Commands​列表添加以下命令:

    • SWitchEngine -input ${file} -destMime PNG -resize 48 -output ${directory}cq5dam.thumbnail.48.48.png
    • SWitchEngine -input ${file} -destMime PNG -resize 140x100 -output ${directory}cq5dam.thumbnail.140.100.png
    • SWitchEngine -input ${file} -destMime PNG -resize 319 -output ${directory}cq5dam.thumbnail.319.319.png
    • SWitchEngine -input ${file} -destMime JPEG -resize 1280 -preserveCMYK -output ${directory}cq5dam.web.1280.1280.jpeg

    奇利马

  9. (可选)使用单个命令从中间再现生成缩略图。 中间再现用作源,以生成静态和Web再现。 此方法比以前的方法快。 但是,无法使用此方法将自定义参数应用于缩略图。

    奇利马

  10. 要生成Web再现,请在​启用Web的图像​选项卡中配置参数。

  11. 同步更新的DAM更新资产工作流模型。 保存工作流。

验证配置、上传TIFF图像并监视error.log文件。 您会注意到INFO消息中提及SwitchEngineHandlingProcess execute: executing command line。 日志中提到生成的演绎版。 工作流完成后,您可以在AEM中视图新演绎版。

On this page