Problema di installazione del pacchetto su AEMaaCS

Ultimo aggiornamento: 2023-11-08

Se ricevi un errore durante l’installazione di un pacchetto su AEMaaCS, potrebbe contenere un percorso immutabile. Questo articolo ti aiuterà a correggere l’errore e a installare correttamente il pacchetto.

Descrizione

Ambiente

Experience Manager as a Cloud Service

Problema/Sintomi

Quando si tenta di installare un pacchetto in un’istanza di AEM as a Cloud Service (AEMaaCS), il cliente riceve il messaggio di errore:

Il pacchetto (o i relativi pacchetti secondari) contiene contenuto dell’applicazione non supportato in fase di esecuzione.

Il pacchetto può essere installato correttamente su un’istanza locale o su un SDK locale.

Risoluzione

Il pacchetto che il cliente sta tentando di installare contiene /apps e non può essere caricato in un’istanza di AEMaaCS tramite il gestore di pacchetti se contiene un percorso immutabile.
In fase di runtime solo le aree mutabili come /content, /conf, ecc. possono essere modificati.

Questo pacchetto deve essere distribuito tramite pipeline di cloud manager, incorporandola nella tutto modulo.

Inoltre, assicurati che un pacchetto di terze parti sia compatibile con Cloud Service.

In questa pagina