Experience Manager: Validar la versión del paquete OSGi después de las actualizaciones

Última actualización: 2023-11-22

Compruebe la versión del paquete OSGi después de una actualización para confirmar que la instalación se ha realizado correctamente. Siga los pasos mencionados a continuación.

Descripción

Problema

Debe comprobar la versión del paquete OSGi después de una actualización para confirmar que la instalación se ha realizado correctamente.

Resolución

Pasos a resolver

  1. Copiar/pegar el JSON de *http://aemhost1:port/*system/console/bundles.json a la JSON real campo de texto.
  2. Seleccionar Versión del producto versión menor en los dos menús desplegables para rellenar automáticamente la variable JSON esperado campo AEM o bien, copie/pegue el JSON de otra instancia de en JSON esperado campo (también de *http://aemhost2:port/*system/console/bundles.json).
  3. Clic Comparar para ver la diferencia.
  4. Los paquetes similares se muestran en blanco, las distintas versiones de los paquetes se muestran en amarillo, los paquetes recién añadidos se muestran en aguamarina y los paquetes eliminados en rojo claro.
  5. Filtre los datos con la variable Filtrar cuadro.

Versión del producto:          AEM AEM AEM Seleccione la versión principalAEM 6.5 6.4 6.3 6.2 Seleccione la versión secundaria
JSON de /system/console/bundles.json
JSON real 
JSON esperado
 
Resultados de la comparación
 Filtro:          Todos los cambios añadidos eliminados similares     

Nombre simbólico Nombre de paquete Número de versión esperado Número de versión real

* Gracias a Sham Sundar Hassan Chikkegowda para proporcionar el original código fuente para esta herramienta.  Su sitio personal se puede visitar aquí.

En esta página