AEM : La version du lot OOTB est inférieure à ce qui était prévu.

Dernière mise à jour : 2022-09-29

Description

Problème

Dans la console OSGi, il existe un lot dont la version est inférieure à celle attendue pour le SP/CFP installé. Ce problème ne serait pas un problème isolé. En règle générale, un événement critique se produit (par exemple, un échec de connexion AEM) et une enquête le révèle comme une cause intermédiaire.

Cause

Il est possible que la mise à jour du lot ait échoué lors de l’installation SP/CFP. L’une des causes possibles de l’échec de la mise à jour est qu’une personne a commencé AEM en tant qu’utilisateur root avant et après avoir commencé en tant qu’utilisateur normal. Lors de l’exécution en tant qu’utilisateur root, crx-quickstart/launchpad/felix/bundleXX était détenu par root. Au moment de l’installation du SP/CFP, AEM qui s’exécute car l’utilisateur ordinaire ne peut pas écrire sous bundleXX, la mise à jour du bundle a échoué.

Résolution

Vérifiez le propriétaire du fichier/répertoire sous crx-quickstart. Si un fichier/répertoire n’est pas détenu par l’utilisateur ordinaire pour AEM processus, procédez comme suit.

(1) Arrêtez AEM.

(2) Remplacez le propriétaire par l’utilisateur ordinaire.

(3) Démarrez AEM.

(4) Réinstallez le SP/CFP.

Sur cette page