AEM: La versión del paquete OOTB es inferior a la esperada

Última actualización: 2022-09-29

Descripción

Problema

En la consola OSGi OSGi Bundles, hay un paquete cuya versión es inferior a la esperada para el SP/CFP instalado. Este problema no se trataría de un solo problema. Por lo general, algo crítico sucede (por ejemplo, AEM fallo de inicio de sesión) y la investigación revela esto como una causa intermedia.

Causa

Posiblemente, la actualización del paquete falló en la instalación de SP/CFP. Una de las posibles causas del error en la actualización es que alguien comenzó AEM como usuario raíz antes y después comenzó como usuario normal. Durante la ejecución como usuario raíz, crx-quickstart/launchpad/felix/bundleXX era propiedad de root. En el momento de la instalación de SP/CFP, AEM que se está ejecutando como el usuario normal no puede escribir en bundleXX, entonces la actualización del paquete falló.

Resolución

Compruebe el propietario del archivo/directorio en crx-quickstart. Si algún archivo o directorio no es propiedad del usuario normal para AEM proceso, realice los pasos siguientes.

(1) Detener AEM.

(2) Vuelva a cambiar el propietario al usuario normal.

(3) Iniciar AEM.

(4) Vuelva a instalar el SP/CFP.

En esta página