Creating interactive PDFs
from InDesign.
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InDesign contains many features that help you
format, style, manage, and keep track of the
content in your documents. It's what makes
InDesign so powerful.

Bookmarks and linked TOCs from InDesign.

Improve the reading experience of your PDF files by adding bookmarks and
a table of contents. Learn to use the Table of Contents feature in InDesign to

generate both bookmarks and hyperlinks that will help your readers quickly find
information in your PDF files.

It all starts with Paragraph Styles.

While speaking at Adobe MAX conferences, I've often referred to InDesign as "the
most stylin’ app in the Creative Cloud." Styles in InDesign range from paragraph
and character styles for text to objects and graphic frames—and can also

include tables and table cells, anchored objects, grep statements, nested styles,
hyperlinks—and the list goes on.
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Paragraph styles, however, are key for the Table of Contents feature. Typically,
styles used for headings work the best for a TOC. To create a Paragraph Style,
begin by opening the Paragraph Styles panel from the Window > Styles menu.
Next, select the characters of your headline within your Layout. With the

text still selected, click the Create new style icon in the bottom-right of the
Paragraph Style panel. This will create a style based on the properties of the
text you had selected.

To rename your style or make style changes, double-click the new paragraph
style in the list to open the style options dialog box. Once you finish editing
your style, assign the style to your headline by selecting the characters of
your headline, then selecting the paragraph style form the list of styles in your
Paragraph Styles panel.
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Advanced Tip: If you hold the Option key (Mac) or the Alt key (Windows)
when clicking the create new style icon, the properties dialog box will
immediately open from the Paragraph Styles panel, allowing you to edit the
new style right away.



Choose a location in
your document

Throughout your InDesign document, be sure to apply the Paragraph Style to all
of the headings. Not only will this allow you to make design changes faster, but it
will also help us add bookmarks and interactivity within a PDF file.

Creating a table of contents.

The Table of Contents feature gathers the contents and page numbers of
specific paragraph styles in order to provide a list of the contents included in
your publication. This content is created automatically and can be updated as
your document is edited. While this provides very useful textual information in
regard to finding content, this same information can also be used to make your
document interactive when exporting to PDF.

Other Styles:

Entry Style:
Other Styles:
A Heading

Include Full Paragraph

Choose Layout > Table of Contents to define  Choose the paragraph styles
TOC properties to be included

CONTENTS o

Click-and-drag a new text box that
contains the TOC content, including the
text and page numbers for each included
paragraph style

To begin to create a TOC, find a location in your document where you'd like the
TOC to appear. Next, select Table of Contents from the Layout menu. We'll be
setting a few properties within this dialog box, starting with setting the title to
simply "Contents. In the Styles in Table of Contents section, we'll choose the
paragraph style for our heading and click the Add button.



The Options section of the Table of Contents dialog box includes the Create PDF
Bookmarks option. Checking this option will result in a PDF file that includes
bookmarks that link directly to the corresponding content within the document.
This feature also results in a more structured and searchable PDF file. Bonus!

When finished, click OK to return to your document with a loaded text cursor.
Click to add a new story into your document that includes all of the TOC
information.

Updating the table of contents.

Because the TOC is automatically generated, making changes involves revisiting
the Table of Contents dialog box. To do this, select the TOC text frame in your
layout, then choose Table of Contents from the Layout menu.
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Continue to make edits in this dialog box, including changes to the title, included
paragraph styles, and various options, then click OK. The selected text frame will
update with your new settings. You can update the Table of Contents as often as

you like.

After you have finished designing your document, you'll want to update the TOC
entries and page numbers. Just as we did before, select the TOC text frame, then
choose Update Table of Contents from the Layout menu. This will refresh the
content of the TOC based on all of the settings we defined earlier.

Exporting an interactive PDF.

Now that we have added a TOC to our document, we'll need to make sure we
check the options for Bookmarks and Hyperlinks in the PDF export dialog box.
InDesign provides a few ways to export a PDF file.
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Interactive Elements: Include Appearance

In order to preserve the links in your PDF file,
be sure to include Bookmarks and Hyperlinks
in the Adobe PDF dialog box

If you have created PDF presets in any Creative Cloud application, they will be
available in the File > Adobe PDF Presets menu. You can also use one of two
pre-defined Format presets located in the File > Export menu. These presets are
named Adobe PDF (Print) and Adobe PDF (Interactive).



In the Export Adobe PDF dialog box, be sure to check the options for Bookmarks
and Hyperlinks. These options are automatically checked when choosing
the Adobe PDF (Interactive) option. The resulting PDF file will now contain a
hyperlinked TOC as well as a corresponding Bookmark for each TOC entry.
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Bookmarks and Hyperlinks generated from the Table of Contents
feature of InDesign



Graphical hyperlinks and nested master pages in
InDesign.

Hyperlinks can do more than link to websites. Combining Hyperlinks with Text
and Page Anchors allows you to provide quick access to key areas of your PDF
document. Applying Hyperlinks with Master Pages allows you to quickly manage
a navigation system throughout all of your pages.

Creating hyperlinks in InDesign.

Hyperlinks can be added and managed within InDesign from the Hyperlinks
panel, located under the Window >Interactive menu. To create a hyperlink to
a website, select some text in your layout, then click the Create New Hyperlink
icon. In the New Hyperlink dialog box, choose URL in the Link to dropdown
menu, then enter the full URL, including "http” into the URL field. Choose an
optional Character Style or PDF Appearance if you wish, then click OK. Your
new URL-based hyperlink will show in the list of links associated with the
InDesign Document.
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If you'd like to speed up the Hyperlink creation process, simply select some text,
then add a full website URL into the URL field in the Hyperlinks panel and press
Return. This will create a new hyperlink with all of the previously used settings.

Creating page and text anchors.

Text and Page Anchors provide you with a way to add an invisible object or
destination point within your InDesign document. These anchors can be set as
the target or destination of a hyperlink. What's even more useful is that these
anchors move with the page or text that they are assigned to—so if you add or
remove pages or text, your hyperlinks will still go to the correct destination.

To create a page anchor, navigate to the desired page in InDesign, then select
New Hyperlink Destination from the Hyperlink panel’s fly-out menu. The New
Hyperlink Destination dialog box will default to setting the type of destination to
a Page, and the name and page number of the document will match the page
you are currently viewing. There is also an option to change the zoom setting of
the page when a reader goes to this anchor in the resulting PDF.
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You can change the name of the Page anchor to make it easier to locate later. In
the example above, I'll keep the name that was automatically generated form my
selected text.



Advanced Tip: You do not need to navigate to a specific page in InDesign before
creating Page anchors. It is possible to set all of your page anchors from the
Hyperlinks panel while viewing any page in your document. Once you define a
New Hyperlink Destination, choose your desired page number form the page
dropdown menu.

Text anchors work a lot like page anchors, except they are inserted into the text
of your document. To create a text anchor, select some text within your InDesign
document, such as a heading, then choose the New Hyperlink Destination item
from the Hyperlinks panel fly-out menu.
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The selected text will be the default name given to your new text anchor. You
can rename your text anchor, and keep in mind that each text anchor needs

a unique name. If you want to see exactly where your text anchor is being
assigned, you can see it in the story editor. With either the text frame selected, or
some text selected, choose Edit in Story Editor from the Edit menu. In the editor
you'll see a small target icon that represents the text anchor.



Linking to page and text anchors.

Now that we have some page and text anchors in our document, we can now

make hyperlinks that will link to those internal destinations. I'll start by selecting
some textin my layout, then adding a hyperlink to that text by clicking the Create
New Hyperlinkicon in the Hyperlinks panel. In the dialog box, I'll change the Link

To option to a Text Anchor, then select the text anchor I'd like to link to from the
Text Anchor dropdown menu.
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Hyperlinks can be applied to objects, as well as text, within your InDesign
document. This means we can link graphic objects to Page or Text Anchors. This

technique allows you to provide a more visual navigation system to your PDF
file, while maintaining compatibility across all devices.
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Interactive Elements: Include Appearance

In order to preserve the links in your PDF file,
be sure to include Bookmarks and Hyperlinks

in the Adobe PDF dialog box

First, I'll create a new Master Page named "C-Nav," then I'llimport a checklist
graphic from Illustrator. Next, I'll select the graphic, and add a hyperlink that links
to a Text Anchor | created for the Checklist page. I'll repeat the process to create a
series of links that go to the first, contents, and the contact pages.
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In order to preserve the links in your PDF file,
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Now, to apply the navigation master page to other master pages, we'll make use
of InDesign’s ability to nest one master page into another. To achieve this, I'll click
and drag the C-Nav master page icon and drop it directly on top of the two other
master pages. This will, in turn, combine the navigation elements of master page

C with the elements of master pages A and B.



Watch these features in action.

Join Chris Converse in the recorded webinar and learn how to use features such as
Table of Contents, Hyperlinks, and Nested Styles and Nested Master Pages to create
a user-friendly interactive PDF desktop computers and mobile devices.

In this session you'll learn the following:

- Design documents for better usability

- Use advanced styles for greater control

- Add interactive content such as hyperlinks
- Create Paragraph and Character Styles

- Define and update a Table of Contents for your document

Adobe Creative Cloud e-Learning Series
Watch the live recording here:

Creating interactive PDFs from InDesign
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