Adobe Commerce access keys

NOTE

The Upgrade Compatibility Tool is available for Adobe Commerce instances only.

You must have Adobe Commerce access keys to download and use the Upgrade Compatibility Tool. Add your Adobe Commerce access keys to your auth.json file, which is located at ~/.composer by default.

NOTE

Check your COMPOSER_HOME environment variable to see where the auth.json file is located.

The public key corresponds to the username whereas the private key is the password:

Example of Adobe Commerce access keys

    "http-basic": {
        "repo.magento.com": {
            "username": "YOUR_MAGENTO_PUBLIC_KEY",
            "password": "YOUR_MAGENTO_PRIVATE_KEY"
        }
    },
NOTE

If you do not correctly configure your Adobe Commerce access keys, you cannot download the Upgrade Compatibility Tool and the composer create-project command will fail.

Run composer install in your terminal to install dependencies.

System requirements

The minimum requirements to use the Upgrade Compatibility Tool in a command-line interface are:

Requirements Constraints
PHP version >= 7.3
Composer no known requirement.
Node.js Node.js versions ^12.22.0, ^14.17.0, or >=16.0.0 (see Install Node.js)
Memory limitations At least 2GB RAM.

Adobe Commerce is only supported on Linux operating systems. You can run the Upgrade Compatibility Tool in a Linux OS. You do not have to run the Upgrade Compatibility Tool where your Adobe Commerce instance is located.

It is necessary for the Upgrade Compatibility Tool to have access to the source code of the Adobe Commerce instance. For example, you can install it on one server and point it at your Adobe Commerce installation on another server.

If you are running the Upgrade Compatibility Tool against an Adobe Commerce instance with large modules and files, the tool might require a high amount of RAM (at least 2GB).

On this page