Store Fulfillment requirements for Adobe Commerce

You must meet the following technical and business requirements to install and enable the Store Fulfillment solution for Adobe Commerce.

Platform and software version requirements

The Store Fulfillment solution is available to Adobe Commerce customers on the following platforms.

  • Adobe Commerce on cloud infrastructure (ECE)
  • Adobe Commerce on premises (EE)

The Store Fulfillment solution is compatible with the following software versions.

Software Compatibility

Software Minimum Version Maximum Version
Adobe Commerce 2.4.0 2.4.4
Composer 1.x 2.x
MariaDB 10.2 10.4
MySQL 5.7 8.0
PHP 7.4 8.1

For detailed requirements, review the Adobe Commerce System requirements in the Developer documentation.

Store Assist app requirements

The end-to-end process to manage store pickup orders is managed through the Store Assist app installed on mobile devices. These devices—provided by the retailer or by store employees using their personal smart phones—must meet the following requirements:

Minimum operating system requirements

  • Android 6
  • iOS 12

Minimum hardware requirements

  • 1GB RAM
  • 600MB free disk space

Business requirements

Your business must meet the following minimum criteria to implement the Store Fulfillment solution.

  • US-based businesses only

  • B2C Retailers, CPG Manufacturers selling D2C, or distributors selling D2C or to small businesses

  • At least one physical store or warehouse

  • Manage your product inventory with Inventory Management for Adobe Commerce (aka MSI)

  • Ability to syndicate merchant inventory

  • Store Wi-Fi availability at all locations that support the Store Fulfillment solution: 3 Mbps minimum Internet speed

  • Store and warehouse associates have access to iOS or Android mobile devices during their shifts, either personal or provided by the merchant

  • Products managed by using the Store Fulfillment solution must have product attributes that include either a SKU or UPC product code

On this page