Det går inte att spara kontakt som URL-nyckel

Den här artikeln innehåller en lösning på problemet när du inte kan spara contact som en URL-nyckel (t.ex. "/contact") för produkter eller CMS-sidor.

Berörda produkter och versioner

Adobe Commerce (alla distributionsmetoder) 2.4.x

Problem

Du kan inte spara en produkt eller en CMS-sida med termen contact som URL-nyckel. När du försöker spara URL-nyckeln visas ett fel som anger att URL-nyckeln är en dubblett-URL.

Steg som ska återskapas:

Skapa en CMS-sida med kontakt som URL-nyckel.

Förväntat resultat:

Sidan sparas med contact som URL-nyckel.

Faktiskt resultat:

Du kan inte spara sidan. Du får felet: Värdet som anges i fältet URL-nyckel skulle generera en URL som redan finns.

Orsak

Kontakt är ett reserverat ord som definieras i vendor/magento/module-contact/view/frontend/layout/contact_index_index.xml.

<router id="standard">
      <route id="contact" frontName="contact">
          <module name="Magento_Contact" />
      </route>
  </router>

Lösning

Du kan inte använda termen contact som URL-nyckel, men du kan använda termen contact i kombination med en annan bokstav eller siffra (till exempel contact1 och contact2). Även om termen inte behöver vara contact+&lt;ett annat tal eller en annan bokstav>, kan termen vara vilken sträng som helst så länge längden inte överstiger 255 tecken.

Utför följande steg:

  1. Logga in på Commerce Admin.

  2. Gå till Marketing > SEO & Search > URL Rewrites.

  3. Klicka på Add URL Rewrite.

  4. Välj Custom i listrutan Create URL Rewrite.

    1. Skriv "contact" i Request Path. Observera att Request Path är det som en användare anger i webbläsaren och att Target Path är den plats där den ska dirigeras om.
    2. I Target Path skriver du in den nya URL-nyckeln (till exempel "contact1").
    3. Välj No i listrutan Redirect.

Relaterad läsning

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a