Unable to save entity Adobe Commerce backend
This article provides a solution for when you are unable to save an entity in the Adobe Commerce backend. For example, when you cannot edit and save a specific cart_price rule.
Description description
Affected Products and Versions
This issue can affect all Adobe Commerce versions that have Max Session Size configured, including Magento Open Source 2.3.7-p1 and Adobe Commerce (all deployment methods) versions 2.4.9-alpha, 2.4.8, 2.4.7, 2.4.6, 2.4.5, 2.4.4, 2.4.0–2.4.3, as well as Magento Open Source 2.3, 2.2, 2.1, and 2.0.
Issue/Symptoms
When you try to reconfigure your store, the page reloads and your changes are not saved. A message can be seen in var/log/system.log:
[ 2021-11-27 00:30:52] report.WARNING: Session size of 418056 exceeded allowed session max size of 256000. [ ] [ ]
Steps to Reproduce
- Select a rule in the Adobe Commerce store: Production
>Marketing>Cart price rules. - Choose a rule, set it to Inactive, and save the change.
Expected Result
The rule is set to inactive.
Actual Result
The page reloads without any message. The rule remains active.
Cause
This issue is related to new functionality introduced recently that has impacted the Max Session Size. See Session management in our developer documentation.
Resolution resolution
Increase the Max Session Size value in: Stores > Configuration > Advanced > System > Security > Max Session Size.
Related reading
Marketing Menu in our user guide.