1k 以上の製品でカテゴリを保存する際に 504 ゲートウェイタイムアウトエラーが発生する
この記事では、大規模なカテゴリ(1,000 以上の製品)で操作を実行する際のタイムアウトの問題の解決策を提案します。
メモ: この問題は、バージョン 2.4.7 で修正されました。
説明 description
0.5511122
- クラウドインフラストラクチャー上のAdobe Commerce 2.3.3
- Adobe Commerce オンプレミス 2.3.3
- Magento Open Source 2.3.3
問題/症状
前提条件: ストア > 設定 > カタログ > カタログ ストア表示 > 「 製品 URL にカテゴリパスを使用 」オプションを はい に設定する。
再現手順:
- Commerce Admin で、Catalog に移動します。
>カテゴリ 。 - 1000 を超える割り当てられた製品など、大きなカテゴリを開きます。
- カテゴリに製品を追加します。
- カテゴリを保存 をクリックします。
期待される結果:
カテゴリが正常に保存されました。
実際の結果:
保存プロセスを 5 分実行すると、504 ゲートウェイタイムアウトエラーページが表示されます。
根本原因
このプロセスは、サーバーで設定されているタイムアウトよりも長い時間がかかります。
解決策 resolution
「 カテゴリ/製品」 URL 書き換えを生成 」オプションを無効にすると、すべてのカテゴリ/製品 URL 書き換えがデータベースから削除され、大きなカテゴリでの操作に必要な時間が大幅に短縮されます。
警告: このオプションをオフにすると、カテゴリ/製品の URL の書き換えが完全に削除され、復元できなくなります。
「カテゴリ/製品」 URL 書き換えの生成 オプションを無効にするには:
- Commerce管理者で、 ストア に移動します。
>設定>カタログ>カタログ 。 - 設定ページの左上隅にある「 範囲 」フィールドで、設定範囲を デフォルト設定 に設定します。
- 「カテゴリ/製品」 URL 書き換えの生成 を いいえ に設定します。
- 「 設定を保存 」をクリックします。
bash bin/magento cache:cleanを実行するか、Commerce管理の System でキャッシュをクリーンアップします>ツール>キャッシュ管理 。
これで、カテゴリへの製品の追加や、多数の製品を含むカテゴリの移動に進むことができます。これらの操作は時間がはるかに短く、タイムアウトを引き起こすべきではありません。
関連資料
ユーザーガイドの 製品の自動リダイレクト 。
recommendation-more-help
3d58f420-19b5-47a0-a122-5c9dab55ec7f