Elasticsearch is shown as the search engine despite OpenSearch installation

This article provides a solution for the issue where Elasticsearch is still shown as the search engine for Adobe Commerce on cloud even after installing or upgrading to OpenSearch.

Affected versions

Adobe Commerce on cloud 2.4.3-p2 - 2.4.5-p2

NOTE
OpenSearch is available as a search engine starting from Adobe Commerce 2.4.6.

Issue

Elasticsearch is still shown as the search engine for Adobe Commerce on cloud even after installing or upgrading to OpenSearch.

Steps to reproduce:

  1. Go to Stores > Configuration > Catalog > Catalog Search.
  2. Check the search engine. It will show Elasticsearch7.

Cause

Adobe Commerce is hard-coded to specify Elasticsearch7 as the search engine.

Solution

To verify if OpenSearch has been installed, run the following command:

Method 1:

  • Run the following command on server: curl 127.0.0.1:9200. It should return OpenSearch with its version.

Method 2:

  • Use the following command on the Magento-cloud CLI: magento-cloud relationships -p <project_id>. After using the command, locate OpenSearch.

Set up OpenSearch service in the Commerce on Cloud Infrastructure guide.

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