Adobe Campaign 2023 environment upgrades

Last update: 2023-07-31

Campaign infrastructure relies on third-party systems which must be regularly updated with the latest versions and fixes. These updates are mandatory to ensure continuity of service and secure Campaign environments from security risks. In addition, a Campaign upgrade is required to ensure compatibility with third-party system changes.

As a Hosted or Managed Cloud Services customer, Adobe informs you about these upgrades when they are needed. You will be required to upgrade your environments in accordance with the recommendations to ensure compliance.

As an On-premise or Hybrid customer, Adobe highly recommends that you to upgrade your system and Campaign versions according to the same calendar.

For security reasons, you must install the latest Campaign build, and then upgrade your operating system and/or your Relation Database Management System (RDBMS).

NOTE

For any questions about these changes, contact Adobe Customer Care. See also the Build upgrade FAQ.

Campaign build upgrade

Are you impacted?

If you are impacted by the operating system upgrade and/or the database system upgrade detailed below, you must upgrade your Campaign environments to the latest 7.3.2 version, which is compatible with these systems.

How to update?

  • As a hosted or Managed Cloud Services customer, Adobe will contact you and upgrade your Campaign version.
  • As a hybrid customer, Adobe will inform you of the scheduled build upgrade dates for your mid-sourcing environment. You must also upgrade your marketing environment to that same version.
  • As an on-premise customer, you are requested to upgrade your Campaign environments to the latest 7.3.2 build.

Operating system upgrade

Are you impacted?

If you are running Campaign on a Debian operating system, to benefit from latest Debian security updates, you need to move your Campaign infrastructure to Debian 11. Note that security support for Debian 9 will be available until June 30, 2023.

How to update?

  • As a hosted or Managed Cloud Services customer, Adobe will contact you and upgrade your environment.
  • As a hybrid customer, Adobe will inform you of the scheduled upgrade dates for your mid-sourcing environment. If your marketing environment is also running on Debian, you must upgrade it to Debian 11 too.
  • As an on-premise customer, you are requested to upgrade your environments to Debian 11.

Database system upgrade

Are you impacted?

If your database system for Campaign is PostgreSQL, to benefit from latest PostgreSQL innovations and security updates, you need to upgrade to PostgreSQL 14. Note that PostgreSQL 11 will reach End Of Life on November 9, 2023.

How to update?

  • As a hosted or Managed Cloud Services customer, Adobe will contact you and upgrade your database system from PostgreSQL 11 to PostgreSQL 14.
  • As a hybrid customer, if your marketing database system is PostgreSQL, you must upgrade it to PostgreSQL 14.
  • As an on-premise customer, you are requested to upgrade your database system to PostgreSQL 14.

On this page