Compatibility matrix

This document lists all systems and components supported for the latest build of Adobe Campaign Classic. Products and versions that are not part of this list are not compatible with Adobe Campaign.

If you are a Gold Standard user, refer to the Gold Standard Compatibility matrix.

Important notes

Unless mentioned otherwise, all minor releases are supported.

In its latest build, Adobe Campaign Classic is compatible with all the systems and tools listed in this page. As specific versions of these 3rd party systems and tools reach end-of-life (EOL) with their respective creators, Adobe Campaign will no longer be compatible with those versions, and they will be removed from our compatibility matrix in the subsequent product release. Please ensure you are on supported versions of any systems listed in the compatibility matrix to avoid any issues.

To learn more about deprecated items, visit this page.

CAUTION

This matrix is regularly updated with new supported items being added and deprecated items being removed.

Operating Systems

CentOs

8.x (64 bits)

7.x (64 bits)

Debian

10 (64 bits)

9 (64 bits)

8 (64 bits)

RHEL

8.x (64 bits)

7.x (64 bits)

Important: If you are using RHEL, you must be willing to disable SELinux or to have your architects write custom SELinux rules to check that an enabled SELinux is not causing issues with Campaign operations.

Windows Server

2016

2012 R2

2012

Web Servers

Microsoft IIS

10.0 on Windows Server 2016

8.5 on Windows Server 2012 R2

8.0 on Windows Server 2012 - Windows 8

Apache

2.4 for RHEL7 - CentOS 7, Debian 8/9, Windows (64 bits)

Tools

Java Development Kit (JDK)

11

9

8

The application has been approved for the Java Development Kit (JDK) developed by Oracle as well as for OpenJDK.

Libre Office

6 (and previous versions if embedded in your system)

SpamAssassin

3.4.x

RDBMS servers

NOTE

RDBMS driver must match with RDBMS server version.

Oracle

19c

18c

12c

11g R2

PostgreSQL

12.x

11.x

10.x

9.6.x

9.5.x

9.4.x

Note: you can also use Amazon RDS for PostgreSQL with the versions specified above.

SQL Server

2019

2017

2016

2014

2012 - SP1 and SP2

Warning: Microsoft SQL Server is not supported as the primary database when the Campaign server is running on Linux. Learn more.

NOTE

PostgreSQL is the default database server for Hosted environments.

CRM connectors

Salesforce connector API

API version 37

SFDC API

API version 21

API version 15

Oracle On Demand API

Web Services v1.0 API

MS Dynamics

Web API: Dynamics 365 On-premise and Online

Federated Data Access (FDA)

Microsoft Azure Synapse Analytics  
Amazon Redshift

 

Oracle

19c

18c

12c

11g

PostgreSQL

12.x

11.x

10.x

9.6.x

9.5.x

9.4.x

SQL Server

2019

2017

2016

2014

2012 SP1 and SP2

MySQL

5.7

Teradata

16.20

16

15.10

15.0

Netezza

7.2

Sybase

IQ 16

ASE 15.7

SAP HANA

version 1 SPS 12

Hadoop via HiveSQL

HortonWorks HDP 2.4.X, 2.5.x, 2.6.x

HDInsight 3.4 (HDP 2.4), 3.5 (HDP 2.5), 3.6 (HDP 2.6)

Cloudera CDH6.x

Snowflake  

Client Console operating systems

Windows Server

2016

2012

Windows

8

10 (recommended for Japanese instances)

Mobile SDK

Android

7.x, 8.x, 9.0

with mobile SDK build 1.0.27.

iOS

iOS 9 - 14

with mobile SDK build 1.0.26, compatible with 32 and 64-bit versions.

Browsers

For the following browsers, the latest version is supported: Microsoft Edge, Mozilla Firefox, Google Chrome, Safari.

Internet Explorer 11 is supported.

More like this

On this page