Prerequisiti per l’installazione di Campaign in Linux

Prerequisiti software

Questa sezione descrive i passaggi preliminari per le configurazioni necessari prima di installare Adobe Campaign.

La configurazione tecnica e software necessaria per l'installazione Adobe Campaign è dettagliata nella matrice dicompatibilità.

Come promemoria, è necessario installare e configurare correttamente i seguenti componenti:

Nota

Per installare una build inferiore o uguale a 8709 sulle piattaforme CentOS 7 e Debian 8, è necessario abilitare il modulo apache access_compat.

Librerie

Per installare Adobe Campaign in Linux, accertatevi di disporre delle librerie necessarie.

  • La libreria C deve essere in grado di supportare la modalità TLS (Thread Local Storage). Questa modalità è attiva nella maggior parte dei casi, tranne per alcuni kernel per i quali il supporto Xen è stato disattivato.

    Per verificare questo, è possibile utilizzare il nome uname -a | grep xen , ad esempio.

    Se il comando non restituisce nulla (riga vuota), significa che la configurazione è corretta.

  • È necessario disporre della versione 0.9.8 o 1.0 di OpenSSL.

    Per le distribuzioni RHEL 7, è necessaria la versione 1.0 di OpenSSL.

  • Per utilizzare Adobe Campaign, è necessario che sia installata la libreria libicu .

    Sono supportate le seguenti versioni di libicu (32 bit o 64 bit):

    • RHEL 7, CentOS 7: libicu50
    • Debian 8: libicu52
    • Debian 9: libicu57

    Per utilizzare Adobe Campaign, è necessario che sia installata la libreria libc-ares. In RHEL/CentOS, eseguite il comando seguente:

    yum install c-ares
    

    Su Debian:

    aptitude install libc-ares2
    

SELLinux

Se utilizzato, il modulo SELLinux deve essere configurato correttamente.

A questo scopo, accedete come root e immettete il comando seguente:

echo 0 >/selinux/enforce

Inoltre, nel file /etc/sysconfig/httpd , è stata aggiunta la riga seguente per fare riferimento allo script di configurazione dell'ambiente Adobe Campaign :

. ~neolane/nl6/env.sh

In RHEL e CentOS, problemi di compatibilità con i livelli client dei database sono stati rilevati quando SELLinux è abilitato. Per essere certi Adobe Campaign è in grado di funzionare correttamente, si consiglia di disattivare SELLinux.

Applicate il seguente processo:

  • Modificare il file /etc/selLinux/config

  • Modificate la linea SELINUX nel modo seguente:

SELINUX=disabled

Font per le statistiche MTA

Per visualizzare correttamente i rapporti sulle statistiche MTA (nms/fra/jsp/stat.jsp), aggiungete i font.

In Debian, aggiungete il comando:

aptitude install xfonts-base xfonts-75dpi ttf-bitstream-vera ttf-dejavu

In Redhat, utilizzare il comando seguente:

yum install xorg-x11-fonts-base xorg-x11-fonts-75dpi bitstream-vera-fonts dejavu-lgc-fonts

Font per istanze giapponesi

I font di caratteri specifici sono necessari per le istanze giapponesi per esportare i rapporti in formato PDF.

In Debian, aggiungete il comando:

aptitude install fonts-ipafont

In Red Hat, aggiungete il comando:

yum install ipa-gothic-fonts ipa-mincho-fonts

Installazione di LibreOffice per Debian

Per Debian sono necessarie le seguenti configurazioni:

  1. Installate i seguenti pacchetti standard:

    apt-get install libreoffice-writer libreoffice-calc libreoffice-java-common
    
  2. Installate i seguenti font (facoltativi ma altamente consigliati per le istanze giapponesi):

    apt-get install fonts-ipafont
    

Installazione di LibreOffice per CentOS

Con CentOS sono necessarie le seguenti configurazioni:

  1. Installate i seguenti pacchetti standard:

    yum install libreoffice-headless libreoffice-writer libreoffice-calc
    
  2. Installate i seguenti font (facoltativi ma consigliati per le istanze giapponesi):

    yum install ipa-gothic-fonts ipa-mincho-fonts
    

Livelli di accesso al database

I livelli di accesso per il motore di database utilizzato devono essere installati sul server e accessibili tramite l'account Adobe Campaign . Le versioni e le modalità di installazione possono variare a seconda del motore di database utilizzato.

La versione pilota supportata è dettagliata nella matrice dicompatibilità.

Consultare anche la sezione Database generale.

PostgreSQL

Adobe Campaign supporta tutte le versioni delle librerie client PostgreSQL dalla versione 7.2: (libpq.so.5, libpq.so.4, libpq.so.3.2 e libpq.so.3.1).

L'utilizzo di PostgreSQL con Adobe Campaign richiede anche l'installazione delle librerie pgcrypto corrispondenti.

Oracle

Recuperate la versione della libreria per Debian a 64 bit, ovvero: libclntsh.so, libclntsh.so.11.1 e libclntsh.so.10.1.

È possibile ottenere un pacchetto Linux RPM dalla Oracle Technology Network.

Nota

Se avete già installato il client Oracle ma l'ambiente globale (ad esempio: /etc/profile) non è configurato correttamente. È possibile aggiungere informazioni mancanti allo script nl6/customer.sh . Per ulteriori informazioni, vedere le variabili diambiente.

Risoluzione dei problemi e procedure ottimali

I problemi possono verificarsi dopo un client Oracle o un aggiornamento del server, una modifica della versione o alla prima installazione dell'istanza.

Se nella console client si notano ritardi imprevisti (una o più ore) nei registri, l'ultima elaborazione del flusso di lavoro, l'elaborazione successiva e così via, potrebbe verificarsi un problema tra la libreria del client Oracle e il server Oracle . Per evitare tali problemi

  1. Accertatevi di utilizzare il client ​completo.

    Sono stati identificati diversi problemi quando si utilizza la versione Oracle Instant Client. Inoltre, è impossibile modificare il file Timezone sul client istantaneo.

  2. Verificate che la versione ​client e la versione del server di database siano uguali.

    È noto che il mixaggio delle versioni nonostante matrice di compatibilità Oracle e la raccomandazione per allineare le versioni client e server causa problemi.

    Controllate anche valore ORACLE_HOME per essere certi che punti alla versione client prevista (nel caso in cui sul computer siano installate più versioni).

  3. Accertatevi che il client e il server utilizzino lo stesso file ​timezone.

DB2

La versione della libreria supportata è libdb2.so.

Passaggi di implementazione

installazioni Adobe Campaign per Linux devono essere eseguite nella seguente sequenza: l'installazione del server seguita dalla configurazione dell'istanza.

Il processo di installazione è descritto in questo capitolo. Le fasi di installazione sono le seguenti:

  • Passaggio 1: Installazione del server applicazione, vedere Installazione di pacchetti con Linux.
  • Passaggio 2: Integrazione con un server Web (facoltativo, a seconda dei componenti distribuiti).

Una volta completati i passaggi di installazione, è necessario configurare le istanze, il database e il server. Per ulteriori informazioni, consulta Informazioni sulla configurazioneiniziale.

In questa pagina