isCoopSafe

Eine optionale boolesche Konfiguration, die festlegt, ob DIL Daten an die Adobe Experience Cloud-Gerätekooperation sendet oder nicht.

Anforderungen

Um isCoopSafe zu verwenden, müssen Sie:

  • Verwenden Sie DIL v6.11 oder höher.

  • Teilnahme an der Experience Cloud-Gerätekooperation. Zukünftige Mitglieder der Gerätekooperation sollten diese Dokumentation ebenfalls lesen, um festzustellen, ob isCoopSafe mögliche Fragen über die Verwendung der Daten zur Erstellung eines Gerätediagramms beantwortet.

  • Wenden Sie sich an Ihren Adobe-Berater, um eine Zulassungsliste- oder eine Blockierungsliste-Markierung auf Ihrem Gerätekooperationskonto zu setzen. Es gibt keinen Self-Service-Pfad, um diese Flags zu aktivieren.

Nutzungsszenarios

isCoopSafe ist in zwei Nutzungsszenarios hilfreich, in denen es um die Erfassung der Daten von aktuellen oder zukünftigen Mitgliedern der Gerätekooperation geht. Diese Nutzungsszenarios beziehen sich darauf, wie Site-Besucherdaten an die Gerätekooperation übergeben werden, um das Gerätediagramm zu erstellen. In der folgenden Tabelle wird beschrieben, wie isCoopSafe in diesen Nutzungsszenarios verwendet wird, um Daten an das Gerätediagramm zu senden oder die Datenübergabe zu blockieren.

Anwendungsfall Beschreibung

Authentifizierte Besucher

Fügen Sie isCoopSafe Ihrem -DIL -Code hinzu, um zu steuern, wie Daten authentifizierter Besucher, die die Nutzungsvereinbarungen akzeptiert haben oder nicht, von der Gerätekooperation zum Erstellen des Gerätediagramms verwendet werden.

DIL auf Drittanbieter-Sites

Fügen Sie isCoopSafe Ihrem -DIL -Code für die Verwendung auf Drittanbieter-Sites hinzu, auf denen Sie:

  • Sie können nicht sicherstellen, dass authentifizierte Besucher die Nutzungsvereinbarungen akzeptiert haben.
  • Sie müssen steuern, wie die Daten durch die Gerätekooperation verwendet werden, um das Gerätediagramm zu erstellen.

Syntax und Codebeispiel

Syntax: isCoopSafe: true | false

Die booleschen Optionen bestimmen, ob Kundendaten von der Gerätekooperation verwendet werden können.

  • isCoopSafe: true: Von einem Mobile-SDK oder einer Website erfasste Besucherdaten können zur Erstellung des Gerätediagramms verwendet werden.

  • isCoopSafe: false: Von einem Mobile-SDK oder einer Website erfasste Besucherdaten können nicht zur Erstellung des Gerätediagramms verwendet werden.

Code-Beispiel

Legen Sie dies fest, wenn DIL instanziiert.

var dilInstance = DIL.create({ 
     ... 
     isCoopSafe: true 
});

POST-Parameter für Ereignisaufrufe

Abhängig von der festgelegten Kennzeichnung ( true oder false) übersetzt DIL isCoopSafe in diese POST-Parameter und sendet sie in einem Ereignisaufruf an Adobe:

  • d_coop_safe=1
  • d_coop_unsafe=1

Anhand der POST-Parameter stellt die Experience Cloud-Gerätekooperation fest, ob Benutzerdaten in das Gerätediagramm aufgenommen werden dürfen oder nicht. Die folgende Tabelle definiert die Beziehung zwischen den booleschen Kennzeichnungen von isCoopSafe und den im Ereignisaufruf übergebenen POST-Parametern. Wenn Sie isCoopSafe nicht verwenden, wird keiner von ihnen in einem Ereignisaufruf übergeben.

Konfigurationsstatus POST-Parameter

isCoopSafe: true

d_coop_safe=1

Die Gerätekooperation kann Besucherdaten verwenden, um das Gerätediagramm zu erstellen.

isCoopSafe: false

d_coop_unsafe=1

Die Gerätekooperation kann keine Besucherdaten verwenden, um das Gerätediagramm zu erstellen.

Post-Instanziierungs-APIs

Mit diesen APIs können Sie den Status von isCoopSafe überschreiben. Sie ermöglichen es, den Status nach der Instanziierung bzw. Anmeldung eines Besuchers auf einer Site oder bei einer Single-Page-Anwendung zu ändern, wenn die Seite nicht aktualisiert wird. Beispielsweise müssen Sie diese APIs aufrufen, wenn sich ein Benutzer auf Ihrer Site oder bei Ihrer Anwendung authentifiziert und später eine Nutzungsrichtlinie akzeptiert, die der Gerätekooperation die Verwendung seiner Daten ermöglicht.

API Beschreibung

dilInstance.api.setAsCoopSafe();

Legt den POST-Parameter d_coop_safe=1 in allen nachfolgenden Ereignisaufrufen fest.

dilInstance.api.setAsCoopUnsafe();

Legt den POST-Parameter d_coop_unsafe=1 in allen nachfolgenden Ereignisaufrufen fest.

Auf dieser Seite