Requisiti per l'inoltro lato server

Devi soddisfare questi requisiti di soluzione, servizio e codice di Experience Cloud per implementare l’inoltro lato server. Questi requisiti includono anche istruzioni su come verificare la presenza di versioni di codice e su dove ottenere le ultime librerie di codice.

Requisiti della soluzione

L'inoltro lato server funziona con Analytics e Audience Manager e/o Audiences.

Requisiti di servizio

L'inoltro lato server richiede Identity Service. Il servizio Identity fornisce un ID universale che identifica i visitatori del sito in tutte le soluzioni dell’Experience Cloud. È necessario implementare il servizio ID prima che l'inoltro lato server funzioni.

Versioni del codice

L'inoltro lato server richiede la versione 1.5 (o successiva) delle librerie di codice elencate di seguito. Come best practice, consigliamo di utilizzare le versioni più recenti anziché i requisiti minimi.

  • AppMeasurement.js
  • AppMeasurement_Module_AudienceManagement.js
  • VistorAPI.js

Determinare la versione della libreria dei codici

Qualsiasi strumento che monitori le richieste HTTP effettuate da un browser può mostrarti il numero di versione per il tuo codice AppMeasurement e API Visitor. Il AppMeasurement_Module_AudienceManagement.js non contiene o restituisce un ID versione. Gli esempi seguenti mostrano come si presentano gli ID di versione per il codice AppMeasurement.js e VisitorAPI.js .

  • AppMeasurement.js: L’ Adobe Debugger restituisce la versione AppMeasurement come riportato di seguito: Version of Code | JS-1.5.1. Altri strumenti possono utilizzare un'etichetta diversa, ma il valore segue sempre il pattern JS-X.X.X, dove X è un numero di versione.
  • VisitorAPI.js: Cerca il d_visid_ver parametro . Ti mostrerà il servizio ID visitatore in questo modo: d_visid_ver: 1.5.5. Il codice API del visitatore precedente alla versione 1.5.2 non includeva un numero di versione. Stai probabilmente utilizzando una libreria di codici precedente (e devi effettuare l’aggiornamento) se i risultati del monitoraggio non restituiscono un numero di versione.

In questa pagina