Oberes Navigationsfenster wird nicht in Storefront geladen

In diesem Artikel finden Sie Konfigurationslösungen für ESI-Probleme (Varnish Edge Side Includes), bei denen der Inhalt bestimmter Seiten, normalerweise das obere Navigationsfenster, nicht auf der Storefront angezeigt wird, wenn Varnish zum Caching verwendet wird.

Betroffene Produkte und Versionen

  • Adobe Commerce 2.x.x
  • Alle Lackversionen

Problem

Voraussetzungen:

Installieren und konfigurieren Sie Varnish für Ihren Adobe Commerce-Store.

Schritte zur Reproduktion:

  1. Geh zum Laden.
  2. Durchsuchen Sie die Store-Seiten.

Erwartete Ergebnisse:

Alle Inhalte und Seitenblöcke wurden erfolgreich geladen.

Tatsächliche Ergebnisse:

Beachten Sie, dass einige Inhaltsblöcke, z. B. das obere Navigationsfenster mit Kategorien, nicht geladen werden. Stattdessen wird Leerraum angezeigt.

Ursache

Mögliche Gründe für das Problem sind:

  • ESI Include-Tags werden mit dem HTTPS-Zugriffsprotokoll generiert, während Varnish nur mit HTTP funktioniert.
  • Lack verarbeitet ESI nicht innerhalb von JSON.
  • Antwort-Header sind zu groß für „Lackieren“; sie können nicht verarbeitet werden.

Lösung

Um die Probleme zu beheben, müssen Sie eine zusätzliche Lackkonfiguration durchführen und Varnish neu starten.

  1. Wenn Sie ein Benutzer mit root Berechtigungen sind, öffnen Sie Ihre Vanish-Konfigurationsdatei in einem Texteditor. Unter Ändern der Konfiguration des Lacksystems in unserer Entwicklerdokumentation finden Sie Informationen darüber, wo sich diese Datei für verschiedene Betriebssysteme befinden könnte.

  2. Fügen Sie in der DAEMON_OPTS variable -p feature=+esi_ignore_https, -p feature=+esi_ignore_other_elements, -p feature=+esi_disable_xml_check hinzu. Dies würde wie folgt aussehen:

    code language-bash
    DAEMON_OPTS="-a :6081 \    -p feature=+esi_ignore_other_elements \    -p feature=+esi_disable_xml_check \    -p feature=+esi_ignore_https \    -T localhost:6082 \    -f /etc/varnish/default.vcl \    -S /etc/varnish/secret \    -s malloc,256m"
    
  3. Speichern Sie Ihre Änderungen und beenden Sie den Texteditor.

  4. Erhöhen Sie in der VCL-Konfigurationsdatei die Antwort-Header, indem Sie die Werte dieser Parameter erhöhen: http_resp_hdr_len, http_resp_size, workspace_backend. Stellen Sie sicher, dass die letzten beiden ähnliche Werte haben.

  5. Wenn Sie dies ändern, müssen Sie service varnish restart ausführen, damit die Änderungen wirksam werden.

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