Kunden werden abgemeldet oder verlieren den Warenkorbinhalt in der Adobe Commerce-Storefront
Dieser Artikel bietet eine Lösung für das Problem, bei dem Kundinnen und Kunden abgemeldet werden oder Artikel aus dem Warenkorb in der Storefront verlieren, nachdem sie von Zahlungsdiensten oder anderen Drittanbieterdiensten zurück zum Adobe Commerce-Store weitergeleitet wurden (Sitzungs-Cookie geht verloren).
Betroffene Produkte und Versionen
- Adobe Commerce On-Premise, alle unterstützten Versionen
- Adobe Commerce auf Cloud-Infrastruktur, alle unterstützten Versionen
Problem
Schritte zur Reproduktion:
- Der Kunde fügt Produkte in den Warenkorb auf der Storefront ein und geht zur Kasse.
- Der Kunde wird zur Zahlungs-/Versandseite oder zu anderen Informationen/Services an die Website eines Drittanbieters weitergeleitet.
- Der Kunde wird zurück zum Geschäft weitergeleitet.
Tatsächliches Ergebnis:
Der Kunde wurde zum leeren Warenkorb oder zu einer leeren Seite weitergeleitet.
Erwartetes Ergebnis:
Der Kunde wurde zu einer Erfolgszahlungsseite (oder einer anderen Erfolgsseite) umgeleitet, ohne die Checkout-Daten und den Fortschritt zu verlieren.
Ursache
Das SameSite-Cookie-Attribut ist auf Lax oder nicht angegeben (was als festgelegt behandelt wird Lax ). Mit SameSite
= Lax wird die Übertragung eines Cookies an externe URLs über POST
deaktiviert.
Lösung
Um das Problem zu beheben, wenden Sie sich an den Drittanbieter und bitten Sie seine Entwickler, ihre Integrationen zu aktualisieren, um Cookie-Parameter zu konfigurieren.
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