Durch Anwenden eines Pflasters wird Ihre Website heruntergefahren
In diesem Artikel wird über das Problem gesprochen, dass ein Patch, den Sie gerade angewendet haben, Ihre Website herunterfährt. Um es zu beheben, können Sie den Patch entfernen.
Betroffene Produkte und Versionen
- Adobe Commerce (alle Bereitstellungsmethoden), alle unterstützten Versionen
- Magento Open Source, alle Versionen
Problem
Nachdem Sie einen Patch angewendet haben, geht Ihre Site verloren.
Ursache
Dieses Problem tritt möglicherweise aufgrund einer Versionsinkompatibilität zwischen dem Patch, den Sie gerade auf Ihre Website angewendet haben, Ihren Anpassungen, anderen Patches, die Sie in der Vergangenheit angewendet haben, oder einem anderen Fehler auf.
Lösung
Entfernen Sie den Patch. Die Methode zur Patch-Entfernung unterscheidet sich bei Adobe Commerce in der Cloud-Infrastruktur von der in Adobe Commerce vor Ort und Magento Open Source.
Magento Open Source, alle 1.X-Versionen
Für Magento Open Source 1.x:
- Führen Sie den folgenden SSH-Befehl aus:
h SUPEE_patch --revert
Adobe Commerce vor Ort, Magento Open Source, alle 2.x-Versionen
Für Adobe Commerce On-Premise und Magento Open Source 2.x-Versionen:
-
Führen Sie den folgenden SSH-Befehl aus:
code language-none patch -p1 -R %patch_name%.composer.patch
(Wenn der obige Befehl nicht funktioniert, verwenden Sie
-p2
anstelle von-p1
) -
Damit die Änderungen übernommen werden, aktualisieren Sie den Cache im Admin unter System > Cache-Verwaltung.
Adobe Commerce in der Cloud-Infrastruktur, alle Versionen
Für Adobe Commerce in der Cloud-Infrastruktur werden alle Versionen
-
Entfernen Sie die Datei(en)
%patch_name%.composer.patch
aus dem Verzeichnism2-hotfixes
. -
Übernehmen und pushen Sie Ihre Code-Änderungen:
code language-none git commit -m "Remove %patch_name%.composer.patch patch" && git push origin
Verwandtes Lesen
- Anwenden eines von Adobe bereitgestellten Composer-Patches in unserer Support-Wissensdatenbank.