Fehlerbehebung bei der Installation von Zahlungsdiensten

In diesem Artikel werden Fehler erläutert, die bei der Installation von Zahlungsdiensten auftreten können, und es werden Lösungen zur Behebung dieser Fehler bereitgestellt, damit Sie die Installation abschließen können.

Betroffene Produkte und Versionen

  • Zahlungsdienste ist jetzt mit den Adobe Commerce-Versionen 2.4.0 bis 2.4.4 kompatibel.

Problem - Falsche Composer-Schlüssel

Bei der Installation der Zahlungsdienst-Erweiterung wird möglicherweise eine Fehlermeldung angezeigt, die besagt, dass Sie während der Installation falsche Composer-Schlüssel verwendet haben.

Zu reproduzierende Schritte:

  1. Versuchen Sie, Installieren von Zahlungsdiensten.

  2. Siehe den folgenden Fehler:

    Es konnte keine passende Version von Package Magento/Payment-Services gefunden werden. Überprüfen Sie die Rechtschreibung des Pakets, Ihre Versionsbeschränkung und ob das Paket in einer Stabilität verfügbar ist, die Ihrer minimalen Stabilität (stabil) entspricht.

Erwartetes Ergebnis:

Sie können diesen Installationsanweisungen in unserer Entwicklerdokumentation zur erfolgreichen Installation von Zahlungsdiensten.

Tatsächliches Ergebnis:

Während der Installation wird eine Fehlermeldung angezeigt, die besagt, dass Sie während der Installation nicht die richtigen Composer-Schlüssel verwendet haben.

Ursache

Sie haben während der Installation falsche Composer-Schlüssel verwendet.

Lösung

Stellen Sie sicher, dass Ihre Composer-Schlüssel sind mit der Magento-ID verknüpft. bei der Registrierung von Zahlungsdiensten verwendet werden.

Problem - Verwendung des gleichen Datenraums über mehrere Instanzen hinweg

Ausführen einer Multi-Umgebung-Einrichtung mit Zahlungsdiensten für jede.

Lösung

Derselbe API-Schlüssel kann für alle Instanzen verwendet werden, aber jede Instanz muss einen eigenen SaaS-Datenraum verwenden.

Wenn Sie ein SaaS-Projekt erstellen, generiert Commerce je nach Ihrer Commerce-Lizenz einen oder mehrere SaaS-Datenräume:

  • Adobe Commerce - Ein Produktionsdatenraum; zwei Testdatenbereiche
  • Magento Open Source - Ein Produktionsdatenraum; keine Testdatenbereiche

Befolgen Sie die Anweisungen unter Commerce-API-Schlüssel und privater Schlüssel , um Ihre Zahlungsdiensterweiterung erfolgreich zu konfigurieren.

Problem - Nicht genügend Speicher für PHP

Bei der Installation der Zahlungsdienst-Erweiterung wird möglicherweise eine Fehlermeldung angezeigt, dass Sie nicht genügend Speicher für PHP haben.

Zu reproduzierende Schritte:

  1. Versuchen Sie, Installieren von Zahlungsdiensten.

  2. Siehe folgenden Fehler oder Ähnliches:

    Schwerwiegender Fehler: Zulässige Speichergröße von 2146435072 Byte ausgeschöpft (versucht, 4096 Byte zuzuweisen) in phar:///usr/local/bin/composer/src/Composer/DependencyResolver/RuleWatchGraph.php in Zeile 52

Erwartetes Ergebnis:

Sie können diesen Installationsanweisungen in unserer Entwicklerdokumentation zur erfolgreichen Installation von Zahlungsdiensten.

Tatsächliches Ergebnis:

Während der Installation wird eine Fehlermeldung angezeigt, dass Sie nicht genügend Speicher für PHP haben.

Ursache

Der Grenzwert für PHP in Ihrer Umgebung ist nicht hoch genug.

Lösung

Erhöhen Sie die Speicherbegrenzung für PHP. in Ihrer Umgebung in php.ini.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a