Aktualisierungen des Staging für geplante Inhalte werden nicht mit veraltetem Fastly-Cache angezeigt

Dieser Artikel enthält eine Fehlerbehebung für Fälle, in denen Adobe Commerce Stores bei der Verwendung von Content Staging und Fastly keine geplanten Aktualisierungen anzeigen. Das Problem ist auf die standardmäßig aktivierte Fastly Soft Purge zurückzuführen. Diese Funktion reduziert das Laden der Anwendungsressourcen und generiert nur bei einer zweiten Anforderung einen neuen Cache. Um dieses Problem zu beheben, können Sie die Option CMS-Seite bereinigen über den Commerce-Administrator aktivieren, um immer neue Inhalte zu generieren und bereitzustellen.

Problem

Geplante Aktualisierungen für ein Store-Inhalts-Asset (Seite, Produkt, Block usw.) werden nicht unmittelbar nach dem Startzeitpunkt der Aktualisierung auf der Storefront angezeigt. Dies geschieht, wenn Aktualisierungen mithilfe der Content Staging -Funktion geplant wurden.

Ursache

Aufgrund der (standardmäßig aktivierten) Softbereinigungsfunktion von Fastly erhält die Adobe Commerce-Storefront beim Senden der ersten Anfrage für das aktualisierte Asset an Fastly weiterhin den alten (veralteten) zwischengespeicherten Inhalt. Eine zweite Anforderung zur erneuten Generierung der Site-Daten ist erforderlich.

Daher kann Fastly veraltete Inhalte bis zur zweiten Anfrage für den aktualisierten Inhalt bereitstellen.

Erwartete Zwischenspeicherung: Nachdem wir eine Aktualisierung für ein Inhalts-Asset mit Content Staging planen, sendet Adobe Commerce eine Anfrage zur Aktualisierung des Caches an Fastly. Aktualisiert den vorherigen zwischengespeicherten Inhalt schnell (ohne Inhalt zu löschen) und beginnt mit der Bereitstellung des aktualisierten Inhalts.

Tatsächliches Caching: Wenn beim Empfang der ersten Anfrage für den aktualisierten Inhalt weiterhin der veraltete Inhalt bereitgestellt wird, wird der Inhalt nur nach Erhalt der zweiten -Anfrage neu generiert und korrigiert. Dieses Verhalten wurde implementiert, um die Server-Last zu reduzieren, indem der Cache nur in Bereichen mit nachweislichem Traffic erneuert wird, ohne den Cache für die gesamte Website neu zu generieren. Aktualisiert den Cache schnell und speichert die Anwendungsressourcen.

Lösung

Wenn die Bereitstellung von veraltetem Inhalt auch für die erste Anforderung inakzeptabel ist, können Sie die Softbounce-Bereinigung deaktivieren und die Option CMS-Seite bereinigen aktivieren:

  1. Melden Sie sich bei Ihrem lokalen Commerce-Administrator als Administrator an.
  2. Wechseln Sie zu Stores > Konfiguration > Erweitert > System > Gesamter Seiten-Cache.
  3. Erweitern Sie Schnelle Konfiguration und erweitern Sie dann Erweitert.
  4. Setzen Sie Use Soft Purge auf Nein.
  5. Setzen Sie CMS-Seite bereinigen auf Ja.
  6. Klicken Sie oben auf der Seite auf Konfiguration speichern .

purge_options.png

Verwandte Dokumentation

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a