Beheben von Problemen mit dem Verschlüsselungsschlüssel

In diesem Artikel wird beschrieben, wie Sie die Probleme beheben, die durch den Verschlüsselungsschlüssel verursacht werden, der nicht zusammen mit dem DB-Dump in die andere Umgebung verschoben wird.

Betroffene Produkte und Versionen

  • Adobe Commerce auf Cloud-Infrastruktur 2.2.x, 2.3.x

Problem

Nach dem Import einer Datenbank-Dump von der Produktions- zur Staging-/Integrationsumgebung, erscheinen gespeicherte Kreditkartennummern falsch und/oder Zahlungen schlagen bei Zahlungsintegrationen fehl, die die Verwendung von Händleranmeldeinformationen erfordern.

Ursache

Der Verschlüsselungsschlüssel, der zum Verschlüsseln sensibler Daten wie Kreditkartennummern und Händleranmeldeinformationen verwendet wird, wird nicht in der Datenbank gespeichert und wird daher nach dem Import/Export der Datenbank-Dump nicht in andere Umgebungen übertragen.

Lösung

Sie müssen den Verschlüsselungsschlüssel aus der Quellumgebung kopieren und in die Zielumgebung einfügen.

So kopieren Sie den Verschlüsselungsschlüssel:

  1. SSH zu Ihrem Projekt, das die Quelle für die Datenbank-Dump war, wie beschrieben in SSH in der Umgebung in unserer Entwicklerdokumentation.
  2. Öffnen app/etc/env.php in einem Texteditor.
  3. Den Wert von key für crypt.
return array ('crypt' =>      array ('key' => '<your encryption key>', ),);

So legen Sie den Schlüsselwert für das Zielprojekt fest:

  1. Öffnen Sie die Cloud-Konsole und suchen Sie Ihr Projekt.
  2. Legen Sie den Wert der CRYPT_KEY (in unserer Entwicklerdokumentation), wie hier beschrieben: Projekt konfigurieren in unserer Entwicklerdokumentation. Dadurch wird der Bereitstellungsprozess Trigger und CRYPT_KEY wird im app/etc/env.php -Datei bei jeder Bereitstellung.

Optional können Sie den Verschlüsselungsschlüssel im app/etc/env.php Datei:

  1. SSH in die Zielumgebung.
  2. Öffnen app/etc/env.php in einem Texteditor.
  3. Fügen Sie die kopierten Daten als key Wert für crypt.
  4. Speichern Sie die bearbeitete env.php.
  5. Cache in der Zielumgebung bereinigen, indem Sie bin/magento cache:clean oder im Commerce Admin unter System > Instrumente > Cacheverwaltung.
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