Fastly Error: Plugin VCL Version ist veraltet! Bitte erneut hochladen

Dieser Artikel bietet eine Lösung für den Fall, dass die Meldung "Plugin VCL Version ist veraltet! Bitte neu hochladen."in der Fastly-Konfiguration in Commerce Admin, da das neueste Fastly-Modul nicht installiert wurde.

Betroffene Produkte und Versionen

Adobe Commerce auf Cloud-Infrastruktur 2.2.x, 2.3.x

Schnell: Dieser Fehler kann sich auf alle Versionen des Fastly-Moduls mit Ausnahme der neuesten Version auswirken. Informationen zur neuesten Version finden Sie unter Schnelle Versionshinweise auf GitHub.

Problem

  1. Melden Sie sich beim Commerce Admin-Bedienfeld an.
  2. Navigieren Sie zu Stores > Konfiguration > Erweitert > System > Vollständiger Seiten-Cache Schneller Cache.
  3. Im Automatische Upload- und Dienstaktivierung gibt es einen Plugin VCL Version ist veraltet! Bitte neu hochladen."Benachrichtigung.
  4. Sie versuchen, die VCL-Snippets hochzuladen, indem Sie auf die Schaltfläche "VCL auf Fastly hochladen"klicken, aber dennoch wird die Warnung angezeigt Plugin VCL Version ist veraltet! Bitte neu hochladen."

Ursache

Die Fastly-Erweiterung wurde aktualisiert (zusammen mit einer gebündelten VCL-Konfiguration und Vorlagen), aber die aktualisierte VCL-Konfiguration wurde nicht in den Fastly-Dienst hochgeladen. Beim Aktualisieren des Adobe Commerce-Moduls Fastly_Cdn, müssen Sie eine aktualisierte VCL-Konfiguration erneut auf Fastly hochladen.

Lösung

  1. Vergewissern Sie sich, dass die neuesten ECE-Tools installiert sind, und klicken Sie auf aktuelle Version in unserer Entwicklerdokumentation. ECE-Tools verfügt über eine Version des Fastly-Pakets in seinen Abhängigkeiten.

    Dies ist möglicherweise nicht die neueste Version des Fastly-Plug-ins. Es handelt sich jedoch wahrscheinlich um eine spätere Version als die, die Sie derzeit installiert haben. Es empfiehlt sich, die neuesten ECE-Tools zu installieren.

  2. Wenn Sie nicht mit der aktuellen Version der ECE-Tools arbeiten, führen Sie die folgenden Schritte aus, um Upgrade in unserer Entwicklerdokumentation.

  3. Nachdem Sie die ECE-Tools aktualisiert haben, überprüfen Sie, ob Sie jetzt über eine aktuelle Version der Fastly-Plug-in installiert.

  4. Wenn das Fastly-Plug-in nicht die aktuelle Version ist, führen Sie die folgenden Schritte aus, um Aktualisieren des Plug-ins auf die neueste Version in unserer Entwicklerdokumentation.

Verwandtes Lesen

  • Informationen zum Einrichten und Konfigurieren von Fastly finden Sie unter Fastly Services konfigurieren in unserer Entwicklerdokumentation.
  • Allgemeine Informationen zu Fastly finden Sie unter fastly.com.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a