Fehler beim Bereinigen des Fastly-Cache in Cloud (Die Bereinigungsanforderung wurde nicht erfolgreich verarbeitet)

Dieser Artikel enthält eine Korrektur für den Fall, dass Sie eine Option zur schnellen Bereinigung verwenden und den Fehler erhalten: Die Bereinigungsanfrage wurde nicht erfolgreich verarbeitet. Fastly ist ein CDN- und Caching-Dienst, der in Adobe Commerce in Cloud-Infrastrukturplänen und -Implementierungen enthalten ist. Wenn Sie versuchen, eine Option zur schnellen Bereinigung zu verwenden, die nicht verarbeitet wird, liegen möglicherweise falsche Anmeldeinformationen in Ihrer Umgebung vor oder es ist ein Problem aufgetreten.

Diese Informationen helfen Ihnen beim Überprüfen und Testen von Schnellkopfzeilen für Ihre Live-Site und Herkunftsserver.

Betroffene Versionen

  • Adobe Commerce auf Cloud-Infrastruktur 2.1.X und höher
  • Fastly 1.2.27 und höher

Problem

Das Caching funktioniert zwar, aber wenn Sie versuchen zu bereinigen, erhalten Sie einen Fehler oder es funktioniert nicht. Der Fehler enthält: "Die Bereinigungsanforderung wurde nicht erfolgreich verarbeitet."

Ursache

Möglicherweise haben Sie in Ihrer Umgebung falsche Anmeldeinformationen festgelegt oder müssen VCL-Snippets hochladen.

Auflösen

Fastly-Anmeldeinformationen überprüfen

Überprüfen Sie, ob Sie in Ihrer Umgebung über die richtige Fastly Service-ID und das richtige API-Token verfügen. Wenn Sie über Staging-Anmeldeinformationen in der Produktion verfügen, werden die Bereinigungen möglicherweise nicht korrekt verarbeitet oder verarbeitet.

  1. Melden Sie sich bei Ihrem lokalen Commerce-Administrator als Administrator an.
  2. Klicken Sie auf "Stores"> "Einstellungen"> "Konfiguration"> "Erweitert"> "System"und erweitern Sie "Vollständiger Seiten-Cache". magento_full_page_cache_2.4.1.png
  3. Erweitern Sie Fastly Configuration und überprüfen Sie die Fastly Service-ID und das API-Token für Ihre Umgebung.
  4. Wenn Sie die Werte ändern, klicken Sie auf Testanmeldeinformationen.

VCL-Snippets überprüfen

Wenn die Anmeldedaten korrekt sind, kann es bei Ihnen zu Problemen mit Ihren VCLs kommen. Um Ihre VCLs pro Dienst aufzulisten und zu überprüfen, geben Sie den folgenden API-Aufruf in ein Terminal ein:

curl -X GET -s https://api.fastly.com/service/<Service ID>/version/<Editable Version #>/snippet -H "Fastly-Key:FASTLY_API_TOKEN"

Überprüfen Sie die Liste der VCL. Wenn Sie Probleme mit den standardmäßigen VCLs von Fastly haben, können Sie den Inhalt erneut hochladen oder anhand der Fastly default VCLs überprüfen. Informationen zum Bearbeiten Ihrer benutzerdefinierten VCLs finden Sie unter Benutzerdefinierte Fastly VCL-Snippets im Handbuch zu Commerce on Cloud Infrastructure.

Weitere Informationen

In unserer Entwicklerdokumentation:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a