Überprüfen des Bereitstellungsprotokolls, wenn in der Cloud-Benutzeroberfläche der Fehler log snipped auftritt

Dieser Artikel bietet eine Lösung für das Problem, bei dem in Adobe Commerce auf der Benutzeroberfläche der Cloud-Infrastruktur der eingegebene Log angezeigt wird, da die Fehlermeldung zu lang war, wenn versucht wurde, das Bereitstellungsprotokoll in der Benutzeroberfläche des Cloud-Projekts anzuzeigen. (Gilt nicht für die Adobe Commerce Cloud-Konsole.)

Betroffene Produkte

Adobe Commerce in der Cloud-Infrastruktur (alle unterstützten Versionen)

Problem

Beim Versuch, das Bereitstellungsprotokoll auf der Benutzeroberfläche des Cloud-Projekts anzuzeigen, zeigt Adobe Commerce auf der Benutzeroberfläche der Cloud-Infrastruktur die folgende Fehlermeldung an: Protokollausschnitt, da es zu lang war.

Zu reproduzierende Schritte

  1. Wechseln Sie zur Projekt-URL und klicken Sie auf den Status der betreffenden Bereitstellung.
  2. Wenn das Protokoll zu lang ist, um in der Benutzeroberfläche angezeigt zu werden, wird die Fehlermeldung angezeigt: Protokollausschnitt, da es zu lang war.

Ursache

Beachten Sie, dass das in der Benutzeroberfläche angezeigte Protokoll nicht als "Source of Truth"behandelt werden sollte, insbesondere wenn Sie feststellen, dass die Site nach der Auflistung der Bereitstellung mit dem Status "Success"nicht reagiert oder ordnungsgemäß funktioniert. Sie sollten dies auch mit den Protokollen auf dem Server überprüfen. Weitere Informationen finden Sie unter Anzeigen und Verwalten von Protokollen in unserer Entwicklerdokumentation.

Lösung

  1. Stellen Sie sicher, dass Magento Cloud CLI in Ihrer lokalen Umgebung installiert ist.

  2. Führen Sie den folgenden Befehl aus:

    code language-bash
    magento-cloud activity -p <project id> -e <environment>
    
  3. Es wird eine Ausgabe zurückgegeben, die der folgenden ähnelt:

    code language-bash
    Activities on the project <project name> (project id), environment <environment>:
    +---------------+---------------------------+-------------------------------------+----------+----------+---------+
    | ID            | Created                   | Description                         | Progress | State    | Result  |
    +---------------+---------------------------+-------------------------------------+----------+----------+---------+
    | l5wgwmzwrsskg | 2021-06-01T08:18:02-07:00 | ABC merged Integration into Staging | 100%     | complete | success |
    | raah5xrhqz3wg | 2021-06-01T08:07:18-07:00 | XYZ pushed to Integration           | 100%     | complete | failure |
    
  4. Kopieren Sie die Aktivitäts-ID der betroffenen Bereitstellung und führen Sie dann den Befehl aus:

    code language-bash
    magento-cloud activity:log <activity ID> -p <project id> -e <environment>
    

    Beispiel zur Überprüfung des Protokolls der fehlgeschlagenen Bereitstellung:

    code language-bash
    magento-cloud activity:log raah5xrhqz3wg -p <project id> -e <environment>
    

Weitere Informationen finden Sie in unserer Entwicklerdokumentation:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a