Suchmaschine in app/etc/env.php
kann nicht geändert werden
Dieser Artikel bietet eine Lösung für das Problem, dass Sie versuchen, die Suchmaschinenkonfiguration aus der app/etc/env.php
-Datei zu entfernen, die Konfiguration nach der erneuten Bereitstellung jedoch auf die vorherige Einstellung zurückgesetzt oder standardmäßig auf OpenSearch geändert wird.
Betroffene Produkte und Versionen
- Adobe Commerce auf Cloud-Infrastruktur, alle unterstützten Versionen
Problem
Sie versuchen, die Suchmaschine in Commerce Admin zu ändern, aber die Felder sind gesperrt.
Ursache
Die Suchmaschinenkonfiguration ist in der app/etc/env.php
gesperrt oder die Suchmaschine wird explizit in der .magento.env.yaml
definiert.
Lösung
-
Überprüfen Sie die
.magento.env.yaml
Datei unter der Bereitstellungsphase und überprüfen Sie, ob dieSEARCH_CONFIGURATION
konfiguriert wurde. Beispiel:code language-yaml SEARCH_CONFIGURATION: engine: elasticsearch7 ... <VARIABLE X>
-
Ist die
SEARCH_CONFIGURATION
vorhanden? Wenn nicht vorhanden, ist die Suchmaschinenkonfiguration standardmäßig auf OpenSearch gesperrt. Um die Konfiguration zu ändern, müssen Sie die Variable zur.magento.env.yaml
-Datei mit dem entsprechenden Wert für die Suchmaschine hinzufügen. Wenn die VariableSEARCH_CONFIGURATION
vorhanden ist und Sie die Engine ändern möchten, ersetzen Sie den vorhandenen Wert für die Engine in.magento.env.yaml
. Mögliche/bekannte Werte: opensearch, livesearch, elasticsuite, amasty_elastic und amasty_elastic_opensearch. -
Stellen Sie die Instanz erneut bereit.
-
Das Suchmaschinenfeld in Admin bleibt gesperrt, sollte jedoch mit dem von Ihnen angegebenen Wert aktualisiert werden.
Verwandtes Lesen
- Gesperrte (ausgegraute) Felder in Commerce Admin im Handbuch zu Commerce in der Cloud-Infrastruktur.