Admin 2FA-E-Mail-Benachrichtigungen werden nicht empfangen
Betroffene Produkte und Versionen
- Adobe Commerce auf Cloud-Infrastruktur, alle Versionen
Problem
Sie haben die Zwei-Faktor-Authentifizierung eingerichtet, um die Sicherheit des Admin-Zugriffs zu verbessern, erhalten jedoch keine E-Mail mit den Anweisungen zum Abschließen der Einrichtung.
Ursache
Wenn Sie die Absender-E-Mail nicht richtig konfiguriert haben oder Ihre Domain in SendGrid nicht mit einem weißen Label versehen wurde, ist die E-Mail wahrscheinlich im Spam-Ordner gelandet.
Fehlerbehebung
Schritt 1: Spam-Ordner überprüfen
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Wenn die E-Mail nicht im Spam-Ordner angezeigt wurde, führen Sie diese MySQL-Abfrage aus, um zu überprüfen, ob die E-Mail-Adressen konfiguriert wurden:
code language-sql select * from core_config_data where path like '%trans_email%';- Wenn keine Ergebnisse zurückgegeben werden, bedeutet dies, dass die Absenderadresse nicht konfiguriert wurde.
Da Sie keinen Zugriff auf den Administrator haben, müssen Sie die Konfiguration in die Datenbank einfügen. Fügen Sie die entsprechende E-Mail-Adresse ein und führen Sie die MySQL-Anweisung aus:
code language-none insert into core_config_data (scope,scope_id,path,value) values ('default',0,'trans_email/ident_general/email', your-email@here.com)- Wenn ein Ergebnis zurückgegeben wird, fahren Sie mit (2).
- Wenn keine Ergebnisse zurückgegeben werden, bedeutet dies, dass die Absenderadresse nicht konfiguriert wurde.
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Wenn die E-Mail in Ihrem Spam-Ordner angezeigt wurde, klicken Sie auf den Link in der E-Mail. Wenn der Link seitdem abgelaufen ist, versuchen Sie erneut, sich anzumelden, um den Vorgang zu wiederholen.
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Nachdem Sie Zugriff erhalten haben, gehen Sie zu Stores > Konfiguration > Allgemein > E-Mail-Adressen speichern und konfigurieren Sie die E-Mail-Adressen.
Schritt 2: Wenn/nachdem die E-Mail-Adressen ordnungsgemäß konfiguriert wurden, SSH in die Umgebung einbinden und diesen Befehl ausführen:
php -r "mail(<your email address>,<subject>,<content>,'To: <sender email>');"
Überprüfen Sie Ihren Spam-Ordner auf die E-Mail.
Wenn die E-Mail in Ihrem Spam-Ordner angezeigt wird, ist die E-Mail-Authentifizierung Ihrer Domain möglicherweise nicht vollständig für den ausgehenden Versand über SendGrid konfiguriert.
Wenn Sie den von Adobe verwalteten SendGrid-Service verwenden:
Senden Sie ein Support-Ticket in dem Sie anfordern, dass Ihre Versand-Domain mit SendGrid authentifiziert auch als „weiß gekennzeichnet bezeichnet) wird.
Dieser Prozess umfasst das Hinzufügen von DNS-Einträgen (DKIM und SPF), um SendGrid zu autorisieren, E-Mails im Namen Ihrer Domain zu senden, was die Wahrscheinlichkeit erhöht, dass Ihre E-Mails an den Posteingang statt an den Spam-Ordner gesendet werden.
Wenn Sie Ihr eigenes SendGrid-Konto verwenden:
Sie sind dafür verantwortlich, Ihre Domain-Authentifizierungseinstellungen direkt in Ihrem SendGrid-Konto-Dashboard zu verwalten. Weitere Informationen finden Sie der SendGrid- unter „Einrichten der Domain-Authentifizierung“.