Pakete wurden nach der Aktualisierung von 2.4.4 auf 2.4.4-p1 heruntergestuft

Dieser Artikel enthält einen Hotfix für das Problem, wenn Händler in Version 2.4.4 die Variable composer update und dann werden die unten aufgeführten Pakete (Module) auf ihre früheren Versionen heruntergestuft, die nicht mit Version 2.4.4 kompatibel sind und nur mit Version 2.4.5 und höher verwendet werden sollen.

Betroffene Produkte und Versionen

  • Adobe Commerce in Cloud-Infrastruktur 2.4.4
  • Adobe Commerce vor Ort 2.4.4
  • Magento Open Source 2.4.4

Problem

Es gibt zwei Szenarien, in denen dieses Problem auftreten kann und wie es reproduziert werden kann:

Szenario 1

Zu reproduzierende Schritte:

Beim Upgrade von 2.4.4 auf 2.4.4-p1 gibt es eine Reihe von Paketen (Modulen), die mit ähnlicher Ausgabe heruntergestuft werden:

Downgrading magento/module-adobe-ims (2.1.4 => 2.1.3)
Downgrading magento/module-adobe-ims-api (2.1.2 => 2.1.1)
Downgrading magento/module-adobe-stock-admin-ui (1.3.2 => 1.3.1)
Downgrading magento/module-adobe-stock-client-api (2.1.2 => 2.1.1)
Downgrading magento/module-adobe-stock-image (1.3.3 => 1.3.2)
Downgrading magento/module-adobe-stock-image-admin-ui (1.3.3 => 1.3.2)
Downgrading magento/module-banner-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-inventory (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-advanced-checkout (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-api (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-bundle-product (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-catalog-api (1.3.3 => 1.3.2)
Downgrading magento/module-inventory-configurable-product-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-configurable-product-frontend-ui (1.0.3 => 1.0.2)
Downgrading magento/module-inventory-import-export (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-in-store-pickup-admin-ui (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-in-store-pickup-frontend (1.1.3 => 1.1.2)
Downgrading magento/module-inventory-in-store-pickup-graph-ql (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-in-store-pickup-sales-admin-ui (1.1.3 => 1.1.2-p1)
Downgrading magento/module-inventory-in-store-pickup-shipping (1.1.2 => 1.1.1)
Downgrading magento/module-inventory-low-quantity-notification (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-low-quantity-notification-api (1.2.2 => 1.2.1-p1)
Downgrading magento/module-inventory-requisition-list (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-sales-admin-ui (1.2.3 => 1.2.2)
Downgrading magento/module-inventory-sales-api (1.2.2 => 1.2.1)
Downgrading magento/module-inventory-shipping-admin-ui (1.2.3 => 1.2.2-p1)
Downgrading magento/module-inventory-source-selection-api (1.4.2 => 1.4.1-p1)
Downgrading magento/module-inventory-wishlist (1.0.2 => 1.0.1)
Downgrading magento/module-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-re-captcha-checkout-sales-rule (1.1.1 => 1.1.0)
Downgrading magento/module-re-captcha-customer (1.1.3 => 1.1.2)
Downgrading magento/module-re-captcha-frontend-ui (1.1.3 => 1.1.2)
Downgrading magento/module-staging-page-builder (2.2.3 => 2.2.2)
Downgrading magento/module-two-factor-auth (1.1.4 => 1.1.3)
Removing magento/module-admin-adobe-ims (100.4.0)

Erwartete Ergebnisse:

Das Upgrade von Version 2.4.4 auf 2.4.4-p1 führt zu den richtigen Paketen (Modulen) für Version 2.4.4-p1.

Tatsächliche Ergebnisse:

Während des Upgrades von Version 2.4.4 auf Version 2.4.4-p1 werden diese Pakete (Module') herabgestuft. Diese Meldungen können jedoch ignoriert werden und die Funktionalität ist davon nicht betroffen.

Szenario 2

Zu reproduzierende Schritte:

Wenn 2.4.4 Händler die composer update -Befehl, dann dieselben Pakete (Module), die oben unter Szenario 1 erhalten Sie ein Upgrade auf ihre neueren Versionen, die nur mit Version 2.4.5 kompatibel sind und nicht mit Version 2.4.4 verwendet werden sollten.

Erwartete Ergebnisse:

Das Upgrade von Version 2.4.4 auf 2.4.4-p1 führt zu den richtigen Paketen (Modulen) für Version 2.4.4-p1.

Tatsächliche Ergebnisse:

Pakete (Module) werden nach der Aktualisierung von Version 2.4.4 auf Version 2.4.4-p1 heruntergestuft.

Problemumgehung 1: Patch

Der Patch ist an diesen Artikel angehängt. Scrollen Sie zum Herunterladen nach unten zum Ende des Artikels und klicken Sie auf den Dateinamen oder auf den folgenden Link: Herunterladen ACPLTSRV-2017-fix.sh.zip

Kompatible Adobe Commerce- und Magento Open Source-Versionen:

Der Patch wurde für erstellt:

  • Adobe Commerce in Cloud-Infrastruktur 2.4.4
  • Adobe Commerce vor Ort 2.4.4
  • Magento Open Source 2.4.4
NOTE
Der Patch ist nicht mit anderen Adobe Commerce- und Magento Open Source-Versionen und -Editionen kompatibel.

Anwenden des Pflasters

Verwenden des angehängten Bash-Skripts ACPLTSRV-2017-fix.sh.zip als Behelfslösung für dieses Problem.

Genaue Anweisungen zur Verwendung des Skripts:

In Adobe Commerce zur Cloud-Infrastruktur:

  1. Herunterladen der Bash-Skriptdatei ACPLTSRV-2017-fix.sh zum lokalen Checkout Ihrer Cloud-Codebase.
  2. Bash-Skriptdatei ausführen ACPLTSRV-2017-fix.sh , um die Composer-Dateien lokal zu ändern.
  3. Fügen Sie die geänderten Composer-Dateien hinzu und übertragen Sie sie in Ihr Git-Repository.

Auf Adobe Commerce oder in der Magento Open Source vor Ort:

  1. Bash-Skript platzieren ACPLTSRV-2017-fix.sh im root Ordner Ihrer Adobe Commerce/Magento Open Source 2.4.4-Installation (derselbe Ordner wie der composer.json).

  2. Bash-Skript mit einer apply -Argument zum Sperren der betroffenen Pakete (Module) auf ihre 2.4.4-Versionen:

    code language-bash
    sh ACPLTSRV-2017-fix.sh apply
    
  3. Führen Sie Composer aktualisiert aus, um die gesperrten Pakete (Module) zu installieren.

  4. Sobald Sie auf 2.4.5 oder 2.4.4-p1 aktualisieren können, führen Sie das Skript mit einem rollback Argument:

    code language-bash
    sh ACPLTSRV-2017-fix.sh rollback
    

    Das Überspringen dieses Schritts führt zu Aktualisierungsfehlern aufgrund von Anforderungen an in Konflikt stehende Pakete (Module).

  5. Nach Abschluss der oben genannten Schritte können Sie mit der Aktualisierung beginnen.

Problemumgehung 2

Die zweite Lösung für dieses Problem besteht darin, die composer update -Befehl ohne Argumente.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a