Zugriff auf Adobe Commerce im Cloud-Repository nicht möglich: Fehler 403 Verboten oder 404 Nicht gefunden bei der Bereitstellung

Um Adobe Commerce-Bereitstellungsfehler wie 403 Forbidden oder 404 Not Found zu beheben, rufen Sie gültige Autorisierungsschlüssel ab und stellen Sie sicher, dass sie in der env:COMPOSER_AUTH-Variablen und der auth.json-Datei korrekt angegeben sind.

Hinweis: Nur gültige Autorisierungsschlüssel zu haben, garantiert nicht den Zugriff auf den Code. Wenn ein Problem mit der Rechnungsstellung auftritt oder Ihr Vertrag abgelaufen ist, verlieren Sie den Zugriff auf den Code und die Möglichkeit, Support-Tickets einzureichen.

Beschreibung description

Umgebung

Adobe Commerce on Cloud Infrastructure-Versionen 2.2.x, 2.3.x und 2.4.x

Problem/Symptome

Bei der Bereitstellung von Adobe Commerce in der Cloud-Infrastruktur kann es zu Fehlern kommen, die darauf hinweisen, dass der Zugriff auf die Repository-URL nicht möglich ist, was zu Bereitstellungsfehlern führt. Im Bereitstellungsfehlerprotokoll in der Projekt-Benutzeroberfläche wird eine Fehlermeldung wie die folgende angezeigt:

Auf die URL "https://repo.magento.com/archives/magento/magento-cloud-configuration/magento-magento-cloud-configuration-x.x.x.x.zip" konnte nicht zugegriffen werden: HTTP/1.1 403 Verboten

ODER


Die Datei "https://repo.magento.com/archives/magento/module-customer-segment/magento-module-customer-segment-x.x.x.x-patchY.zip" konnte nicht heruntergeladen werden (HTTP/1.1 404 Nicht gefunden)

(Klicken Sie auf das Fehler-Symbol in der Projekt-Benutzeroberfläche, um das Protokoll anzuzeigen.)

Ursache

Die Hauptursache dieser Fehler sind ungültige oder falsch angegebene Autorisierungsschlüssel. Dies kann aus folgenden Gründen passieren:

  • Verwenden von Schlüsseln, die von einem freigegebenen Konto generiert wurden
  • Lizenzwiderruf aufgrund von Zahlungsproblemen
  • Die konfigurierten Schlüssel wurden aus dem Konto gelöscht
  • Verwenden verschiedener Authentifizierungsschlüssel in env:COMPOSER_AUTH und auth.json, was zu Berechtigungskonflikten und Paketerstellungsfehlern führen kann
  • Die Berechtigung für Adobe Commerce wurde in ein anderes Konto (MAGE-ID) verschoben, während die Umgebung weiterhin Composer-Authentifizierungsschlüssel verwendet, die unter dem vorherigen/nicht mehr unterstützten Konto generiert wurden.

Hinweis: Wenn dies auf ein Problem mit der Rechnungsstellung oder einem abgelaufenen Vertrag zurückzuführen ist, wenden Sie sich an Ihr Adobe-Accountteam, um weitere Informationen zu erhalten. Nach der Reaktivierung Ihrer Lizenz werden Ihre Support- und Bereitstellungsberechtigungen wiederhergestellt.

Lösung resolution

Bevor Sie beginnen: Stellen Sie sicher, dass Sie Composer-Authentifizierungsschlüssel verwenden, die unter dem (derzeit ) Adobe Commerce Konto generiert wurden. Unter einem früheren oder nicht mehr unterstützten Konto generierte Schlüssel funktionieren nicht.

Schritt 1: Neue Authentifizierungsschlüssel generieren

  1. Wenden Sie sich an den Adobe Commerce-Lizenzinhaber, um neue Authentifizierungsschlüssel zu generieren, wenn Sie Schlüssel verwenden, die unter einem freigegebenen Konto erstellt wurden. Wenn Ihre Lizenz aufgrund von Zahlungsproblemen zuvor widerrufen wurde und seitdem verlängert wurde, müssen Sie
    Neue Authentifizierungsschlüssel generieren.
  2. Wenn sich der Kontoinhaber nicht bei anmelden kann
    Adobe Commerce Marketplace,
    Senden eines
    Support-Anfrage
    über Adobe Experience League.
  3. Wenn sich der Kontoinhaber anmelden kann, überprüfen Sie, ob
    MAGE ID
    ist mit der richtigen E-Mail-Adresse verknüpft. Wenn die Verknüpfung falsch ist, öffnen Sie ein Marketplace-Support-Ticket über
    Kontaktieren Sie uns,
    oder per E-Mail
    Commerce Marketplace-Support
    um ein Update anzufordern.

Schritt 2: Aktualisieren der Composer-Authentifizierungskonfiguration

Fügen Sie die Authentifizierungsschlüssel zur env:COMPOSER_AUTH hinzu oder überprüfen Sie, ob die richtigen Werte bereits konfiguriert sind. Stellen Sie sicher, dass die Werte auf Projektebene, Umgebungsebene und in der auth.json (falls vorhanden) konsistent sind. Weitere Informationen finden Sie Vorhandenes System vorbereiten.

Schritt 3: auth.json aktualisieren oder entfernen

Wenn Sie die Variable env:COMPOSER_AUTH verwenden, empfiehlt Adobe, auth.json aus dem Projekt zu entfernen, um widersprüchliche Anmeldeinformationen zu vermeiden. Wenn Sie die Datei beibehalten, stellen Sie sicher, dass sie die richtigen Authentifizierungsschlüssel enthält.

Melden Sie sich bei dem Computer an, auf dem sich Ihre Adobe Commerce on Cloud Infrastructure SSH-Schlüssel befinden, und melden Sie sich dann bei Ihrem Projekt an:

magento-cloud login

Erstellen Sie eine Verzweigung, um die Konfiguration zu aktualisieren (z. B. auth):

magento-cloud environment:branch auth

Öffnen Sie im Projektstammverzeichnis auth.json in einem Texteditor und aktualisieren Sie ihn nach Bedarf:

{
  "http-basic": {
    "repo.magento.com": {
      "username": "<public_key>",
      "password": "<private_key>"
    }
  }
}

Schritt 4: Änderungen übernehmen und bereitstellen

Speichern Sie Ihre Änderungen, übertragen Sie sie dann in das Repository:

git add -A
git commit -m "<message>"
git push origin master

Überwachen Sie den Bereitstellungsstatus in der Projekt-Benutzeroberfläche und bestätigen Sie, dass die Paket-Downloads erfolgreich abgeschlossen wurden.

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