Die Neubereitstellung der Umgebung ist fehlgeschlagen oder der MySQL-Server ist verschwunden.
Dieser Artikel bietet eine Lösung für Adobe Commerce-Probleme (alle Bereitstellungsmethoden), bei denen der Ausfall des für MySQL zugewiesenen Speicherplatzes zu stecken gebliebenen Bereitstellungs- oder Datenbankverbindungsfehlern führt.
Beschreibung description
Umgebung
Adobe Commerce On-Premise und Adobe Commerce on Cloud Infrastructure (alle Versionen)
Problem
-
Der Bereitstellungsprozess schlägt mit dem folgenden Fehler im Bereitstellungsprotokoll fehl (Befehlszeile und Benutzeroberflächenprotokoll):
code language-none Re-deploying environment abcdefghijklm-master-7rqtwti E: Environment redeployment failed -
Adobe Commerce antwortet mit dem Fehler 503, und die folgende Fehlermeldung wird in den Anwendungsprotokollen angezeigt:
code language-none SQLSTATE[ HY000] [ 2006] MySQL server has gone away -
Wenn Sie eine Verbindung zu einem MySQL-Server herstellen, wird die folgende Fehlermeldung angezeigt:
code language-none ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0 "Internal error/check (Not system error)"
Ursache
Für alle Adobe Commerce auf Cloud-Infrastruktur-Starter-Planarchitekturumgebungen und Integrationsumgebung der Adobe Commerce auf Cloud-Infrastruktur-Pro-Planarchitektur SSH auf die Umgebung und führen Sie den Befehl aus:
magento-cloud db:size
[ Sie in der Staging- oder Produktionsumgebung der Pro-Architektur SSH in die Umgebung ] und führen Sie den Befehl df -h | grep mysql aus. Das Ergebnis sieht in etwa wie folgt aus:
sxpe7gigd5ok2@i-00baa9e24f31dba41: $ df -h | grep mysql
/dev/xvdj 40G 7.4G 32G 19% /data/mysql
Lösung resolution
Um das Problem zu lösen, müssen Sie mehr Speicherplatz für MySQL zuweisen
Für alle Starter-Architektur- und Pro-Architektur-Integrationsumgebungen erfolgt dies in der .magento/services.yaml-Datei, indem der mysql: disk: erhöht wird. Beispiel:
mysql:
type: mysql:10.0
disk: 2048
Siehe den Artikel Einrichten des MySQL-) als Referenz.
Um diese Änderungen an der Staging- oder Produktionsumgebung der Pro-Architektur vorzunehmen, müssen Sie ein „SupportTicket erstellen. In der Regel müssen Sie sich jedoch nicht mit dieser Aufgabe in der Staging-/Produktionsumgebung der Pro-Architektur befassen, da Adobe Commerce diese Parameter für Sie überwacht und Sie benachrichtigt und/oder vertragsgemäß Maßnahmen ergreift.
Anwenden der Änderungen
Nachdem Sie die .magento/services.yaml geändert haben, müssen Sie einen Commit ausführen und Ihre Änderungen pushen, damit sie angewendet werden. Mit der Push-Benachrichtigung wird der Bereitstellungsprozess Trigger.