Bereitstellungsfehler, wenn keine Patches gefunden wurden
Dieser Artikel bietet eine Lösung für das Problem, dass beim Upgrade Ihrer Instanz die Bereitstellung fehlschlägt und ein Fehler in den Bereitstellungsprotokollen angezeigt wird: Nächste Patches wurden nicht gefunden: MDVA-XXXXX, ACSD-XXXXX. Bitte überprüfen Sie mit dem Befehl „status“ die Verfügbarkeit dieser Patches für die aktuelle Magento-Version.
Betroffene Produkte und Versionen
- Adobe Commerce auf Cloud-Infrastruktur, alle unterstützten Versionen.
Problem
Beim Aktualisieren von Adobe Commerce tritt ein Fehler auf: Die nächsten Patches wurden nicht gefunden.
Ursache
Zuvor angewendete Patches für Ihre ältere(n) Version(en) sind nicht anwendbar oder nicht mehr für Ihre neue Version verfügbar.
Lösung
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Überprüfen Sie Ihre
.magento.env.yaml
unter dem Abschnitt QUALITY_PATCH, z. B.code language-yaml QUALITY_PATCHES: - MDVA-XXXXX - ACSD-XXXXX
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Suchen Sie die Patch-IDs in den Versionshinweisen zu Qualitäts-Patches, um zu überprüfen, ob jede dieser IDs auf die neue Version von Adobe Commerce angewendet werden kann, auf die Sie ein Upgrade durchführen.
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Wenn der Patch nicht für die neue Version von Adobe Commerce gilt, auf die Sie ein Upgrade durchführen möchten, entfernen Sie die Patch-ID aus der
.magento.env.yaml
. -
Nachdem Sie alle durch den Fehler angegebenen Patch-IDs überprüft haben, übertragen Sie die Änderungen und stellen Sie sie erneut bereit.
Verwandtes Lesen
- Patches anwenden in Commerce im Handbuch zur Cloud-Infrastruktur.