Bereitstellungsfehler, wenn keine Patches gefunden wurden

Dieser Artikel bietet eine Lösung für das Problem, dass beim Upgrade Ihrer Instanz die Bereitstellung fehlschlägt und ein Fehler in den Bereitstellungsprotokollen angezeigt wird: Nächste Patches wurden nicht gefunden: MDVA-XXXXX, ACSD-XXXXX. Bitte überprüfen Sie mit dem Befehl „status“ die Verfügbarkeit dieser Patches für die aktuelle Magento-Version.

Betroffene Produkte und Versionen

Problem

Beim Aktualisieren von Adobe Commerce tritt ein Fehler auf: Die nächsten Patches wurden nicht gefunden.

Ursache

Zuvor angewendete Patches für Ihre ältere(n) Version(en) sind nicht anwendbar oder nicht mehr für Ihre neue Version verfügbar.

Lösung

  1. Überprüfen Sie Ihre .magento.env.yaml unter dem Abschnitt QUALITY_PATCH, z. B.

    code language-yaml
    QUALITY_PATCHES:
     - MDVA-XXXXX
     - ACSD-XXXXX
    
  2. Suchen Sie die Patch-IDs in den Versionshinweisen zu Qualitäts-Patches, um zu überprüfen, ob jede dieser IDs auf die neue Version von Adobe Commerce angewendet werden kann, auf die Sie ein Upgrade durchführen.

  3. Wenn der Patch nicht für die neue Version von Adobe Commerce gilt, auf die Sie ein Upgrade durchführen möchten, entfernen Sie die Patch-ID aus der .magento.env.yaml.

  4. Nachdem Sie alle durch den Fehler angegebenen Patch-IDs überprüft haben, übertragen Sie die Änderungen und stellen Sie sie erneut bereit.

Verwandtes Lesen

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a